What is happening with my Z axis?

I have a MORN dual head 150/80 watt CO2 laser. My Z axis can move about 20 inches vertically. I have tried several times to use the Z axis offset and EVERY time it will move the table up until it crushes the laser nozzle into the wood. I have tried negative and positive numbers. I try it with a 1 mm step which, logically, it should just move it 1 mm, but it does not stop at 1mm. It locks up and crushes the nozzle and I have to shut it down and manually pull the belts at the bottom to move the bed lower and then try and get it level. What could possibly be wrong with how this is working?

Has the Z axis been homed before that?

If not, selecting Relative Z Moves Only should tame the beast.

The firmware sets the Z axis position to something like 10000 mm before homing, so when the cut calls for a 1 mm offset, the platform must move 9999 mm to get there. Nobody expects that!

Homing the axis sets Z=0 at the level set by two firmware offsets (which Ruida may name slightly differently in the LightBurn Machine Settings):

  • Home Offset
  • Focus Distance

Both are applied to set the position as a result of the homing process. The Home Offset value sets the distance the axis retracts after tripping the home / limit switch, then the Focus Distance value puts more distance under the nozzle. The final result is Z=0 with the lens focused at the material surface (or somewhere close, if you’ve set the values appropriately).

If you find the Z Offset distance works “backwards”, flip the Z axis Invert Keypad Direction option in Vendor Settings. The intent is for the “up” arrow to increase the distance between the lens and the platform, which will move the platform down. With that set properly, positive offsets will (uh, should) increase the distance and negative ones will decrease it.

1 Like

No big red Emergency STOP switch?

Yes - I have that but it does not stop it from crushing into the wood. Flipping the off switch does. It is about the same distance to reach as the red button on top.

Interesting info but I have no idea where this would be. I turn it on and it moves the head to 0,0 and back to where it was the last time I cut it off. The z value starts off at 3,000 which is actually not 3,000 millimeters - it says mm but in reality it is not close. The focus is not automatic - I move the Z axis manually to get the focus set. When it is cutting metal it does have an autofocus function but I don’t use it on metal often. So, I am not sure - is that something in the controller panel or in the Lightburn software?

Is there a z-probe on the laser head to find zero?
I’m not familiar with this machine.
Does it use a Ruida Controller?

Until the controller goes through a Home cycle, it has no idea where the Z axis is. The 3000 value is the default “enough to cover any situation” distance from the Z=0 position; after you finish manually homing the platform, the Z position might be 2995.

So the Z offset applies to the absolute position, not the manual position: a 1 mm offset moves the platform nearly 3 m.

Using Relative Z Move Only should solve the problem for LightBurn, but the controller must home the axis to the proper location using the focus pen (or whatever they call it) so its firmware offsets and distances would apply.

Thanks - I am gradually piecing this together but still do not understand the location of “Home” for the Z axis. Since I need to move it there manually- what observation am I looking for to identify the “home” position? I have had this laser almost 5 years. Back to your statement -

So the Z offset applies to the absolute position, not the manual position: a 1 mm offset moves the platform nearly 3 m.

Do you mean 3 Meters or 3 millimeters?

If I change to a different lens with a different focal length do I have to redo the “Home” manual setting?

It seems to remember the last location so once I set it - should it remember it? Also, when i use the Lightburn command - “Go to home” does that take it to just the X-Y home or the X-Y-Z home?

Thanks - I would live to be able to use the moveable platform other than raising and lowering it manually to adjust focus. I think it could help me find the best focal distance if I could programmatically tell it to step through a range of positions and print a set pattern and let me find the thinnest line:).

By definition, the Home position of an axis is referenced to a Home switch: the controller must run the axis until the Home switch trips to set the Home location for that axis. The controller applies various offsets and distances defining how the coordinate axis maps onto the known physical location, so that the resulting coordinate value may not be 0.0 mm at the Home position.

However, until the controller runs through that process, it uses a default value for the axis position that does not correspond to reality: your controller uses 3000 mm, mine uses 10000 mm. This is what I see after turning it on:

The X and Y axes are homed, the U (Z in normal CNC-speak) is not homed and shows the default 10000 mm position. This means the controller assumes the U axis is 10 meters away from the Home position, because it does not know any better.

Moving the axis by hand or with the jogging controls does not affect the homed status. All it does is move the axis and change the default “not homed yet” coordinate. Moving the platform up reduces the coordinate value:

Moving the platform down increases the value:

But Z=0 remains about 10 m away, far below floor level.

So when you jog the Z axis to put the laser in focus at the surface, the position changes from your controller’s default 3000 mm (not 3 mm!) to, let’s say, 2995 mm, which means when LightBurn asks the controller to move to a small offset from Z=0, it will (try to) move by nearly 10 feet, because it doesn’t know where the platform really is.

This is, as you’ve discovered, surprising.

There does not seem to be any way to tell a Ruida controller “I have manually set the focus poInt, so you should set Z=0 right here, right now. Make it so.” Telling LightBurn to use a relative Z offset means it will move that (small) distance relative to the current position.

Telling the controller to run its auto-focus routine homes the Z (or U, whatever) axis by tripping the focus pen on whatever surface happens to be underneath it, wherever the laser head may be:

Which is why the controller does not automatically home the Z axis when it starts up: it does not know what’s underneath the pen. Until you have arranged things properly and triggered the auto-focus routine, the Z axis will remain un-homed.

After running the auto-focus routine, which is a process identical to homing the X and Y axes, the controller can then assign Z=0 to that physical location:

I have not applied any firmware offsets, so the Home coordinate is Z=0.

After homing, LightBurn can apply a 3 mm (or whatever) offset: the controller will move 3 mm away from Z=0 by moving exactly 3 mm, with no surprises to anybody.

The Z axis homing depends only on where the switch trips. I think you can set the controller’s Focus Distance to match each lens focus point’s offset from the switch-defined position, but IMO moving the pen to make the answer come out right with no controller tweakage seems easier.

Or just put the test piece on a slope so the distance ranges from “too far” to “too near”, burn a line, and measure the distance for the best focus. Whatever works!

Thank you so much for an excellent explanation. I am including a few photos to see if any of this helps you tell me the first step to do


This is from the controller on the laser.

I want to see if this is where I do this Home the Z axis from

Not sure what happens next or if I should do anything here.

This is the photo of my laser head near the upper right hand corner.


So, thoughts on how to first set the Z axis home. Also, should I reset the X-Y axis home position as well?
Thanks
George

Yes, as far as I can tell it uses the Ruida controller but I do not know if it should have the firmware upgraded or if there is new software for the controller. I am not aware of any probes that help find zero in any axis. When I turn it on it goes to the upper right hand corner and then returns to the previous origin location. MORN makes a large variety of large industrial lasers. Mine is one of the smallest they make as a dual head 150/80 watt laser. Built like an industrial machine as well. I am not sure how to get anything like version number for the Ruida controller.

You don’t need to home the Z if you enable ‘Relative Z moves only’ in the Edit > Device Settings window (upper right).

With that setting enabled, LightBurn assumes zero Z is whatever height the laser was when the job started, and will only move relative to that starting height - this is the simplest way to use the Z features.

Poke around in that corner (or along the rear and right sides) and you’ll (probably) find a pair of chunky switches on the frame that contact the gantry and spindle carrier. Given that you have a real metalworking machine, they might be real mechanical switches, but they could be inductive sensors similar to this one in my OMTech:

So it’s homing to the right-rear corner and the position of the laser head suggests the coordinates increase leftward and forward from that corner. I do not know if the controller applies an offset to make the home position 10000, rather than 0, or if it simply does not update its I-am-not-homed-yet default of 10000, but it is definitely going through the proper homing motions.

Aaaaand I betcha that chunky dingus hanging on the left of the laser head is the switch intended for auto-focusing on the Z axis, similar to the fragile red “focus pen” on my OMTech in the picture above.

Bearing in mind that Hell hath no fury like that of an unjustified assumption:

Clear the platform and select the X Reset button. That should home the X axis against the right side, reset the X position to 0.0, and do nothing else.

If so, then repeat for the Y Reset button.

If you’re flushed with success, put a metallic sheet under what I assume is the auto-focus dingus, select the Reset Z button, and watch what happens. If the platform goes up, taps the dingus, retracts a bit, and the Z position reads 0.0, then we can put some assumptions to rest.

If the metallic sheet worked, try Reset Z again with a nonmetallic sheet and your hand ready to slap the Big Red Button. If it does the Z home dance again, you have a genuine mechanical switch suitable for laserable materials.

Ruida controllers (seem to) use Z and U interchangeably; mine has setup parameters for both, but only the U axis has motor control / home terminals. On your machine, perhaps the U axis is intended for a rotary?

Report back! :grin:

I have an idea (based on the opposite of my previous assumption).
Please post a pic of the motors driving the z axis and Either the Y or X axis.

I’m wondering, with the heft of the 2-headed machine if you have feedback motors in X and Y and something different in the z. Please also share pics of model numbers for the motors and the controllers they hook up to (where possible).

It’s a bit of a far-flung guess but the two headed machine could need feedback motors so the controller knows where the heads are… if the z is expected to also have positioning and if it has failed or been misplaced it wouldn’t stop moving until it registered motion. Ahhh… it’s a guess.