What is this..cannot delete file because it is open in COM surrogate

Must be simple but I cannot delete any lbn files as I get this Open in COM surrogate. I thought maybe it was just because Lightburn is open but nope. Gotta be an easy one but I don’t even know who this COm Surrogate is and why he is open…:slight_smile:

What version of LightBurn?

Update: Found this…where Oz says:

MOST recent version…I quit windows explorer but no help. Got to be something stupid I am missing.
I think it started after the previous update that allowed us to now see Lbn file previews. I kind of thought it might be related to the thumbnail preview but wasn’t sure. Never had it before but I delete lbn files only now again.
It wasn’t an issue a few months ago but has been lately.

COM surrogate is a “container” that runs plugins for Windows File Explorer, so that if the plugin crashes it only takes the container with it, not Windows Explorer. It used to be that a badly written thumbnail viewer could crash your Windows file views, and this is how they fixed it. If it gets “stuck” on something, you can log out and log back in again, or restart Windows, and that should clear it. I’ll double check the thumbnail tool to make sure I’m not doing something dumb and leaving files open.

Yah nothing has helped so far…close it out…reboot…sign in/out etc just giving same error

And today it is working finally. No idea why…have no clue…just started working. Wish I could say it was because I rebooted or closed and reopened LB but have done that multiple times before. Just started todays work and thought I would check and it no longer gives me the error so…

O.K…so there is something buggy in this preview code. It started doing it but this time won’t delete because the file is open in windows explorer accept…no it isn’t.
I just decided to delete some files today by opening the folder…LB is closed…nothing open…well accepth Microsoft Edge and now again error upon delete.

I’ve occasionally seen this behavior as well. Nothing open on the machine, but can’t delete a file as it’s showing open in COM surrogate. If I go into task manager and kill the COM surrogate process and let it respawn, then I can delete the files. Started seeing this behavior with I believe 0.9.12 or 0.9.13

Glad I’m not alone…started thinking it was me🤪

so this needs to be fixed as it is super annoying and makes editing down files slow. I can kill COm Surrogate in Task Manager but as soon as it reboots I can’t delete files. I get a window of about 30 seconds before it reboots it again and same old error…:frowning:

I’ve looked, and I can’t see anything that I can fix, and you’re the only one having this problem consistently, so I have to assume it’s something on your computer, not something in my code, or everyone would have this instead of just you.

Open a terminal command window by clicking Start, then typing CMD and pressing enter.
In the command shell, type these lines one at a time, pressing Enter after each one.

cd \Program Files\LightBurn
regsvr32 /u LBShellExtThumbnailHandler.dll

That will unregister the thumbnail previewer from your system and won’t lock your LightBurn files any more.

Nah thats worse…I need to see the files in a preview so I will just live with the glitch. I have LB on another computer I use for design mainly and only have LB on there for previewing artwork before sending downstairs. i will see if it has the same glitch or not. I just do not save lb files on there but I will and see.
Oh well thanks…

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.