Whats going on here? (picture)

This was scanned all at once.
If it’s missed steps (physically) how come everything above this is back to normal and dead on?

I ran one before this and it was fine but I have experienced this exact thing on etching other jobs but it’s random.

2 weeks old Red/Black 80w Omtech machine w/
Ruida controller


What version of LightBurn are you using? How did you run this job when this happens, from pressing ‘Start’ or did you ‘Send’ the file and run from the controller? What exact model Ruida controller is installed in this system (silver sticker on control box inside metal cabinet)? What firmware is on that controller? You should see that reported on the HMI key panel when you first power the laser.

Troubleshooting steps…, I might check to see if you get similar results when using RDWorks to produce this job using the exact same settings. I would also drop back to LightBurn version 9.20 and reproduce the same file to run from that version to see if the results are different. These comparisons could yield indications as to what to check next. :slight_smile:

LB Version: 0.9.24
Controller: RDC6442G-B (EC)
Firmware: RDC_V8.00.65

First exact thing I engraved was fine - did well. I wanted it to be a bit deeper so I bumped the power from 35% - 40% and sent the job - it happened. Then I ran the file again from the controller to see if the issue was repeatable. It was and did the exact same thing.
Changed power to 37% sent it and ran from controller perfectly fine tested 4 times.
Since I have been experimenting the power changing back to when it missed up etc.
Hasn’t happened again - yet…

I’ve only been cutting on it for 2 weeks here and there but with just a couple etching jobs before this and it did do it on the first ever etching job I ran.

Thank you for this update. We are trying to track down as much as possible to help the dev team sort this.

Did you get a chance to try this? I am curious to see what results you get. Thanks. :slight_smile:

I haven’t dropped down because I haven’t had it happen again but I’m about to be engraving A LOT so it’s bound to come up. If/when it does I will save the output file and share.
I am keeping a close eye each time I etch so that I can better discover what might be triggering this and I will share that as well. W/E it is - is something abstract.

After that I will try RD w/ verbatim settings if need be.


Took 6hrs till 3am last night but I got it to do it again.
I have emailed a zip file to LB support email address.

Thank you for providing, I found your email and will add to the collection for the dev team’s review. :slight_smile:

If a work around is found until a fix is I could really use it. I am in serious trouble with orders. Hence working on it for 6hrs till 3am lastnight.

I believe you should be able to drop back to pre version 9.21. Grab 9.20 from the Older Version (< click that) repository and you should be able to run without issue. Please try that and confirm.

Ran file from 9.20 does the same thing but the name/number offset from center is more to the right, logo still burning dead on as it should.

Sorry, ran what file? The previous file generated with the new file format, LBRN2? I would like you to try and generate that same file anew, using 9.20, if you will, to see if you are getting similar results. We had not seen anything like this reported prior to the release of 9.21, so wanting to double-check.

Thank you kindly for helping us track this down. :slight_smile:

All below has been performed under v9.20
Ran the original 9.21 problem file in 9.20, problem persists.
Pulled different Name/Numbers that use different fonts etc over from art board I had and tried running it, problem persists.

Copied/Pasted art board contents to a new file and did the follow…
Deleted the Bombers Logo I had been using from the art board…
Run just the Number/Name, it’s correct/centered.
Replace the Bombers logo with another logo, name/number are correct/centered.
Grab the other Bombers Logo from the art board fill it same color (14) and run, name/number are correct/centered.
(Using v9.20) Imported (Ai) the Bombers Logo as I had done on the original file that was giving me the problem, but it didn’t cause the offset, it was fine.
Deleted Name/Number, used one from the art board as before, edited it to have same Name/Number and all same settings as the one I deleted had, it came out fine.

Would it be beneficiary to you team if I revert back to v9.21 and try the same steps above to compare?

At this point I have recreated all my steps from 9.21 and nothing is making it bug out, it’s running fine.
It will only run bad in 9.20 if I directly open and run the 9.21 file that it was missing up on.

I will stay with 9.20 and report back if it happens.
If I can provide anything to help please let me know.

Thank you again. At this point, stay with what is working. :slight_smile:

But…if you do want to do one more test… (:wink:)

Copy the failing .LBRN2 file you generated in 9.21, and simply rename the extension to LBRN (remove the number “2” at the end). Then, open that new file you copied and try and run that one.

1 Like

Sorry, I am not seeing any file with the extension of “.LBRN2” other than one file which was Step5 from the zip package I sent and I have no idea how/why it was saved as LBRN2 and zero of my other files are.

I ran it after changing its ext to “.LBRN”. Still offset/bad.

Got anything else I can try?..

Not at this point, thank you. Will let you know. :slight_smile:

The LBRN2 extension is used for the new LightBurn file format discussed as the “First and foremost…” announcement in the video below. I was wanting to check the new file version, run with an older version, only changing the extension name, so thank you for that.

We troubleshooting your problems or mine?

Nice video BTW, WATCH 3/4ths of it so far.

1 Like

I would define it as “ours”. :slight_smile: You are able to continue to use the earlier version without issue, correct? Did I misunderstand?

I found it slightly humorous.

Might be irrelevant but I was running this LB file on a K40 w/ a Mini Gerbil. When I went over to the Ruida I just swapped to it in devices and mirrored the objects to flip them back right.

Hey Eric (@dbtoutfit),
It sounds like you don’t have this totally figured out yet, and it sounds like an odd error I ran into a little while ago (my part was custom text with an offset cut perimeter). Basically check your fill settings, advanced tab, and see if “flood fill” is on. That caused a odd left/right shift in certain bands/layers like you are seeing.

  • With that setting on I noticed that in the preview when filling in it would do a certain band of the design, then skip others, and then come back to fill in little areas. I think it was trying to limit passing over empty space, so it would jump over that and come back. It would do this in real life too, but what was not in the preview was that it would shift certain sections off to the side. For mine this was worst on the cut layer because it would cut the text in half.
  • I know flood fill has a plan and has it’s place, so jumping around is fine; but it is the offset cuts part (especially that does not show in the preview) that seems like at true program error/issue.
  • What was somewhat more confusing, if I remember this right, when I did a single part it worked fine. But when I went to make multiples it would start to do this odd cut order, and shifted the cut to the side of the fill (every time the same).

@Rick - Sorry I meant to let you guys know about this, but it came at a really busy transition/move and I never made it back to this. Is this something you are aware of or no? If not, does this suffice or do you want me to make another error/request post?

One other note - this was happening in version 0.9.21, but I haven’t run it in a newer version so this might have gone away?

Hope that helps one way or another!

1 Like