Where can i enable the z-axis?

Hello, Starting to work with LB, but where can i enable the Z-axis ?
Its not in the “device settings”, but when i turn off “Continuous Jog” i can manual move Z-axis. also there should be a z-offset in the layer “cut settings editor”, nothing there, my machine has switches om all axis and homing on machine startup…

You may have missed it in device settings:

Also, the cut settings for Z offset:

Hello, thanks for responding,
But no i didn`t, there is no option for it…

Ah. Didn’t realize you were on a Top Wisdom controller or how that changes things.

ok, dont know howto respond to that, does that meen it will not work atall with LB ?

Not necessarily. It just means I’m not familiar. Will need someone who knows this controller to speak up.

maybe you have directly in machine settings?

Could you please confirm your controller information?

The lightburn documentation states

“We currently support most Ruida, Trocen, TopWisdom, and GCode based controllers. Supported GCode controllers,include Grbl, Smoothieware, Grbl-LPC, and Marlin. Supported Ruida controllers include the RDC6442G/S, RDC6445G, RDC6332G, RDLC-320A, and R5-DSP. Supported Trocen controllers include the AWC708C, AWC608, and TL-3120.”

Is yours in the list?

Most of the time, Lightburn gives you the options that it can change. I would guess it doesn’t have that option or it isn’t a supported controller…


1 Like

Yes correctly its the topwishdom TL-A3, the brand is but not the type.
yeah must of the time, but not now. :slight_smile:

Found out that the TL-A3 is the upgrade of the TL410C controller.

@LightBurn , does the DSP version (was a answere on other topic) have the Z-axis for the TL410C controller of topwishdom TL-A3 , the trail version i have now its not.

hmm… no reply after 20days ?, so most of the time meens that it will not have the option for my controller. Even when its a topwishdom controller.

I looked at the TL 410 controller and it supports 3 axes. It also has the ability to ‘enable’ the Z/U/V axis via the control panel.

Have you tried to enable that axes?

Here is the PDF, I’ve renamed it to a .txt file so I could upload it…

UsersManualforTL-410LaserEngravingandCuttingControlSystem.txt (1.8 MB)

Page 81… has the gui and the explanation is on the next page or so…

Good luck…

Sorry you haven’t had much of a response that’s rather unusual.


1 Like

Thank you for replying.
The z-axis is enabled and i can use the controller buttons to lower or higher the table.
But there is no option in LB, only XY axis.

you find it in device settings

Hello, thank for replying, but please read the message`s above, there you can see a screen shot of my screen that i dont have that option.

so i ask again, have you checked if there is in machine settings?
I don’t have one but i guess that with ruida, for example, the enabling is in machine settings, maybe for trocen is the same?

Hello, There is no option to turn on/off the Z-Axis, like the XY axis its always on.

Look in ‘Edit → Settings’ and see if ‘Beginner mode’ is enabled.


Follow the suggest of @jkwilborn and make also that check