Where to post for latest version help?

edit: adding firmware version in case it can help somewhere down the road
[AUTHOR: RenShen]
[MODEL: Ortur Laser Master 2]
[OLF: 137]
[DATE:01:15:16 - Apr 20 2020]
[VER:1.1f.20170801:]
[OPT:VZD,35,254]
edit:

I haven’t used my ortur for a couple of days. downloaded the new version today.

I usually jog to my work piece then move the art work to the laser position.
so with the new version I jogged, got close and used the fire button.
could not do anything after.
hit reset.
tried again but this time I used shift-frame. it let me jog once more then froze.
reset again. move to work area, hit fire then jog. LB shows busy after I hit jog. not before.
reset again. move to work area, used shift frame several times. hit jog, frozen with busy msg.
(i am using device select to reset)
it cuts ok if I don’t use the fire button.
downgraded to .18 and issue went away

to be clear, I only had a lock up problem if i used the fire button. other wise everything was fine.

This is a bug in Ortur firmware, not LightBurn. They are aware of it and trying to figure out what is wrong.

Jogging in LightBurn sends a command to query the position of the controller (the ? command). When I send that, if it is the first command sent to the machine after power up and homing, it ignores it and hangs LightBurn, because LightBurn is waiting for a response. You can type the command manually into the console and watch it do the same thing.

it isnt happening on .18. it works fine.

The 0.19 release was partially made to address this problem because most Ortur users, myself included, have the lock problem with 0.18.

You might have a different version of Ortur’s firmware on your machine. It seems to happen much less if you use the ‘Click to Move’ button once to jog the laser somewhere into the work area, and then everything behaves for a while after that.

image

ok. thanks for the reply and suggestion. I’ll just hang with .18 until i have and issue i guess.