Which laser do I have in this screen shot I am using Sainsmart Genmitsu Jinsoku LC-40 (GRBL)

I sure hope this works as I do not understand this forum

There are a few lasers with the same LC40 model number. Can you specify which maker?

Your profile lists a Sainsmart LS40. Not sure if you’re referring to the same machine but with a typo.

I am using the LC40 from sainsmart and I am leaning toward GRBL

You will need to use the GRBL firmware if you want to connect to LightBurn. I don’t believe the mobile app firmware would be supported in any way.

If using GRBL, select the device type marked “GRBL” and not any of the variants.

Are you using LightBurn with an existing license from Emblaser?

No still on trial, What is this work area is it what is in the dimensions 395mm x 365mm

i have the same machine and these are the working dimentions i have set for GBRL LC-40

there is a phone app for proprietary software use wich is very limited, there is also the proprietary software for windows (laser engraver) same as phone but also very limited but ok for very basic engravings. also supports rotary.

what i have found best is converting the stock LC-40 to GBRL by flashing the firmware and using it in Lightburn. if you have not done that i can post a video link here on how to flash the controller to the GBRL firmware. the sainsmart site has links to this as well.

the device list shows up like this when i connected my first LC-40 to Lightburn.

Please post the link… it’s helpful to others…


here is a link to the LC-40 resource page on the sainsmart website, theres a few different options depending on the computer you are running. but all the links are here.

Well after many hours of trying to get this to work I give up, this is over my old brain the darn thing cannot comprehend. Will be having a sale next month and am going to sell the LC-40 with a laptop computer and also a 3018 CNC with its own laptop. So to all who I have spoken to been fun.

Sorry to hear that… maybe you’re trying to do too much with them too quickly…

Might sit on them a short while and be sure you want to abandon what you’ve invested in both time and money…

Whatever you decide, take care, you have our best wishes…


Thank you
This LC-40 just does not want to work and my real problem is windows will not let me doen load the firmware when I try to Copy and rename the bin file windows pops up and wants me to go to the store and get an app to open the file and I have no idea how to do that. Better to cut and run while I have my sanity.

This doesn’t sound as much like laser problems as it is Windows problems.

You should be able to right click on the file and the drop down should allow you to rename it.

Is that what you are doing?


If you’ve only been struggling for a few or many hours and giving up already, take a break.
This hobby is loads of fun. I’ve spent days at times scratching my head on things that I know should be working but for some minuet oversight on my part, things finally settle in and I get clarity.
BUT, that’s when I know to walk away. I do get frustrated at times like everyone else.
As it’s been said here I believe a few times “No one was born knowing this stuff!”.

Lots of folks here are some of the best responders to help you and me along.

Im with you Jim. Ive had it as well. I can get it to work but I am new to laser cutting. Purchased a gemitsu from sainsmart LC-40 using lightburn. Everytime i run a job, the laser will not stay powered through the entire job leaving areas that have not been cut. I have tried different settings but still no good. I have reached out to sainsmart and they sent me a new control board but that did not help. I was hoping someone can please help me. But no one seems to know. I have posted this in facebook and lightburn but no replies. Very frustrating. I understand how you feel

Are you using a separate power supply for your laser? I found out the hard way. Gotta use seperate PS… Just my 2 cents, hope you get it worked out .

Hi Ken. I have my power supply plugged into a surge protector. It’s weird I have tried everything. Every time I run a job it never fully lasers the part. I can actually see the laser light go off and come back on. I have ruined so many boards. Sainsmart is no help. I don’t know if it’s software or the laser.

Ken all the axis will continue to move just as it should but the laser power will burn then stop for a few seconds then continue to burn. have to try to rerun the job then use a knife to finish where it did not burn. I don’t know if anyone else has this issue because no one seems to have an answer. I appreciate your reply

Hello guys, here what I got. 30% & 40%. Wherever you see no burn the laser was not firing. Confused as why it burned better in the upper part of the cardboard. I’m so lost with this. Any help is appreciated. Many Thanks’