Why can't I change where the job starts from? (green dot)

I do not have any other options but “controller setting” under the start from tab. I would assume that controller setting would put the dot where I have manually set the origin on my machine, but this has not been the case. All I am trying to do is get the green dot in lightburn to match my machines origin, but no matter what I try this is not happening. For reference, I have a BOSS HP 2440.

Older Trocen controllers, like the one in your Boss HP laser, do not allow software to change the origin setting - you have to do it from a menu on the controller panel itself.

On the controller, press Menu, then choose Common Parameters Settings, then Work Mode, then Origin Mode, and choose from there.

Thank you so much!

But there is no way to have it change in Lightburn? What does changing it on the controller do for me?

do you not have “Start From” section just under the “Start” and “Run GCode” buttons? If you do, set that dropdown to User Orgin and then select one of the radio buttons in the 3x3 grid below it to change your origin.

I do, but I have no other options to change it to other than controller setting. If I go on my controller and change it, nothing happens in lightburn and my problem is still there. All I want is for lightburn to recognize my lasers origin

This post might help as it covers the history of why and how LightBurn and Trocen deal with machine origins.

You can use the search, upper-right of every page here, to look for more on the subject, as it has had many posts covering this topic.


Thanks for the input, but the OP is using a Trocen motion controller and this is not how the that control system works in LightBurn. :slight_smile:

1 Like

from what Rick posted it sounds like that controller not only does not allow LightBurn to set the origin it also does not provide where the origin is or if it does it seems LightBurn is not matching it correctly.
It does indeed sound like a pain. I don’t know the specifics of the motion hardware in that machine but if it’s just stepper motors, 3,4 and 5 axis controllers which work very well with LightBurn are generally less than $100. And since you have a LightBurn support person here, I’ll bow out. Good luck and happy burning.

1 Like

If you change the setting on the controller to be ‘Soft Origin’ it means that LightBurn (the software) dictates the starting point. This is identical to ‘Absolute Coords’.

If you change the setting to ‘Key Origin’ it means that you set the origin by pressing the ‘Origin’ key on the controller panel.

Is this not working for you?

Yes, kind of. If I have it on key origin, the origin of the project in lightburn will still be the upper right of the shapes, so it will just start the project from wherever I have they key origin set on the machine. I was looking for a way to change the origin in lightburn so that no matter where the shapes were put in the project, it would always have the origin matching the key origin on the machine. The easiest way to describe it would be with the red and green dots in lightburn. From what I understand, the red dot is the table origin, while the green dot is the project origin. I wanted a way for the green dot to always be in the same spot as the red dot, regardless of where the shapes were in the project.

That is the ‘Soft Origin’ setting on the machine. The green dot will still move, but the artwork will be output exactly on the machine where you have it in the software. Is that what you want?

Yes, that is exactly what I am looking for. When I change my machine setting to Soft origin, nothing seems to change for me in Lightburn. Is there some way to send the change of settings from the machine to the computer?

It won’t change in LightBurn because the controller doesn’t tell us which mode it’s in, but it does work.

1 Like

Okay. Thank you so much for your help.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.