Windows 10 - no com port

I am running a Dell PC windows 10. Just finished my Ortur Laser Master 2. Installed the LaserGRBL software and the VCP software 64bit. Then installed Lightburn.

When I connect I hear the chime.
I can see the device in the device manager under the Universal Serial Bus devices. I do not have a com port to connect to… Not in either software. I have read a number of forums and post but nothing is working…

On a side note - I have an older computer with Windows 10 that I performed the same tasks.
The laser will connect and operate, so I know the laser works. Just not with my newer computer.

Any help is appreciated.

I have no experience with this, but this came up in a search:

  1. Open Device Manager .
  2. Click on Action in the menu bar and select Add legacy hardware > Next .
  3. Select Install the hardware that I manually select from a list (Advanced) and click Next .
  4. Scroll down, then select Ports (COM & LPT) and click Next .
  5. Select the Manufacturer accordingly and click Finish .

Thank you, I tried that… It shows the com port in the drop down but there is no connection to the USB that the laser is connected to… I tried the standard port types then the STMicroelectronics but neither worked. In both cases there was a yellow yield sign saying the device wasn’t working…

The only other reference I could find did relate to Dell computers. It said to enter the BIOS and make sure that com ports are enabled. You could try that.

Grant, thanks for staying with me Bro!.. They are both Dell’s…

Let add some more clues.
Dell 1 is an older AMD processor PC. It had a hard drive failure and i put a solid state drive in and loaded windows. It is primarily used for my CNC which is run by an Arduino Uno with a shield to drive the stepper motors. It also has Benbox and T2 laser software from an earlier laser engraver.

Here is what the Com ports and detail setting look like.

Dell 2 is a newer machine… Intel I7 processor. It has a lot of 3D printer stuff on it, and software to program my drone. (CLUE)… When I add legacy software to get the com ports to show up it looks like this. (at the bottom of the pic you can see the laser is plugged in and under the USB port.

Here is where I think things are going south… when you look at the device details you see this. (pic in next post)

Well, it won’t let me paste the final clue!! The value in the details tab is Betaflight F4. That is the name of the control board for my drone… not sure why it says that…

When I plug in the laser it chimes and auto homes… but I cant make it do anything. On computer 1 it will load and cut parts… At this point its the challenge more than I need this computer to connect to the laser…

Thanks for your interest.

Because it recognised the chip.

you should be able to find the USB identifier, which will tell you the maker and type of serial chip. Download their driver, install it, delete all com devices and reboot, it should find it and apply the correct driver.

Most often these problems occur due to naive hardware suppliers forcing a driver that’s not the right one for the job.

1 Like

I agree with Bo. You have a driver issue. If you open the listing for the Com4 port, what happens when you tell it to update the driver? If that does nothing, as Bo said, if you can find the manufacturer of the serial chip, you may be able to get a driver from them. If Windows doesn’t tell you the manufacturer, go to and download and install the Advisor. Run it, and it will likely tell you the manufacturer of the serial chip.

Guys, thanks for your help… Problem solved… Bo was right, the system had picked what it thought was the best driver for the laser.

For future generations here is what I did.

Removed the legacy hardware as suggested ( I had manually added Com & LPT ports through the Action menu in the device manager).

To change the driver I plugged the laser into the computer.
right Click then- Properties - update driver -

Picked the option " Let me pick from a list…" This is important because when I browsed to the driver I wanted it still thought the one it had was the best.

I selected the first “USB Serial Device” from the list. (this was a little bit of a gamble but it worked)
Click Next and finish.
Then reboot the computer.

When the computer restarted I had the Ports (Com & LPT) I was looking for. I plugged in the laser and launched light burn. Picked my device and made a test cut.

Thanks again to you both…


i have same problem ,if you found the solution(or the driver of usb STMicroelectronics ) help me please

Ortur’s drivers are posted on their site here

What version of Windows are you on? You should only need to install drivers if you are on Windows 7 or 8. If you are on Windows 10 or 11 you should not need to install any drivers.

Also, it looks like you are using a Ortur Laser Master Pro S2. If so, Ortur has changed the microcontroller that they are using for those models so is not the STM32. For some reason, they do not list the drivers for that laser in the link that Oz has included.

It seems they have finally updated the Laser Master 2 Pro S2 specific page to include instructions for how to address the USB driver needed for the S2.
Ortur Laser Master 2 PRO S2 – Ortur

Again, this is only required if you are on Windows 7 or Windows 8. Do not install these things if you are on Windows 10 or 11 or you could end up having a bad time.

If you are still having an issue connecting please respond with specifics to what you are experiencing.

O lm2 pro - windows 11 -GRBL- had com 3 working o messed with the control sliders and then it would let me touch them anymore . I closed out of it and bite I can not connect machine again for some reason

  • ortur is the biggest headache I wish I got something better - I don’t know what to do more I guess I’m screwed

Can you take a step back and state specifically what the problem statement is?

  1. What are you experiencing that’s creating a complication?
  2. What is this preventing you from doing.
  3. What have you so far explored in terms of information gathering or troubleshooting. Please be as descriptive as possible to provide enough context for someone to help you.
  4. Please include screenshots or photographs helping to show the problem that you’re having.