With larger elements, the laser jerks straight lines

Hello, the laser worked great and the problem started with larger elements, e.g. 600x600, where it is supposed to cut the frame. At the beginning, it cuts well, but after 2.3 minutes of work, it starts to make such teeth out of a straight line. I thought it was a design issue, but after running the program again, it does the same thing again, only in a different place, I loosened the tapes on the axes and nothing, I noticed that when it does such teeth, it gently tugs the motors. All tapes are well tightened.


It’s not only the belts. It’s the wheels, linear rails etc. Very important is to check the grub screws at the motors and moving elements. Here is a guide of things to check: Guide to mechanical adjustments and maintenance

I guess you have the S30 Ultra? Be aware, that the workspace is usually not exactly as advertised. In case you have the 22W or 33W module, you can only reach the 600mm if you move the air assist nozzle slightly. Make sure, the laser never touches the frame at any point.

i have sculpfun s30 pro max standard, ok i check and see what happend

I checked everything and updated lightburn to the latest version. After the update, I get error 20 and the laser does not want to cut me.

Can you show a screenshot?

If you have the Pro Max, then your workspace is 370x360. You can’t use projects bigger than that.

If you get error 20, it’s most likely caused by the “gcode clustering” option enabled in the device settings. Make sure that is turned off. (grbl error and alarm codes - Diode Laser Wiki)

I have an extension of the workspace to 890x900, and could you tell me step by step what should I change so that this error does not appear

Ah, if you have the workspace extension, you need to set the new workspace size in LightBurn and the firmware. The guide is here: Workspace extension kit - Diode Laser Wiki
How and where to turn off gcode clustering is shown in the link one post above.

When you installed the extension kit, did you change the motor power as advised? Some people found that turning the potentiometer only 45° instead of 90° gives better results.

Hello, I made a walkthrough for installing the laser driver, I used two programs lasergrbl and xload, the first error pops up, while the second freezes when uploading. In addition, now liteburn does not see the laser, or sees it but there is no cutting or engraving option. Could you please help me remotely?






You can’t flash that firmware to your board. You have a 32bit mainboard. The tools you used are for a 8bit mainboard. Check this guide, look at the S30 section: Firmware Update & Settings - Diode Laser Wiki

I don’t know, nothing works for me anymore, I’m lost in all this. These are my settings and I don’t have any g-code in them




I try to do everything step by step but nothing works. and the same error pops up all the time

Those settings look ok. Make sure you are using mm/min as speed settings, you didn’t show that screenshot.

Then it’s most likely a mechanical issue. Did you check all screws (especially the grub screws!), and wheels/belts etc.?
If this happens after some time of work, I could imagine the stepper driver starts overheating. Try to reduce the current by turning the potentiometer 45° backwards.

Can you give me a step by step description of what I should do with this 45’ rotation? I’ve never done it and in this video course there is some kind of table with brands and I don’t know what it is about. Or post an instructional video

You need to set the driver voltage right. Otherwise, the motors get too less / much power. Try 45° first, if this is not enough, try 90° or something in between.




but from what I remember, when buying a 900x900 size extension, the instructions stated that I should turn the knob to 45’ and I did it, because the plugs are supposed to stay in their original place?

and i dont know what is mean on this table

If you already did the 45° turn, then maybe try a little more. The plugs stay in place, there is no change.

No need to change anything here.