X-Axis motor grinding then skipping position

After about 45-60min of engraving (the same design) the X-axis motor on my inventables 1000mm CNC table will make a grinding sound and the entire design will skip about 6" along the X-axis and I have to start all over. I have tried 4 separate times to find the fix (clearing Cache, restarting program, updated…ect) but am still stuck. I have had no other problems with any designs, in fact I made a much smaller version of the burn and it worked fine. The X-motor is not over heating but is warm. The total burn was about 4:30hr.

I read in the forum about the Perforation setting to be turned off by my version (1.0.06) doesn’t have that feature that I can find.


This sounds like your stepper is skipping steps. Is this accompanied by a layer change with a higher speed setting?

It’s also possible that your current speed setting is on the edge of skipping and only starts skipping under certain circumstances.

Try slowing down your speed. Also review your acceleration settings. If this is too high this could occur at any speed setting.

This is available in line cut settings.

Thanks for the quick reply Berainlb. Yes that sounds about right, I will play with the settings and speeds. SPD/PWR = 3000/100 which I didn’t think was that excessive???

As far as the “Line Cut Setting” I do see the Perforation Mode but this is not there for an image file, which this is. Any idea how to combat this issue for an image file?

What are the units for this? In any of the common units including mm/min 3000 would be considered very high for a hefty CNC based machine. That’s a lot of mass being accelerated and decelerated. I’d actually be surprised if you were actually hitting those speeds. But I could be wrong if you had a very hefty stepper situation going on with an extremely rigid setup. I’m mostly talking about consumer/hobbyist systems.

Perforation wouldn’t be relevant for images which is why it’s not there.

I had thought you were asking two unrelated questions initially. Are you thinking of this as a remedy for the stepper issue? You may have a misperception of what perforation mode is. It basically creates a stipple effect on lines instead of a solid line. This is useful if you want a partially cut line or need this for folded parts or whatnot. It’s not the type of thing that would be used to reduce stepper misses.

Currently 3000 mm/min…but agree its a lot, have never had a problem in the past though. I don’t have any crazy set up. Basic X-carve CNC. I brought up the speed because the burn took over 4hrs. Ive been lightly looking to see if there is a way to burn that IS NOT Bi-directional scanning to avoid the aggressive momentum swings of going back and for on the X-axis. I’m really hoping this is an easy fix but at the end of the day it sounds like if I slow down the speed then the overall time to make larger burns will take much much longer.

Check on Perforation Mode, have never used it but saw a lot of others having problems with it so figured Id give it a try to see if it was messing with my design

If you’re only having this issue during acceleration you may be able to just slow the down the acceleration and keep speed higher. And/or only marginally reduce speed. Most CNC based systems typically are configured with fairly low acceleration rates I assume to deal with higher mass.

You can determine ideal acceleration and speed empirically. Start with a known good value, then run a series of increments until you start getting skipping… then back off a couple of increments. Start with acceleration and then move to speed.

If you are worried about overall burn times, consider increasing line interval slightly and defocusing slightly. This will result in a less detailed image but depending on what you’re doing it might be fine… or even better.

Ok, this is not a speed issue, I just did a test and reduced the speed by over 50%. Once I get within an hour of the burn the X-axis motor gets confused, drunk, dumb, ect…I dont know. But it will jitter like it doesnt know what it wants to do, get off course then continue the burn which is no where were it needs to be. Wondering if there is a bug within the design itself…

I’d expect the error to be repeatable in this case. But sounds like it doesn’t occur at precisely the same spot.

Is it possible that your motor is overheating after a certain amount of runtime? I know you mentioned before that the motor was warm.

Are you only experiencing a problem with this particular job?

Did you also look at acceleration separately? Could still be an issue with acceleration even if total speed is not a problem.

Correct, not happening in the same place. Motor temp is fine, have checked it in relation to other motors and its acceptable. Am only experiencing this issue with this specific burn, thus wondering if its an issue with the image.

Not sure with acceleration speed, kinda new. Any advice on where I could modify this and/or specs that would be acceptable?

These settings will be the most relevant in this case. I suggest you take a full backup before making any changes.

Taken from:
grbl/settings.md at master · gnea/grbl · GitHub

$11 - Junction deviation, mm

Junction deviation is used by the acceleration manager to determine how fast it can move through line segment junctions of a G-code program path. For example, if the G-code path has a sharp 10 degree turn coming up and the machine is moving at full speed, this setting helps determine how much the machine needs to slow down to safely go through the corner without losing steps.

How we calculate it is a bit complicated, but, in general, higher values gives faster motion through corners, while increasing the risk of losing steps and positioning. Lower values makes the acceleration manager more careful and will lead to careful and slower cornering. So if you run into problems where your machine tries to take a corner too fast, decrease this value to make it slow down when entering corners. If you want your machine to move faster through junctions, increase this value to speed it up. For curious people, hit this link to read about Grbl’s cornering algorithm, which accounts for both velocity and junction angle with a very simple, efficient, and robust method.

$120, $121, $122 – [X,Y,Z] Acceleration, mm/sec^2

This sets the axes acceleration parameters in mm/second/second. Simplistically, a lower value makes Grbl ease slower into motion, while a higher value yields tighter moves and reaches the desired feed rates much quicker. Much like the max rate setting, each axis has its own acceleration value and are independent of each other. This means that a multi-axis motion will only accelerate as quickly as the lowest contributing axis can.

Again, like the max rate setting, the simplest way to determine the values for this setting is to individually test each axis with slowly increasing values until the motor stalls. Then finalize your acceleration setting with a value 10-20% below this absolute max value. This should account for wear, friction, and mass inertia. We highly recommend that you dry test some G-code programs with your new settings before committing to them. Sometimes the loading on your machine is different when moving in all axes together.

Strategy wise you could reduce values dramatically just to see if this has an effect. If it does, you could then tune to optimal values.

When looking over the info you sent me it doesn’t seem to be relevant to how my machine is burning. Every burn I’ve ever done is bi-directional, just back and forth along the x-axis. So when talking about the G-code path coming up on a 10 degree turn mine has never done that.

If there is some sort of setting that I could change to NOT do bi-directional burning that would help tremendously with cutting down on the time.

Before I tried another burn yesterday I framed out the image on some wood and the issue with the X-motor jittering happened again! I’m half tempted to just delete this image and start with a new one as I believe this has to do with the image itself.

If you’re doing images exclusively then junction deviation for sure not in play. However, the acceleration will still be in play for the changes in direction. But seems less likely if you don’t experience this with anything else.

Not sure why you’d think that disabling bi-directional burning would reduce times but you can disable this in the cut settings, “Bi-directional scanning”.

It’s likely not the image itself that’s the problem but something in the image that’s triggering the issue. Another image that happened to have the same property would likely cause the same problem.

If you’re open to it upload the .lbrn file here and someone can review it for any anomalies.

Falcon_backup.lbrn2 (450.3 KB)

Here ya go man…let me know what ya think

Unfortunately I don’t see anything that would be a particular problem in the file. One note, though not related to the motor issues is that the image itself seems to have a lot of compression artifacts and is relatively low resolution. A higher quality image would likely result in a cleaner burn.

At this point the only thing I can think of is that your acceleration is set high enough to cause a problem, your motor is possibly failing, or maybe even you have some debris in the rails or somewhere that’s obstructing movement. Have you manually moved the laser head to see that you have free movement to all corners of the machine?

Run this in Console window to check your acceleration settings:


Values are as filed…$120=500/$121=500/$122=50


I agree that I need to slow it down but Im also trying to get past all the “white area” quicker to speed up the design. There has to be a way to do this design in a 20"x20" that isn’t an 8hr burn.

My first reaction is that those numbers seem high for a CNC based machine but I think those might be standard for x-carve. You may want to try something lower to see if you get different results. You can clock it back up later.

You can set Fast Whitespace Scan in Device Settings to specify this speed. Actually, can you check your current value for that as well as the speed setting in the Move window?

If these are set too high I’m wondering if this could cause your skipping. Well, this would be an issue in your other burns as well I suppose but at least work looking at.

Whitespace = 8000mm/min…Wow, I feel like a 5yr old went in and set random numbers because I don’t remember setting that???

Going to reset values as $120=300/$121=300/$122=50/Whitespace=2000

Took my X-axis Nema motor apart and cleaned it out just to make sure there wasn’t any debris inside, all looked good. Hoping the new setting work…feel like I’m learning to walk all over again :frowning:

We all need a little falling on our butts to keep us humble. :rofl:


New design yesterday, everything worked great, then tried another new 20"x20" design and the X-axis step motor did the same thing. Changed all the settings per our discussion and it got the jitters and stepped off the design about 30min into the burn.

Motor seems to be working fine so I’m not sure I should replace it, leaning more towards the controller?

1 Like

Maybe try swapping the motors. See if the problem shifts axes. If so, problem is in the motor. If not, then something else. It could be that the problem goes away since you’re less likely to put a strain on the Y-axis for scanning operations.