XTOOL D1 Not Working With Lightburn After Firmware Update

Capture

Hi there everyone, really hoping for some help here. I just got my RA2PRO today so I went ahead and did the firmware update for my XTOOL D1 10W. I have been using the laser for weeks, including today with LightBurn without any issues. As soon as I did the update, I can’t run any jobs at all in LightBurn.

I’ve open several saved jobs, ones I ran earlier today before the update even, none work. I even tried to just simply create a small rectangle and run that, nothing. The same thing keeps happening, the laser turns on for 1 second and then turns off and the job hangs and I have errors in the log. Please see the attached screenshot.

I belong to XTOOL D1 forums and I’ve posted about this but of course, no one is having the same issue I am or at least they aren’t posting about it there.

Please help! Thank you so much in advance!

Steve

Curious. Based on the message this may be the same issue being discussed in this other Topic:

For some reason the controller looks like it’s crashing and rebooting. Very likely tied to the firmware update. Perhaps a bad flash or something in your settings that it doesn’t like but it would have to be something in common with the other post.

A post was merged into an existing topic: xTool D1 - same problem?

Getting random partial gcode since update. Causing a hesitation with detailed areas. Inconsistent. Also reduced power.

Hello, terribly sorry for the trouble! You may flashback to the 002 version firmware referring to instructions here or wait for the next version firmware expected to be released by xTool next Friday.

Please share a link or a post to help direct folks toward the next xTool D1 Firmware update. Very exciting. :slight_smile: