Xtool D1 Pro Home Position Problem

I place the head in the top left hand corner.

I turn the machine on.

I press “get position” in Lightburn (I have also tried pressing “set origin”) and the software shows 0,0.

I move the head around either using the software arrows or by manually grabbing the head and moving it to a new position.

When I press “Home” or “Return to Origin”, the head does go back, but it continues past the point where I set it and keeps trying for a few seconds to go further, and is banging against the top because of that.

Is there something I missed on setting the Home?

1 Like

If you have limit switches, you should have the capability of auto-homing.

When you tell the xTool D1 Pro to Home, does the laser proceed toward the Limit switches?

Did you use the recommended V3 lbprefs file provided by xTool for your Pro device?

Which xTool firmware version is stated when the device connects?

This may be worth a look:

there is no provision for position feedback with gcode devices. Moving something by hand or with hand controls outside LightBurn will force the position information to be lost or inaccurate.


So if I use the arrows in lightburn to move the head and send it home it still tries to go back to far when I send it home. If I also move it out to say 2 inches from the top and the side and set the 0. If I also try moving head using the arrows and press the home button, it will also go back to the original spot.
It is like it does not want to make the initial turn on the machine home = home?

1 Like

I tried to make a video showing the project was started at 200mm to the right and 200mm down, run the framing, come back to see 202.87 and 187mm in the “move” window… Then when the project finishes and the laser either goes back to the start position or somewhere else, Lightburn now shows this is “home” or 0,0…

If I do anything with “going home” or hit play again it now crashes.

Why is the xTool not returning or sending location coordinates back to Lightburn? Or why is Lightburn not keeping track of the location?

When I first bought my XToolPro 20 watt, and pressed “home” on light burn, it went back, hit the rear bar and there was a loud crashing of gears. Inspection showed that the sensor (the metal bracket) was in an incorrect position, so it could not be sensed. As a temporary fix, I undid the two tiny bolts, and moved it, so it is now just held with one bolt.

So, now it usually, but not always homes OK (but occasionally it beeps and reports a hard stop).

I am putting up with this.

So when I am cutting, I do a “home”, then a “frame” and then I make my cut. That is usually OK.

But annoyingly, at the end of the cut, when it homes itself, it almost always hits the end stop and beeps a fault.

So now once it has framed, I click the “Set finish position”. Now after a cut it does not try to go home, but just goes to exactly where it started the cut. This is completely accurate so if I find that the cut is not all the way through the wood, I can run the identical cut again.

So, from my point of view, this is liveable with. It may be (I don’t know) because the 20 watt laser is a bit bigger than the lower power lasers.

Hope this helps


I’m with you. Even just figuring the alignment issues out is baffling. Why are the crosshairs way over on the left? How does that help if the laser head is 16mm over to the right?!


Simply because it’s not a closed loop system, neither direct nor indirect.
AFAIK those are really rare in budget systems, and I don’t know enough about GRBL control to know wether it has even the ability to use direct or indirect position feedback.

While the feedback sounds very simple in theory, the reality is a different matter, especially when speeds increase.



That feature is indeed a strange one, perhaps something in the internal design of the laser unit has prevented the crosshair laser to be integrated onto the same optical axis as the higher powered laser.
Or the laser unit and the crosshair unit is originally from different suppliers.

That really doesn’t matter in reality as long as it’s “accurate”.
In parentheses because the width of the crosshairs is ~5 times the width of the laser beam :/.
For the rather short time I’ve tinkered with my new toy, I’ve found that crosshair feature rather useless, so I’ve disabled the “laser pointer offset” in the “Device Settings” menu on LB.

Perhaps when I dig deeper and eventually start to cut and mark something that require more precision, I’ll have to re-evaluate that point of view ;).
Or I simply start to frame and position using the laser beam on low power, that should be possible AFAIK.


Has anyone found a resolution. I am having the same issues, some good ideas, but NO resolution

This is allowed and expected for red laser pointers. The Enable Pointer & Offset for the laser pointer is in Device Settings. It ‘Should’ handle the offset automatically but the xTool may be getting lost with this.

Comparing 200, 200 to 202.87, 187 we see roughly 3 and 13. The xTool laser pointer offset is similar but I thought it was x minus 13 or 16 and Y plus 5. I’ll check xtool docs. Please check to see what can be seen in the Device Settings.

It may be worth experimenting with switching off the pointer and selecting Enable laser fire button and Laser on while framing. When closing the Device settings window, after the settings are changed, click OK to keep these new settings.

Please also, scroll back in the Console window and select and copy the first messages when the xTool connects and paste them into a reply here. I would like to see which Firmware version is flashed into the xTool D1 Pro.

There may be a worthwhile update available from xTool.

anyone got a solution to this? I’m still having similar problems with my recent D1 pro. Ive also noted when I get the laser to work and engrave / cut the mage is inverted. Im running it in Mac OS. its as though the y axis is inverted - so basically I’m at - Y if that makes sense.

All drivers are updated its just the homing and inverted image I can’t get sorted.

Thanks in anticipation

Can you post a screenshot of your settings? Sounds like you might have set your machine origin wrong if the Y axis is inverted. Your origin should be upper left.

Ive done the below screen shot - played about a bit today, and it seems not to be inverting the image again (watching X Tool Lightburn for Dummies by Buster Beagle has helped a bit!), every time I Home the laser its bumping / grinding against the upper left frame.

Grinding while homing is usually either the limit switch is bad, the plug is loose, or the cable that runs up to the toolhead is in the way. I suggest rerouting the cables outside of the frame so they do not jam against it and keep it from homing properly.

1 Like