Y Axis will not move. 80 w CO2 laser red/Black Ruida controler

Its like driving my car to the corner and a stop sign is ahead, I put my bakes on before i reach the corner to slow down and avoid a collision. If the sensor is working it should tell the gantry to slow down before docking

Pass the gantry over the sensor making sure there’s not interference at any point.

You may have missed what I indicated earlier. There is no direct communication between the gantry and sensor. The sensor detects when something has come within its proximity. It has no previous knowledge of this. The gantry must be able to freely move over the top of the sensor for it to be detected.

This is why the homing process is a multi-step process with the iniital movements towards the home position being faster. Once X and Y sensors are actuated once, the laser head will retract slightly, then re-home at a slower rate to get a more precise position.

This is why it’s imperative that the clearance from gantry to sensor be properly established yet the granry still needs to be within 5 millimeters of the sensor for it be detected proeprly.

Dont know how to change that as i have not modified the position of the gantry to the sensor, moving it manually it knocks the sensor over, i will go and study again to see if I missed something

I think I found the problem, see pics y axis of , y axis on see the metal passing over the sensor, the cable has been touching when it passes over the y axis, I was able to move the cable and pass the gantry over the sensor and woolaaa the sensor light came on

If you look at the picture you can see where the cable has been catching, I have a new cable and sensor I will attach tomorrow and try to get homing right

That’s brilliant. Almost there.

Ok i have tightened up sensor y axis and moved cable so it doesnt catch, slide the gantry back and forth over sensor a number of times and light comes on, its not touching any more but i will put a cable tie on to make sure.
what’s the next step

Make sure both X and Y are lighting up when passed over and also showing up in Diagnostics.

If so, replug the terminal blocks at 2A and 2B. Then turn on machine and allow to home but be prepared to stop the machine in case of a crash. It should home properly.

Hi Berainlb. Did exactly what you said, tested x and Y on diagnostics 3 times both show up, shut down machine and connected 2a and 2band retarded machine, arm went directly to homing position no problem, shut down machine 3 times and retested… PERFECTO, I do believe that you have corrected my machine, thank you so much, we are back in business… Ciao Sam

1 Like

Reset Machine (not retarded Machine)

That’s fantastic news. Congratulations on the epic return. Hopefully your wife throws you a bone now.

Thank you so much for your time its been a long journey, but i learned more about these machines Ciao Sam

One final question , will i have to realign mirrors first

Some of the mechanical issues you showed made that possibility very high. The gantry getting out of square alone could potentially cause an issue.

However, I’d suggest gathering data first to guide your next steps. Run some test pulses and work backwards from the nozzle until you get a positive result.

If I were to guess I’d say you potentially have issues with M2, M3, and nozzle alignment. You might also be lucky and not have any serious issues.

Hi Berainlb… Had some success and some not, ran a number of times ok start and stop shut down, then it crashed only minor, shut down and restart homed properly no problem, fired the laser once after 1st start ok, then shut down and start up laser would not fire, tried homing and then tried to frame a job, laser went strait to bottom and could not frame, so it seems still a little to correct the above, any thoughts… Sam

Confirm that the reported position of the laser head is 0,0 after homing. You can do this from the panel or by pushing “Get Position” in the Move window in LightBurn.

If so, it’s likely homing correctly and there’s something else going on.

You indicated earlier that you changed the dip switches on one of the stepper drivers. Check that your laser head moves dimensionally accurately. In Move window, request movement of 10mm left, right, down, up. Does the laser head move the right distances?

If both position after homing and calibration is correct then it could very well be a configuration or workflow issue.

Can you take a full screenshot of LightBurn with your design loaded and ready to frame?

Position ok, other things happening this morning, machine crashed twice and then reset, homing ok, water pump ok first up, then went off water protect on, changed plug on water pump not working now, dont know why all of a sudden water pump off, its doing my head in at the moment, see pics to see if you can make anything out of this, frame is now at bottom of machine

What exactly are you doing when it crashes? Are the crashes random or repeatable?

Did you confirm that your machine motion is properly calibrated?

As for water protection check these things:

  1. Is your water pump in fact on?
  2. Check for kinks in the line
  3. Check that any water flow sensor is working correctly
  4. Check that connections to Ruida for water protection are intact

Found problem with water pump, it stopped pumping ,Stange to happen on day, but have another pump will install. machine crashed after putting in homing position, it returned home then crashed. crashes are random, shut down and restarted ran fine and homed perfectly, calibration reads 0.0 after homing get position shown in pics, how to check machine motion, it seems ok.
how should i check

How are you doing this?

It’s possible that the sensors are unreliable. Either by being faulty or due to installation. Is the crash occurring on both X and Y or just one of the directions? That will narrow down where to focus.

Did you completely replace the Y sensor yesterday or did you work with the one that had been there? Make sure that the gantry is passing within 5 mm of the sensor.