Y Axis will not move. 80 w CO2 laser red/Black Ruida controler

Please explain in detail exactly what this photo is trying to show, including history and intent.

changing the wires from Y axis to x axis and visa versa , made no difference on the movement of the gantry

the gantry movement up or down, did not change

this was done for a so called computer expert, to see if moving y to x would help, but did not help

Please try to answer each of these questions.

  1. Is this the before state or the after state?
  2. How were the pins chosen? I specifically want to understand how pins 2 and 4 of CN1 were play into this.
  3. What do the arrows show in terms of action taken?
  4. Can you take a much clearer picture of CN4. Typically CN4 is all you would need for the limit sensors.

this is the after state.
here is a screen shot of the current situation

Okay, assuming that pin 2 goes to the Y sensor, correct? and pin 4 goes the X sensor?

And with that, the diagnostics screen does not show activation for the Y-limit when actuated with a screwdriver? Please confirm.

checked the machine just now and tightened all connections, Y lights up on the diagnostic screen now, but X does not show up on diagnostic, but lights up on the gantry.

Try very carefully swapping the wires that are on pins 2 and 4. Then retest.

What are the results?

y has now changed to XL gantry still not moving up or down

Do both the limit switches correctly show as being activated in the diag screen when triggered? If so, that means that the switches themselves are functional and any previous issue was likely due to a bad connection.

Put the switches back in place as they were. Confirm proper function by testing each sensor. Once both are confirmed working, push “Reset” button on the panel to get the machine to rehome. Does it home properly?

If so, then test motion. If not, document exactly what’s happening.

replaced wires to original position on board.checked both sensors by tapping with screwdriver, both light up. checked Y axis sensor with screwdriver to Diagnostic screen, this lights up. checked X axis sensor with screw driver to Diagnostic screen, does not light up,see Pics. Reset function on screen, machine returns to side, does not crash,Machine will still not home to top RH corner…

also rechecked wires to see they were tight, all ok

Okay. I want to make sure I have the facts.

Please confirm.

  1. X Sensor on X Pin - Does not light X on diag screen
  2. X Sensor on Y Pin - Does not light Y on diag screen
  3. Y Sensor on Y Pin - Lights Y on diag screen
  4. Y Sensor on X Pin - Lights X on diag screen

If this is correct then the X sensor seems bad but the controller fortunately looks good. Replace X sensor.

chnged controller heres results

what next, do you want me to do.

I don’t understand what you’ve done.
Your images without context for what each is showing is disorienting.

Can you confirm whether or not my understanding is correct in my previous response?

If my understanding is correct then you need a new X sensor. If it’s not correct, please provide details as to what’s not correct.

i change the controler with a new one for x axis as you requested and now they all lite up on the diagnostic screem, I am confused with your comments.

I changed the X sensor