Z axis does not work after calibration

Ive been trying to get my Z axis to calibrate properly. In its current state when the controller says the table has moved 100mm in reality it had only moved 11.83mm. When I use the axis calibration it changes the step length. As of right now the step length is 10.31 but gets changed to around 1.22. After this happens the motors on the Z axis no longer work. Is this an issue I can fix in Lightburn or do I need to mess with the motor controller settings?

Try decrementing the step length value more gradually. Does it work for a while and then drop off at some point or does any change break this?

Also, have you made any mechanical changes to the machine? Such a large variance would imply a fundamental shift.

I replaced the entire control system since the old one was run on LaserCut 5.3 which was just impossible to use. I’m trying to get the machine setup. When I set the step length anywhere below 10 the motor controller turn on the red error light. Setting it back to 10.31 makes it work again.

Read through this Topic as it has very similar symptoms. @ednisley has some very specific guidance so I’d suggest reading those areas carefully.

1 Like

following those steps slowed down the motors quite a lot. moving at about 1rpm which translates to 3.2mm a min yet the controller is still reading around 5mm/s

never mind i got it all sorted out. was off by a factor of 1000. just moved the decimal place and now it works fine

1 Like

Excellent. Glad that worked.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.