Z axis limit for down stroke

Just wondering if anyone else has been in this situation, I would like to get my Z axis to travel farther , because when I use my rotary axis with a larger diameter the head won’t clear . The Z axis has a micro switch for it’s top stroke , but the down stroke seems to be software governed . Can the parameters be changed to increase travel and if so how ? If anyone could shed light on this it would be appreciated .

With your Ruida controller, you may notice that when you start your machine (or reset it), Z always starts at the same number (no matter where you last left it). Mine always reverts to 3000. As it travels lower, Z value increases.

If you click EDIT : MACHINE SETTINGS and navigate down to the list to Z Axis Settings, there you will find the value for MAX TRAVEL (mm).

I set mine to a ridiculous value because I have both upper and lower limit switches:

1 Like

Thanks for your help, EXACTLY what was happening, down to the same numbers on the control.
After exploring the machine settings , I also found I could increase the z speed , as it was really slow, and also enabled the limit switch as it was also disabled.
Thanks again!

Jeff, just curious, if you have limit switches why don’t you let it home on startup? Actually same question for Les, if you have an upper Z switch why not let it home?

I’m not comfortable with Z homing. If I had left thick material on my bed, the rotary, any object I may have been working on, etc it would crash the head (and on my machine destroy the gantry).

Z is just such a constant / job / material specific coordinate. X and Y make sense in that they define an ever changing position consistent in every job that absolutely relies on the synchronization / homing of the machine origin.

Z is a critical job specific / material specific height relative to the ToM (Top of Material) that I find best set for the specific job queued for the machine.

I should also add that I do utilize auto focus.

Jeff beat me to it , when I first started up machine I almost took my auto focus probe off because the slats are higher than the bottom of the probe . Poorly designed for sure , but this is a way to avoid collisions .
And as a CNC machinist I’m all about not colliding with my parts :wink:

Thanks. Was just curious what your rationale was. On my machine it homes to x and y first before homing Z. So, the chance of material sitting in that back corner is minimal.

However, on a Ruida after homing, the head will move to the last user-defined origin pre reset / power cycle.

So even though the head may move up and over to the far left to set / find 0,0 (calibrating home), it doesn’t stay there.

Does this behavior change in the return to last origin if homing Z?

Oh and that’s also assuming flat material I guess, because consider the potential for tall objects that could strike any width of the gantry.

I personally am not comfortable with Z moving at any time without strict control. I am nervous even when I set focus offsets on layers. I wish there was a control in LightBurn where that value would only accept < or = 0.

Hmm. I have a ruida 6442 and it doesn’t behave that way. It goes to the back right corner, homes, and stops.

But now that you mention it it did do what you’re describing in the past. I changed something but don’t remember what.

I def wouldn’t want to see that changed in the z offset on cut layers! I use both negative and positive numbers in that setting for some of the focus tests I create. Not the built in focus tests, but files with custom focus tests. As a matter of fact it’s annoying to me that I have to create my own focus tests in order to get negative z moves to work. The built in focus test doesn’t support negative z moves.

I do use relative Z moves only because I don’t want to deal with entering material heights every time I’m working on something. On startup my machine homes and zeroes all 3 axis. I then know that the bed height needs to be moved to 6.6 for the focal point to be on the bed. I add to that whatever my material height is then just use the move window in LB to set the z.

And now that I’m thinking about it, I wonder if there’s a way to manually home z after starting the machine and doing it only when you know you’re ready for it?

Yes, it’s the ‘Focus Z’ button.

Thanks, Oz. Doesn’t really matter for me since my Z homes on startup but might be useful for Jeff.


(stated in my post):

Ah, that’s right. I seem to remember that from another post. I did away with my autofocus long ago.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.