Z offset runes second image at different settings

Kind of annoying that threads get locked automatically with no real answers. I want to say I have the same issue as this thread.

I run some text, then I run images with a z offset of -0.0394 to defocus.
Text runs, then z offset is adjusted and the First image is fine. The bed then seems to reset and offests again, but the second image runs much slower and power output seems affected in a weird way,. Display still shows expected speeds.

If I set the z offset to zero, no other changes, all 10 images run just fine.

z offset test.lbrn (178.0 KB)

Controller RDLC 5.00.38
LB 1.0.02

We try to get to every post, and also do this to help manage the flow.

This is the default behavior on our forum. :slight_smile:

I didn’t look to much into this issue myself. We worked around it by either using SVG or manually offsetting the bed.

I’m not too well versed in RD files, but looking through the file LightBurn creates - I think whats happening is that LightBurn may not be setting the speed after doing z moves?

I haven’t been able to test this, but you might want to @turbo2ltr, do the settings “Optimize Z moves” or “Relative Z moves only” make any difference to the issue?

Thanks. What RD file decoder do you use?
I used this site on a small test file that fails:
https://stefan.schuermans.info/rdcam/decode.html
z offset test.lbrn (178.0 KB)

Apparently the forum will not accept rd files.

There’s a lot of undecoded lines and the ones that are decoded seem all over the place as far as order. But I know nothing of this format either.

I’m pretty sure I tried those other Z settings, but I may have not systematically tried every permutation. I will do that next.

I used this one, but had to add some additional code to handle what I think are new commands in the RD file: GitHub - kkaempf/ruida: Decoder and tooling for the RDWorks .rd file format A lot of it is still not decoded, but enough that I think I can explain the behavior.

Looking at a few decoded files with different numbers of images and z moves: At the start of the file it’ll do the first z move, then set the layer speed for the image. However subsequent z moves will set a speed for the z axis move and then it does not have another speed command.
I think what is happening is that even though the speed for the layer has been set, the speed for the z move is overriding it, and its not being set back to the layers speed.

However, when turning on “Optimize Z moves”, the RD file does not have any z move or speed commands between the images. So this setting may actually fix the issue.

This does seem like a possible bug in lightburn, that even if the Optimize Z moves does fix it, the non optimized one should still work as expected.