1mm lost pls help me!

Hello, I need some help. When I cut in your software, I found the problem of insufficient moving distance. (The following units are mm.)For example, if I want to cut a square with a side length of 150 * 150, the result is 149 * 149. If I cut a square with a side length of 50 * 50, then the actual cutting is 49 * 49. The preset side length is 200 square, and the side length is 199 * 199. Each cutting will lose 1mm. What’s more amazing is that when I use, for example, rdworks to control the machine, the machine is perfectly cut (which means it’s not the problem of the machine). How to solve this problem? Thank you :green_apple::apple::pear::tangerine:

sounds like something which might be related to scanning offset or overscan. Have you looked at settings in the Edit->Device Settings window?

What should be viewed here?

Calibrate your axes in Lightburn.


Use the largest distance you can measure accurately to minimise measurement errors.

I used a 150 x 150 mm square that my callipers could measure. After a couple of iterations I now get 400 x 400 mm to better than the precision I can measure with a steel ruler (+/-0.2mm).


I’ve tried to use lightburn to calibrate the axis, but it’s strange that only the current length is valid and the other lengths are still biased. For example, after I calibrate with 200mm, I test that 200mm is accurate. But 150, 50 is still wrong. I’m sorry, the way the shaft is calibrated doesn’t work for my machine.

Is there anyone else who can help me? I need a solution to this problem. Thank you very much

I figured system distance calibration wasn’t the problem because the distance lost is always the same 1mm. it would scale with larger distances if it were related to a motion calibration issue.

1 Like

When you state that the 150mm and 50mm tests are wrong (after the axis calibration for 100mm is complete) would you be willing to tell me if the behaviour is linear?

What kind of machine are you calibrating and would you be willing to share some pictures of what you’re seeing? You can drag and drop them into your reply window here.

This seems like a very sound posit. More information is required.


Sorry for the delay in my reply. I don’t understand what you mean by whether the behavior is linear. At the beginning, I mentioned that when used in rdworks, the machine can cut perfectly, and the two software read the parameters of the same motherboard. I also personally saw that the steps and other parameters read by the two software are the same. This is very frustrating. I don’t know what went wrong with lightburn. If you need any accurate pictures, I can send them to you. I have the cut-out physical map. I really hope you can help me. The machine has been like this for several days

Do you have an email address? We can send you pictures in the mailbox

I’m trying to describe what’s happening. Why don’t you tell me why the same step gets different results in the two software. What are the possibilities

I think he’s asking if you try to do a 10mm line and get a 9mm line, when you double the length to 20mm so you get an 18mm line. trying a 30mm line would get you a 27mm line which is a linear progression. I know you already mentioned that you always go a loss of 1mm no matter what size box you tried to create but when a LightBurn staff person asks it’s best to repeat and answer the question.

Myself, I would be looking at the Ruida settings for overscan first with RDWorks connected and then with LightBurn connected. This is most likely an issue with a setting getting changed or set with one application and set or not set in the other application.

Well, thank you very much

OK, another question, how can I cancel the hard limit protection of the machine in
Lightburn.Thank you very much for your help

The Model Number on the controller may be of benefit here.

One of the reasons for a public forum is to share ideas and problem solving strategies. There is a good chance several years from now someone will read a solution like this with pictures and descriptions and different perspectives and test cases.

I am requesting some information to reduce my list of possibilities from a few dozen down to 3 or 4 things to verify. My tea leaves say Kerf Selection but that’s a bruise from yesterday that may have nothing to do with you. :slight_smile:

This seems like a conclusion arrived at via some innovative or potentially unconventional assumptions.
There may be something going on with the limit switches or the controller wiring that inspires your question. Please tell us what the error message looks like. Take pictures if need be. We really are trying to help.

You may be experiencing something like this:

This seems like what’s happening and this may be great advice…

This may help with some of the questions posed:

My motherboard model is Ruida 6640y

I’m sorry, I’m back. The machine situation has taken a turn for the better. His stroke is no longer the regular 1.5mm, and the deviation is more or less, 1mm, 2mm, 1.5mm and so on. I will try my best to provide you with effective information, but before that, please tell me what you need, and I will provide it all the way

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.