$79 Cenoz laser engraver on Amazon... any good?

Jack, I have no clue what that “programmer” is supposed to do. That’s why I tried to stress that the Windows laptop, the zipfile, USB cable, and laser machine were all that are required to flash the board… that’s all I had.

EDIT: Is the programmer required to “unbrick” your board?

– David

If you go back to post 10 and see the board. I purchased a ‘programmer’ that will allow me to write to the devices memory via the connector in post 10 photo.

I should be able to load it via that input.

They are called ‘st-link’ …

It should allow me to bypass the boot loader, I think… It also allows for a debug connection to the board, on ones so equipped… Don’t know if this one is…

It’s supposed to show up tomorrow…


1 Like

Does homing work properly? I believe @LsrSal wasn’t able to get his to work. If so, what is position after homing?

If homing isn’t working, are you placing laser head at front-left before starting machine?

I was looking at this homing. The switches are located in the front/right.

When I first fired it up, it come home (front/right) then moved to the back/left… never ran anything to see what it did, but thought it was a curious boot sequence.

See post 37…


The machine’s limit switches are placed to put home in the right-front corner. The unaltered machine will home to the right-front and then run to the left-back corner upon power-up. After flashing Grbl… trying to home goes in the wrong direction, both X and Y IIRC. Changing the $23 Grbl setting ($23=1) now goes to the switches and leaves the laser in the front-right corner.

That said, I have never depended on limit switches and homing… in fact, most of my machines don’t even have limit switches. I usually like the freedom of placing the workpiece wherever convenient and frame to the workpiece. I normally use “User Origin” or “Current Position” rather than absolute coordinates and don’t depend on the laser being in a particular spot when I power on the machine.

1 Like

So… did you configure Device settings with the home (origin) at the front/right?


No, I didn’t… TBH I didn’t think about it. But I was using my default “GRBL” Device which designates the front/left being my 0,0 and I do not set “Auto-home on startup”. As I stated in my last post, I don’t depend on limit switches or homing anyway.

So I just homed the machine since it has the switches… front-right. Reading the position yielded -2, 2 for X and Y… 2mm off the switches is correct, I think. Moving 100mm out into the workarea yields -102, 102… so it appears to be in Quadrant 2. I’d prefer to work in Quadrant 1 and need to figure out how to move my 0,0 to front-left. Maybe that’s why my “User Origin” usage crashes left even though it seems to frame properly? “Current Position” worked fine… :thinking:

In that case are you defining origin after power on each time?

My guess is that this is a front-left origin machine irrespective of homing location.

This is possible.

Based on what you’re saying try this:

G10 L2 P1 X-200 Y0
1 Like

Ok… here’s what I have decided. My machine is now behaving like all my other GRBL machines.

I’ve disabled the Homing cycle ($21=0) in Grbl settings. I’m removing “Home/Homing” from my vocabulary and ignoring limit switches and any position coordinates in LB.

“Origin” is my friend. I put a workpiece down and jog/position and lightly fire the laser where I want it relative to the workpiece and matching the “Job Origin” setting. I select my graphic and Preview to insure all looks right. I select “User Selection Origin” and “User Origin” in the Laser tab. Frame to insure all looks well and “Set Origin” and “Set Finish Position” in the Move tab. Frame once more for a warm fuzzy and “Start”. The job runs to completion and returns to the starting point.

Thinking only in terms of job/work coordinates is pretty much how I run my machines. If doing a “run” of pieces, I clamp a positioning fixture (square, strong magnets, blocks, etc) in place. I realize this is not sophisticated use of gcodes, homing, offsets, etc… but is less confusing for this old man.

– David


I run my machine the exact same way :call_me_hand: :call_me_hand: :call_me_hand:
I have no need for a homing cycle.


Just piddlin’ to make sure I’ve got my process down…

– David

and should allow you to create your own grbl rom and load on the stm32.

Just as I have used ST-Link to fix bricked Otur machines loading the Ortur bootloader and then using it to flash their GRBL firmware image.

More progress…

Managed to hook up the Xtool RA2 rotary fixture (3x the cost of the engraver!) and run Lightburn’s rotary setup tool. Only odd thing about this Cenoz machine is that it uses TWO motors (hooked in parallel) to drive the Y-axis… rather than a single motor and driveshaft. You’ll need to unplug BOTH motors and plug the rotary fixture into one of the connectors.

This machine should make a dandy machine for doing cermic tiles/glass and rotary jobs on bottles and glasses. It’s sturdy and portable… easy to block up, relocate, and/or put away for storage.

BTW don’t tell anyone… I’ve ordered another one. I’ve got a friend that I think is really gonna want one as soon as he sees this one… :wink:

– David


WOW,You must have bought the last one.
They’re out of stock now. :grinning:

This one still seems available?

How weird is that.
It looks like the same machine other than its a little bigger and a different name.

It doesn’t appear bigger… same 220mm x 290mm and virtually identical AFAICT. Yes, it is a different name/brand.

BTW the other one that I bought was an even different name (Yofuly?). And I really do have a friend in mind who does real CNC woodworking… but he’s genuinely too busy to mess with this stuff right now.

I thought there was some act of subversion in buying it for a ‘friend’… :crazy_face:


1 Like

Ok gentilemen.
so I got my laser today but I cant get it to do anything.
This is the only thing I get.

Am I supposed to install another file?

Did you load their driver?