Added new Axis for Rotary - how to get it working?

I have just installed a new axis driver, and attached it to the U axis.

I have 6445S controller.

I cannot see any way of getting the Rotary to work in LB through the U axis, although I’ve read lots of threads saying the rotary need to be working off the U axis.
In LB I only see option for Y Z A axis, Should I coonnect it to the Z axis, and enable the Z axis in device settings?

I see you had no response to your question.

Most Ruida users do not realise the 6445S is different in regards rotary to the 6445G, often wrongly stating how things must work on the 6445S

I had to update to the latest firmware before the rotary would work. Firmware as supplied did not.

RDC6445S-V26.01.16 is the firmware that fixed it. Only released in December.

1 Like

I have the latest firmware on my PC, but I cannot transfer it to the controller because RDWorks will not connect and cannot do it through LB.

I have tried many many times to install, uninstall, reinstall RDworks and USB drivers, different versions of RDWorks etc etc, it will not connect and I don’t know why, and have no idea how else to update the firmware to the board.

If I send the job to the controller from LB, with the rotary connected to my new Axis (U Axis) it seems to run ok but the engraving sometimes fires and sometimes doesn’t…weird

Try connecting RDworks via Ethernet.
Always preferable to USB IMO

yes other have said the same, although maybe you can answer my question I have asked them many times.
Ethernet cable is connected :

A) Laptop direct into laser
B) Laptop into router - router into laser?

If B, I cannot do it as router is in the office 10meters away

I was involved in a couple of discussions on this recently that covers this:

I use laptop direct to laser. It is rock solid.

Post above has much better info than I can provide.

@berainlb @Greolt I have got it running through Ethernet connection, well almost!

Many thanks for the info and advice, I have 1 issue…Lightburn works perfect through Ethernet and connects no issues, however I still cannot connect RDworks USB or Ethernet both come up with port error??? When I put the ip address in the device set up in RD and test, com error…no idea why??? So still cannot upgrade the firmware, whic was the whole point of the ethernet connection.

Any ideas?

Make sure there’s no anti-virus or security software that may be blocking the connection. Disable any firewall in the meantime.

If that doesn’t work can you post a screenshot of the error?

How have you connected the laser to ethernet? Was this a straight connection from computer to laser or are you going through a switch or router of some sort?

What version of RDWorks are you using?

Straight connection out the laptop ethernet port into the laser.

Would it be going through a firewall? Thought LAN doesn’t use it…I’m probably worng there not a techy.

I will check AV and Firewall though, strange LB works fine with it though?

So I turned off AV and all firewalls and still get the same error…


All ports are potentially subject to firewall rules. In your case anything run on the laptop itself. I’m guessing minimally you’d have Windows Defender running.

If you had been going through a switch there would potentially be firewall rules enforced on the switch side.

There can be application specific rules that are applied. Or classes of rules. I suggest you disable all AV and firewall software entirely as you’re debugging as to rule it out.

I’m assuming you don’t have a basic networking issue at this point since you can communicate via LightBurn.

This would limit issues to either something specific to RDWorks or something between RDWorks and the network.

What version of RDWorks are you running? Are you certain this is meant to work with your controller? Just want to rule out any potential compatibility issues.

What did you set your laptop IP for the ethernet adapter to?

What IP range is your WiFi using?