ALARM:2 message

this is the error I’m getting after installing 0.9.21. Any sugestions?

Stream completed in 0:00

Starting stream

Layer Mandala

ALARM:2

G-code motion target exceeds machine travel. Machine position safely retained. Alarm may be unlocked. (Right-click the ‘Devices’ button to reset the connection)

On or near line 5:

Job halted

Stream completed in 0:00

[MSG:Reset to continue]

ok

Ortur Laser Master 2 Ready!

OLF 139.

Grbl 1.1h [’$’ for help]

[MSG:’$H’|’$X’ to unlock]

[MSG:Caution: Unlocked]

ok

Yes, we tell you in the message. :wink:

Alarm 2 is the machine telling you it hit a hard limit or tried to go out of bounds. Was this ‘Job Origin’ set to ‘Absolute Coords’? It should be and this should help with understanding the Start From options, when to use each, and why. Coordinates and Job Origin - LightBurn Software Documentation

Absolute Coordinates is the simplest - The page grid you see in the main editing window represents your machine’s work area. Anything you place in that area will be cut in the corresponding place on your machine. Users with small lasers like the K40 will likely find this the simplest and most intuitive option.

I had this happen when I installed 0.9.21 trial. Turned out my X-axis size in lightburn got bumped up to 500mm instead of 400mm somehow. Reset it to 400, moved my project back in the work area and problem solved.

It may not be your problem, but it is easy to check under device settings.

Thats odd will try to replicate

Actually found the issue. there was a number in the material (in) box. Thank you everyone.

1 Like

Thank you for posting the solution to your problem. It may help someone else in the future.

That box only appears if you have Z moves enabled, and the Ortur doesn’t have a Z axis, so you should turn that back off in the device settings.

1 Like