Artisan 10W v2.5.23 funktioniert nicht mit Lihtburn v1.6.0.0 (Artisan 10W v2.5.23 does not work with LightBurn v1.6.0.0)

Hallo ich mir einen Snapmaker Atrisan mit 10W Modul im Februar gekauft und wollte jetzt meine Laserarbeiten mit Lightburn erstellen. Gestern habe ich mir die aktuelle v1.6.0.0 runtergeladen. Erst wollte ich wie bei Luban eine Verbindung über das LAN/WLAN aufbauen was nicht funktioniert. Dann habe ich einen Windows 10 I7 Laptop per USB mit dem Artisan verbunden. Bin auf Gerät suchen gegegngen. Es wird ein "GBRL-M3 (1.1e or earlier) gefunden. Es lässt sich aber nur eine Fahrt zur Ausgangsposition bewerkstelligen. Dan habe ich manuel den einzigsten zur Verfügung stehenden SnapMaker (Marlin) eingerichtet hier passiert überhaupt nichts. Wenn ich GCode mit den Profilen erstelle und auf das Gerät kopiere (über Luban) bekomme ich Fehler und der Artisan denkt es ist ein 3D Druck GCode. Er beginnt zu Lasern allerdings außerhalb der Grenze und die Y-Achse bewegt sich nicht in die links untere Startposition.
Gibt es eine Möglichkeit mit den Softwareversionen den Snapmaker Artisant unter Ligtburn zum laufen zu bekommen.
Ideal wäre es für Mich das ganze über LAN/WLAN zu Verbinden.
Danke schon mal vorab
Gruß Dietmar

Hello, I bought a Snapmaker Atrisan with a 10W module in February and now wanted to create my laser work with Lightburn. Yesterday I downloaded the current v1.6.0.0. First I wanted to establish a connection via the LAN/WLAN like with Luban, which doesn’t work. Then I connected a Windows 10 I7 laptop to the Artisan via USB. I ran into Search Device. A "GBRL-M3 (1.1e or earlier) is found. But only one trip to the starting position can be accomplished. Then I manually set up the only available SnapMaker (Marlin) and nothing happens here. When I use GCode with the When I create profiles and copy them to the device (via Luban), I get errors and the Artisan thinks it is a 3D printing GCode. However, it starts to laser outside the limit and the Y-axis does not move to the bottom left starting position.
Is there a way to get Snapmaker Artisant to run under Ligtburn with the software versions?
It would be ideal for me to connect the whole thing via LAN/WLAN.
Thanks in advance
Greetings Dietmar

I would set it up with just GRBL.

1 Like

Das hat nichts gebracht.
Jetzt ist auch eine neue Firmware V2.5.24 auf meinem Snpmaker Artisan

That didn’t help.
Now there is a new firmware V2.5.24 on my Snpmaker Artisan

When you created the device profile manually as GRBL in LightBurn, did you set your origin to bottom left?

What part of setting up your machine up in LB as GRBL didn’t work for you? Are you receiving error messages from your console? If so, please share them.

Glad you have new firmware, good start :+1:

Ja, ich habe den Ursprung auf links unten gesetzt.
Jetzt bin ich auch weiter als vorher, vielleicht die neue Firmware.
In den Geräteeinstellungen habe ich die Z-Achse aktiviert.
Zum Testen habe ich 2 Rechtecke ineinander gezeichnet und mit Schnittparameter Linie 400mm/min 40% gestartet, Material ist Karton.
Der Laser bleibt erst mal in der Z-Achse ganz oben fährt aber den Job ab.
Dann habe ich die Z-Achse über Bewegen ungefähr auf den Fokus gestellt. (In Luban ist das kalibriert, da gebe ich nur Materialstärke noch an)
Der Job wurde abgefahren. Allerdings hat er nur das 1. Rechteck ausgeschnitten den Laser ausgemacht und ist das 2. Rechteck abgefahren der Laser blieb aber aus.

Yes, I set the origin to bottom left.
Now I’m further along than before, maybe the new firmware.
In the device settings I activated the Z axis.
To test, I drew 2 rectangles one inside the other and started with cutting parameters line 400mm/min 40%, material is cardboard.
The laser initially stays at the top of the Z-axis but completes the job.
Then I set the Z axis to approximately focus via Move. (This is calibrated in Luban, so I only specify the material thickness)
The job was canceled. However, he only turned off the laser to cut out the 1st rectangle and moved the 2nd rectangle, but the laser didn’t turn off.

Nachtrag:
In der Konsole wird folgendes ausgegeben:
Auf Verbindung warten …
ok
echo:Unknown command: “$I”
ok
Projekt in 0 Millisekunden geladen
Stream wird gestartet
Layer C02
set air pump switch: open
echo:busy: processing
echo:busy: processing
echo:busy: processing
echo:busy: processing
echo:busy: processing
echo:busy: processing
echo:busy: processing
echo:busy: processing
echo:busy: processing
echo:busy: processing
echo:busy: processing
echo:busy: processing
set air pump switch: close
echo:Unknown command: “M2”
Stream fertiggestellt in 0:25
delay 5s disable laser switch

bei den Schritten echo:busy: processing fährt er die beiden Rechtecke ab. Beim 2. Rechteck ist der Laser dann aus.

Addendum:
The following is output in the console:
Waiting for connection…

in the steps echo:busy: processing it moves through the two rectangles. At the second rectangle the laser is off.

Can you type $$ into your console window, copy the response, and paste it in a reply back?

$$
echo:Unknown command: “$$”
ok

Thanks for helping me learn something new today. Marlin doesn’t have the $$ command. The command M503 is used to report settings.

I’d like to clarify what exactly happened in the job. I understand that the first rectangle was cut but I’m not clear on the second. Did the laser behave as if it were lasering and it just wasn’t firing? Or while traveling the laser didn’t turn off between rectangles?

1 Like

Yes, good to note.

Das erste Rechteck wurde korrekt abgefahren und der Laser hat gefeuert. Dann ist der Laser ausgegangen weil er ja zum Startpunkt des 2. Rechteckes fahren muss. Dann hat er das 2 Rechteckabgefahren wie wenn er es ausschneidet aber halt ohne das der Laser wieder anging.

Ich habe auf der Snapmaker Homepage eine Gegenüberstellung von den Lasermodulen
-1064 nm Infrarotlaser
-40W Diodenlaser
-10W Diodenlaser
gefunden da steht unter Software das das 10W Modul scheinbar Lightburn nicht unterstützt. Kann das sein?
[laser modules comparison – Snapmaker EU]

Im Snapmaker Wiki gibt es den Eintrag das für die 20W und 40W Module Profildateien zur Verfügung stehen.
[Using Ray/Artisan/2.0 with LightBurn | Snapmaker Wiki]

Beim 1,6W und 10W Modul soll man so verfahren. In der folgenden Anleitung sind Screeshots von der Lightburn Version 0.9.24 wo als Gerät der Snapmaker ohne den Zusatz (Marlin) verfügbar ist. bei der Version 1.6.0.0 gibt es nur noch Snapmaker (Marlin)
Kann es damit zusammenhängen. Was sind da die Unterschiede?
[Adding a 1.6W or 10W laser module in LightBurn | Snapmaker Wiki]

The first rectangle was moved correctly and the laser fired. Then the laser went out because it had to go to the starting point of the 2nd rectangle. Then he traced the 2 rectangles as if he were cutting them out, but without the laser turning on again.

I have a comparison of the laser modules on the Snapmaker homepage
-1064 nm infrared laser
-40W diode laser
-10W diode laser
found there under software it says that the 10W module doesn’t seem to support Lightburn. Can this be?
[laser modules comparison – Snapmaker EU]

In the Snapmaker Wiki there is an entry that profile files are available for the 20W and 40W modules.
[Using Ray/Artisan/2.0 with LightBurn | Snapmaker Wiki]

This is how you should proceed with the 1.6W and 10W module. The following instructions contain screenshots from Lightburn version 0.9.24, where the Snapmaker device is available without the addition (Marlin). With version 1.6.0.0 there is only Snapmaker (Marlin)
Could it have something to do with that? What are the differences?
[Adding a 1.6W or 10W laser module in LightBurn | Snapmaker Wiki]

I would email Snapmaker to ask why they don’t have LightBurn supported under the 10W module, as it contradicts with their tutorial:

The main difference is that the 10w uses Marlin and the lbdev configuration files are all using GRBL:

Screenshot 2024-05-21 at 11.52.34 AM

Hi Jess,
danke für deine Unterstützung :slight_smile:

Ich habe bei Snapmaker schon ein Ticket über den Support aufgemacht. aber das dauert scheinbar alles etwas länger. Ich warte da noch auf Antworten.

Es gibt scheinbar bei Snapmaker Firmwareupdates für den Controller der alle Geräte (3D-Drucker / Laser /CNC) verwaltet. Nach Bedarf für die angesteckten Module gibt es scheinbar extra Updates.

Ich kenn mich da nicht aus weil ich neu in dem Laserthema bin. Ist es so das GBRL und Marlin unterschiedliche Controllersoftware ist??

LG aus Deutschland
Dietmar

Hi Jess,
thank you for your support :slight_smile:

I have already opened a ticket via support at Snapmaker. but it all seems to take a little longer. I’m still waiting for answers.

Apparently Snapmaker has firmware updates for the controller that manages all devices (3D printer / laser / CNC). There are apparently extra updates as needed for the connected modules.

I don’t know anything about it because I’m new to the laser topic. Is it that GBRL and Marlin are different controller software?

LG from Germany
Dietmar

Correct, the firmware controls all of the components of your laser.

Marlin actually came from GRBL, but it’s been optimized mainly for 3D printers.

https://www.grbl.org/what-is-grbl