Aufero 2 setup issues

Hello all. First let me say I have an 80w import and am pretty versed in the basics of LB. I have just purchased an Ortur Aufero 2 and on initial set up my when my laser homes to 0,0 (front left) it bangs a few times and stops. The issue is when I hit the get position button on LB it shows me at -585, -585 and no where close to 0,0. How do I change that to 0,0? LB has no problem finding and IDing my laser, and my jog buttons work, just has me at that weird negative location. When I instruct it to go to 0,0 it moves to top right and bangs again and my postion is still negative on both axis. I will also add this is fresh LB install so it’s not any issues with my other laser settings.

Did you add limit switches and enable homing since that machine doesn’t come with homing switches.

The firmware on this machine complicates the normal procedure to correct for this. However, this other user was able to install the firmware from an Aufero 1 to get this to work.

Check out this Topic:

Im aware it doesnt have limit switches, and Im not seeing how that user was able to get their 0,0 set correctly

Did you read through to the end? He loaded Aufero 1 firmware and applied a few GRBL config changes.

Didnt realize there was a whole thread there, just looked at your quoted reply. Pretty fed up atm, this is why I went from a K40 to Ruida based laser as GRBL and I do not get along. Just dropped a ticket with Ortur, going to see what they say before I start a deep dive into this machine. At this point I may just send it back as this is becoming more trouble than its worth

For what it’s worth the challenges with this machine has nothing to do with GRBL in general and everything to do with the firmware on this specific model of laser. I think this may be the only time I’ve seen an implementation that basically made using offsets impossible or impractical. Well, that is outside of manufacturers that deliberately lock you out of making changes.

One thing you could try is to issue this command after homing:

G92 X0 Y0

You will need to also change this setting to have the machine report working position instead of machine position:

$10=0

Revisiting this. It occurred to me that perhaps you didn’t realize that you’re not supposed to use automated homing with this machine.

I believe the intended method to use this machine is to start the machine with the laser head at front left. This is manual homing. After turning on the machine it should be set to 0,0.

You are not meant to use the homing button to home.

I actually just got a message from ortur support and it along those same lines, I will be trying that after we eat, early dinner for my son’s 22nd Bday. Thank you for all of your help, I will report back on this later this evening or tomorrow morning

From Ortur support:
Greetings

Aufero 2 has no limit switches so you must
a) confirm you are running latest firmware, otherwise update firmware
https://ortur.tech/firmware/AL_Series/AL2_Firmware_Release_1.87.zip
b) once done the start up procedure is slightly different from AL1

1- Move the head towards the front left, making sure th emetal parts are in contact
2- Power on the Aufero Laser 2 – you will notice No motion. and a blinking red light
3- Connect usb cable to computer – BLUE led will get solid
4- In lightburn connect to the machine
5- In lightburn PRESS the stop button (The $x command to unlock)
now both red and blue LEds will be solid and machine is ready to be operated nromally

I have tried these steps and they have worked as promised (and not much different than @berainlb suggested)

Thanks for your help and patience, after a late night last night and an early rise my patience was thin to begin with