Cannot connect Lightburn to Gweike laser via ethernet

Trying to connect Lightburn to Gweike laser via ethernet requires the IP address of the Ruida controller. On Gweike, there is not an interface to the controller. How can I find the controller IP address?

There’s been some speculation about this on the forum but haven’t seen anything definitive about how ethernet can be setup on Gweike Cloud without the panel.

Here’s a video from Gweike about Wifi. It’s possible that the ethernet device is configured to the same IP or possibly another IP on the same subnet. From the video it looks like Wifi address defaults to
Tutorial of Gweike Cloud WIFI Connection - YouTube

Here’s a link to a topic that discussed ethernet setup for the OmTech Polar laser which is a closely related device.

It’s likely that Gweike is setup similarly. The Polar has a default IP of It’s likely that Gweike does something similar and defaults to a specific IP. I would look at perhaps these addresses:

If you’re familiar with networking perhaps you could scan across a wider range of addresses to identify the IP.

Tried those IPs with no success. Finally got Gweike to say the static IP was but that did not work either. When I connect ethernet from laser to router the IP address of appears, however, that IP also does not work in Lightburn. That IP also appears with DOS command of “arp -a” showing all connected IPs.

How did you configure your computer or network for this? Ruida’s in general assume a subnet mask of so you’ll need to make sure you’re working in that space.

Where is this appearing? Are you able to ping this IP from your computer?

Separately, what is the local IP for your computer and subnet mask normally?

The appears in the router admin showing connected devices as well as DOS commad “arp - a” and it does ping. I’m thinking mabe that is just the Gweike internal wifi and not the controller.

Connection-specific DNS Suffix . :
IPv4 Address. . . . . . . . . . . :
Subnet Mask . . . . . . . . . . . :
Default Gateway . . . . . . . . . :

I haven’t made any computer or network changes, I’m just using the various IP address in Lightburn where it asks for IP of Ruida controller.

If configuring LightBurn to doesn’t work then I suspect your best bet is to assume that is the correct IP.

Try this:

  1. Manually configure the IP of your ethernet device on your computer to be with a subnet of Gateway likely doesn’t matter but set to
  2. Directly connect your computer to laser
  3. See if you can ping
  4. If that works then configure LightBurn to and test

Thanks for all your help. That did not work either. I’ll just have to live with connecting via usb for now until my brain gets unfried (I was a computer programmer for 35 years). Gweike online support is useless. Only reply I get is to download DingTalk app to text with a technician but I could not get that to work either. Online support says its too inconvenient to be a middleman They did however give me the IP for controller that did not work in Lightburn.

That’s too bad. At what step in the process did it not work?

Everything works via usb. Connect ethernet cable from laser to wifi router. Trying to create device connection in Lightburn. Click devices, create manually, Ruida, Ethernet/UDP, Enter IP address, set dimensions, set origin, finish. Connection fails.

Sorry. I was asking specifically about the last attempt at ethernet. I had listed 4 steps so was curious at what point it failed.

Sorry. Step 3. Ping timed out

Maybe try using an IP scanning program?

Try this:

-reconfigure your ethernet adaptor to IP with mask
-use something like ‘angry IP scanner’ to scan all IP’s from to

If that turns up nothing - try the 10.x.x.x range e.g.

-reconfigure your ethernet adaptor to IP with mask

-start by scanning all IP’s from to

Here you can see the scanner found my ruida at

1 Like

can u help me plz i paid for a license key and put my wrong email in

Took a long time to run but no results. I contacted Gweike support and they told me Lightburn only supports USB and does not support ethernet connection. I corrected them and asked again what the IP address was. They said Gweike has no IP address. When I told them it has an ethernet port and must have an IP address they referred me to tech management. They are supposed to email me a response in the next few days.

Is the ethernet port actually patched into the mainboard? Do you get a solid LED light at the PC’s ethernet port?

The other IP range to try is to

Hopefully you will get a more informative response from Gweike soon!

Must be some kind of wifi daughter board? - perhaps it is not independent - but bridged to the ethernet in a way that precludes it from other use.

*Hi! I got mine working with the gweike cloud and ethernet. I have not got it working with LightBurn over ethernet though, only USB. But I can’t remember if I tried originally, I’ll have a fiddle with it now! *

To connect it for cloud:

You first have to connect over wifi just once as part of the setup process. This video has the instructions: User Guides of the GWEIKE CLOUD 3D Laser Printer - YouTube
And the wifi username and password should be 123456789.

You don’t have to use the same computer to set it up (I had to use my ipad because the PC I wanted to run the machine on doesn’t have wifi capabilities).

Then after that the ethernet works on cloud, when you plug the laser into your router.

Update; I’ve tried to connect via ethernet both to LightBurn and Gweike’s offline software to no avail.

I have contacted Gweike support and after a bit of back and forward this is what I have found out…

Their board only supports ethernet for the purpose of transmitting image data, not connecting to the controller.

This means that when I thought I was connected via ethernet, the laser was sending image data via ethernet and control data via Wi-Fi to my router, and I was connecting to both of these through the cloud software via the ethernet on my PC.

This all means that LightBurn has no way of controlling the machine via ethernet, because we can’t connect to it fully. :frowning: I have suggested they update their website, with the below to help avoid further confusion for us;

I will next explore whether I can connect lightburn to the camera only via ethernet, using the method Oz describes here: Lightburn camera on ethernet connected pc becasue at least that would help with the camera dropping out all the time (I have this issue with basically every job. :neutral_face:)

Sorry for the earlier confusion!

I have made a post here with all the info I have learned about using the Gweike pro with LightBurn:

Same results here. I can connect to gweike via ethernet but only through the gweike cloud software and not via Lightburn. USB works fine with Lightburn so I guess I’m stuck with USB cable for now.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.