Cannot connet to Server due to network error

I have downloaded and installed the latest version. When I try to start free trial, I get the message “Failed to connect to server due to network error”. I have tried turning off firewall on laptop and on router. I have also tried port forwarding. I haven’t had any luck. It may very well be that I missed something in trying to get Lightburn to see through my network. Is there another way to get it working? It is very likely I will buy it after I have tried it as I have heard a lot of good things about it. I just want to see how it works first.

1 Like

Where in the process is it showing you this? Do you already have a trial key?

Can you attach a screenshot of what you’re seeing? The team is out for the holidays so if this is something on the server side you’ll likely have to wait but maybe it’s something simple.

Consider also to install using “run as administrator” if you are on a windows machine.

Is your computer connected to the internet? Is LightBurn allowed to use the network? (some systems require that you give each app permission) Are you on a school or corporate network that might be blocking things?

Yes it is connected to the Internet. Is it allowed to use the Internet? I believe that it is. That is, I installed it the same as any other Windows app. I turned off Windows Defender. In Defender with Advanced security created Inbound and Outbound rules to allow Lightburn.exe send and receive and did the same for SendUDP.exe. In the router, I turned off security and I tried to set up port forwarding. Not sure if I did it right. This is for Home use and is not connected to any school or corporate network. Hope that helps.

To reply to the other thoughts. Yes I tried running as Administrator. When you start Lightburn the first time, it immediately pops up a screen (License Page) with a button “Start Your free Trial”. Clicking on that produces the message after several seconds. I have no trial key.

Take a look through this Topic. It may help you:

Try this command in a powershell:
Test-NetConnection -p 443

Does this return true or false? If false that means there’s something preventing you from getting to the port.

If the above returns false, let’s see if your DNS is at least working correctly:

Are you getting an IP address returned? Should look like this:

Name                                           Type   TTL   Section    IPAddress
----                                           ----   ---   -------    ---------                               A      60    Answer                               A      60    Answer

Thank you for the suggestions.The Test-NetConnection returns failed.The Resolve-DnsName returns Type= A TTL=57633 Section=Answer IPAddress=

To add a little more.The Test-NetConnection returns failed but also says Remote Address: Remote Port:443 Loopback Pseudo-Interface 1 SourceAddress: PingSucceeded:True PingReplyDetails:0 ms TCPTestSucceeded:False

Looks like your DNS resolution is actually not working. It’s showing your loopback device which is basically your own computer.

What are you getting if you run “ipconfig”?

IPConfig gives along set of numbers for the IPv6 address. The IPv4 returns the ip of the laptop and subnet mask The default gateway returns a string of numbers and

I’m specifically interested in the DNS portion.

I should mention that my Provider is Comcast. The DNS servers are 2001:558:feed::1and also 2 and 75:75:75:75 and 75:75:76:76

I will have to sign off in a bit.

Are you familiar with how to change the DNS setting for your network? You may want to temporarily change the DNS server to complete the trial registration.

Some of the largest public DNS. Take your pick:

  • Cloudflare: and
  • Google Public DNS: and
  • OpenDNS: and

Once done, you can switch this back to whatever you had.

Sorry, no idea how to change the DNS setting. How do I do that?

I am looking up how to do it now

I’m not on a Windows 10 system so can’t verify the exact steps but take a look at this:
Windows 10 Configuration – OpenDNS

Thanks for your help.It didn’t work but I will try again in the morning. I may have missed a step.
Signing off

Hi Leed3, when you set the firewall don’t only allow 443. We allowed the full address ( for it to work.
The answer was in the topic linked. :smiley:

Thanks. That got it working.