Can't get LB bridge to connect to laser

Heyo,
My fiance set up a homemade raspberry pi bridge for me today. I’ve gotten so far as to getting it connected to my WiFi network and getting LB to recognize the bridge. Where I’m getting stuck is on the bridge connecting to the laser. I did go in to the lasers IP config and change it, based on the instructions in the bridge documentation. Does anyone have an idea of what the misstep is here?


Try LightBurn Bridge. :slight_smile:

This runs software to help with the UDP issue on Ruida controllers.

I’d configure it the Lightburn software.

If you can’t get it up for some reason, I have a bridge and I have the ruida set to a static ip within the lan range. Set the Ruida to reflect the local gateway. It should connect right up.

I’d highly suggest the Lightburn software be running on the Pi :crazy_face:

:smiley_cat:

Did he connect the ethernet cable from the pi, directly to the Ruida controller Ethernet port? I did that and it didn’t work either. I reconnected the external port to the Ruida controller and connected the pi to the external Ethernet port and it worked. I haven’t had time to troubleshoot it, but it might need a crossover cable between the pi and Ruida.

Hello, I’m the fiancé in question! I’m a web dev but not a network guy, so I’m comfortable making config changes but a little lost when it comes to subnets/gateways/etc.

I’ve set the laser’s gateway address to 192.168.86.1 based on the output of an ipconfig/all:

I’m still stuck, but here’s what I’ve tried so far (they’ve all failed):

  1. Setting the laser_ip field in bridge.json to 10.0.3.3 and setting the laser’s IP address to 10.0.3.3
  2. Setting the laser_ip field in bridge.json to 192.168.86.28 and setting the laser’s IP address to 192.168.86.28
  3. (Assumed this one would fail) - Setting the laser_ip field in bridge.json to 10.0.3.3 and setting the laser’s IP address to 192.168.86.28

I did make sure that 192.168.86.28 was a free address on my network, and for each configuration I tried LightBurn has been able to see the bridge, but still says “No Laser Connected”.

I’ve got a Raspberry Pi 3b that I flashed with the latest (at the time of writing) LightBurn Bridge image which is LightBurnBridge-v1.0-RC4.img.xz. The Pi is plugged into the ethernet port on the back of the machine (not the one inside the machine).

Hello,
I ended up setting the gateway address in the controller to the sub-net mask: 255.255.255.0 and it hooked up like a charm. Give it a try.
Cheers,
Dave

Did you go through LightBurn Bridge setup?

You should also read up on the LightBurn Bridge Configuration Options.

Good luck :slight_smile:

:smiley_cat:

Whoops, deleted my own post somehow.

Yes, the LightBurn Bridge setup page is what we have been using for instructions on how to configure and set up the Bridge.

and the configuration option page?

Yes, the Pi Bridge has been configured per the instructions on that section of the page.

If it’s up and your happy, I’ll cease and desist… and you can skip the rest :slight_smile:

Their docs say if you leave the laser set to it’s default ip then it should just connect. It claims it will provide a wifi access point… Do you see some wifi connection associated with lightburn?

There is something about that address you’re using that, well, looks bad… Not sure what, but…

As long as you’re going through the Ethernet of the laser. My Ruida controller shows when mine is on-line, I think it says ‘lan on’ or something on the bottom of the display.

If you want to try and change it, I’d would go back to ground zero (as far back as possible) and try the procedure again. They have had very few problems, considering what they are doing. I haven’t found mine yet, so I’m not much help, but I use Linux pretty much exclusively.

:smiley_cat:

Hank: Incorrect. The Pi wired connection absolutely does not need to be the same subnet as your WIFI. They actually have to be different for it to work.

1 Like

I’ve never had an issue with getting the Pi to connect to the Bridge, and have not had to change the gateway mask either - I’m not even sure that’s used, as I’ve never touched that on any controller I’ve owned.

The connection between the Pi and the laser is completely independent of your local network, with the only caveat being that they must be on a different subnet. So, if by some chance your WIFI router is set to use 10.0.3.xx as your net, you’d need to change the bridge config to use a different subnet to connect to the laser, or the Pi will try to route the traffic through the WIFI instead of to the laser.

Something you can try - browse to the Pi on a browser - Since yours is 192.168.86.28, plug that into a browser and you should get a status dashboard telling you some simple info. There are logs you can check, just in case anything crashed or threw an exception.

I would try connecting a network cable directly to the Ethernet port on the Ruida controller itself, not just the plug in the case - sometimes those short extension cables are faulty, or not connected internally, so going straight to the controller is a good way to check. Also, try a different network cable from the Pi to the laser, just in case it happens to be bad.

1 Like

I am also having the issue of it connecting but says no laser connected. Was there a fix figured out in this topic?

A little confused - looks like you have a WiFi network called OMTech2. Is this the WiFi network that both your computer and the bridge is configured to connect to? Mostly the name is throwing me off, like it’s one of those Ruida WiFi relay devices (the ones that are just AP mode WiFi dongles).

Same message (No Laser Connected) as in picture at the top of thread, but probably completely different issue. I have a NEJE Master 2s, but no ethernet connection–only USB. So LB sees the bridge (on a RPi 4), at IP 192.168.7.234, but not the laser. Google and forums have vague references to this for NEJE, but I thought I had seen somewhere that LB Bridge on a Raspberry Pi 4 should allow a USB connection between the Pi and the laser. I (in my own simple brain) thought the Pi would translate the ethernet messages over to the USB path. Thoughts?

May have my own answer:

I’m guessing my problem is that the LB Bridge is really just for Ruida controllers? Not GRBL?

I know there is a layer of code in the pi to deal with the udp issue in Ethernet. I feel pretty confident it’s been tested with USB, but don’t know. Don’t remember anyone mentioning it…

Yes, I do remember, now that you reminded me… I try and forget usb…

:smiley_cat:

No need guessing. :slight_smile:

The first sentence from our documentation on the LightBurn Bridge:

The LightBurn Bridge was created by LightBurn to get around some of the limitations of Ruida controllers. - Intro and Setup - LightBurn Software Documentation

Hi everyone! Sorry I disappeared for a bit — thank you all for your suggestions!

I have it working now! Thanks to @LightBurn for your in-depth response. You clarified that I was on the right track initially, setting the laser_ip field in bridge.json to 10.0.3.3 and setting the laser’s IP address to 10.0.3.3. Just for good measure, I also set the gateway address in the machine to my subnet (192.168.86.1).

What ended up being the fix was plugging the ethernet cable directly into the port on the controller, the external port’s adapter must not be connected/working on my fiancée’s machine.

Thanks again everyone, I hope this helps someone else as well!

1 Like