CH340 - failed to install (please advise... maybe wrong settings? thanks!)

Dear Fellow Lightburn users!

Essence of my problem is that Lightburn (and other similar software, like UGS) fails to communicate with Arduino.

I am building my own laser cutting machine, which is controlled by Arduino. The setup so far looks like this:

  • Arduino communicates through COM3
  • GRBL 1.1 installed
  • CNC Shield on top of Arduino board
  • a single A4988 on slots X of the CNC shield - NEMA 17 stepper motor connected
    The above is tested and working fine.

I wanted to test the correct installation and setup of Lightburn (UGS also tried). I wanted to see the stepper motor moving - to see if “at least something” is happening. I experimented with Machine Settings, but received the message: “Communication with controller failed”.

When I klicked on the “Start” button just to provocate the software to do some motion, the error message was “There was a problem sending data to the laser. The machine may be busy or paused”.

I discovered that I do not have CH340 driver and I suspect this is indispensable for the communication between Lightburn and Arduino. (Is it really indispensable?)
I downloaded the driver and tried to install it as shown in many youtube videos. The results were as follows:

After klicking on the “Install” button, the below message appears - as if the driver was already(?!) installed. NO it was not. I checked in Device Manager and it did not appear there. (see two screenshots below)

I tried to “uninstall” it and install it again, but after klicking on the uninstall button, I receive the following message:

It seems as if there was no driver to be uninstalled! This is a self contradiction!!

I checked on my device manager to see what I have. It looks like this:

Képernyőkép 2022-08-03 162434

As I said: Arduino communicates on COM3 - so far so good. But where is CH340 then? If it is successfully “Pre-installed in advance” as the first dialog window says, then why do I not see it under Arduino Uno (COM3)?

I have tried several times, but it seems to me as if the new to-be-installed driver “sees” as if a CH340 was already working on my computer and then fails to install “again”.

COM3 and GRBL are configured in Lightburn like this:

Képernyőkép 2022-08-03 165331

How can I make Lightburn be able to communicate with Arduino? Please advise!

Thank you in advance!

it really seems that CH340 is not installed, where do you get the driver? download LaserGRBL and install the driver from that software, even if they seems similar are not.
look at the date of yours and mine :wink:
ch340

Thanks Rob! Yes I experimented with that also, but I tried once more again. Exact same thing happens:

And in the device manager I should see CH340 somehow like this:

Képernyőkép 2022-08-03 183739

But NO, for God’s sake, it is never there! (the screenshot is from LaserGRBL help page).
I understand and see what should (!) happen, but it is just not working :(.

Thank you for your quick response!

… more ideas???

Thanks!

I use Linux, but there’s a utility that I use often, ‘lsusb’ apparently there is a similar animal in windows… Might give this a shot…

My little CNC shows ‘QinHeng Electronics HL-340 USB-Serial adapter’ with lsusb.

:smile_cat:

1 Like

try also to follow this tutorial

Thanks Jack!

This is a bit of a rocket science for me, but I am trying. I think (do I understand you well?) that I will need to remove USB devices and I suspect: install again from scratch. This is what I am trying/experimenting with now. Thanks again - will keep you posted about results :wink:

Thanks Roberto, I found the same youtube video also… They always show how things SHOULD be… but I still keep returning to the same problem as I described in the beginning. … will keep trying - thanks again

What is does for you is tell you what the os thinks is hanging on there. If you can’t see it displayed, the os probably can’t talk to it.

One of the reasons I dumped windows back in the late 90’s… they obfuscate everything and it doesn’t have the simplicity of Unix.

:smile_cat:

1 Like