Circular array with numbers not working-BUG?

I keep getting bad char when I edit circular array using numbers

I make a circle and run numbers around the circle and if I do 1,2,3,4,5,6,7,8,9,10,11 Some number when I edit the text the number are distorted or missing. I been able to repeat ths BUG?


Can you include a screenshot of what you’re seeing and also attach the .lbrn file here? Will be easier to tell what you’re referring to.

1 Like

I trying to build and circle array starting 1 to 11. I try to edit the second number and it in these screen shots



prr staging yard.lbrn2 (59.0 KB)

Did you remove the numbers in the .lbrn file before saving? I don’t see any there.

I’m not able to reproduce the issues that you’re describing. Can you give some more detail about what you’re doing and how? Also, how are you getting that “Edit Text Shape” dialogue? I’ve never seen that.

Check an updated version of the file. Can you see the changes? I guessed at what you were going for just to see if it would work. Note that I had to flip horizontally and rotate since I have a different origin.

prr staging yard.lbrn2 (64.3 KB)

Sorry I did not save the file with a problem try this file. I trying to number from 1 to 11
prr staging yard.lbrn2 (62.7 KB)


Here is how I have produced this previously, which might work for your application. :slight_smile:

And the step-by-steps…

While I am showing a clock face, the concepts remain the same for any amount of numbers and their location in the array, think gauge dial as an example.

I can’t see the issue that you’re having. I modified the numbers from 1-11. Do you see the problem in this screenshot?

prr staging yard.lbrn2 (64.3 KB)

You may be seeing the shift due to how you have the X-Alignment of your text set. I set mine to ‘Middle’.

I tried changing a few things. It may be a windows thing. Still not working-See picture 3 The number 2 disappears when I edit the numbers 1 to 2. and after I edit the number and confirm by entering the 2 disappears Not all numbers disappear. I tried a new drawing and it worked. It something in my file?


I directly edited your file for the screenshot so I don’t think it’s something in your file. Have you had a chance to review the uploaded file?

When the numbers “disappear” is there still an invisible object there? Or it’s gone entirely?

I found the bug. When I zoom in the 2,3 etc numbers disappear. If I zoom out the all the numbers appear.

See screen shot


Oh… I just recreated the issue. It’s only there if you edit the text from Edit Text Shape dialogue.

@Rick, something to take a look at.

Here’s what things look like right before opening the “Edit Shape Text” dialogue:

Then the ‘2’ disappears as soon as select “Edit Text Shape”:

It does not come back after hitting OK.

This is on version 1.0.06.

I can confirm this aspect of the bug as well. That’s weird. It reappears after zooming out to a certain level:

When visible, the number isn’t fully selectable but it does show some sort of blue dot handle:

If I move the blue dot, I can then select and move the number:

1.0.6. Thank you for confirming it not me.
I am new to your software. This is one of the feature I like about your software


Thank you for the appreciation but this is certainly not my software. I’m just another user like you.

Where do we report this problem?


We just did. @Rick who’s been contributing here does work for LightBurn and others from the team are active on the site.

Also, @adeak1rr I don’t think I made it clear but I never saw the issue because I edited the numbers directly. As in double clicking on the number and editing in-place. The issue never arose there. You can use that method as an alternative to allow you to keep moving.

Thank you both for reporting this.

I am currently running a beta candidate (hint: note title bar :wink:) and I’m unable to reproduce. The issue may have been addressed already in this version, so I will check.

In the morning, I’ll try again with 1.0.06.

(results with your [prr staging yard] file, using 1.1.00 beta on mac)

And thank you, @berainlb, for pointing out Double click edit is working as expected and is a viable alternative at the moment.