Communication problrms

I can no longer communicate with my laser with USB and not with Lightburn bridge. My setup:
Windows 10
Lightburn 1.3.01
Acer Notebook
Starlink network
OMT Polar 350 Laser Ruida RDC6442S

History: My Laser is a new machine. Out of the box it ran great for about 3 weeks, but then started having error messages “There was a problem sending data to the laser. The laser may be busy or paused.” Now it won’t process any laser cut files and all I get is the above message and the status light around the large button on top of the machine turns red (error). The only way to clear the error condition is to recycle power. My computer has three USB ports, two of which I know to be in good working order. I’ve tried multiple USB cables on both working ports with the same results. I’ve noted that after clearing the error neither USB port is entirely dead becuz you can still jog the machine and configure it over USB, it’s just when you send a lightburn file for cutting the error happens almost immediately and every time.

I was going to try a ethernet setup, but my router has no ethernet ports (without spending $$$) so that is out (for now).

I do have everything needed for a Lightburn bridge so I installed this on a RPI4b using the instructions in LB documentation. After installation and power up the bridge shows up on my network and I can ping it and use Angry IP and my router assigned it The problem is the laser is not recognized (and I used Rdworks to set the ip address When I open up a browser window and type the bridge for an address it returns a normal status page and links to log files that I’m including.

I: don’t care about the USB, if I could get the bridge to work that would take care of my needs, as of now I’m dead in the water…

lbrelay.txt (6.7 KB)
lbnetwork.txt (201.3 KB)

How are you doing this? I had thought a control panel was necessary to do this directly at the controller.

If you login to the Bridge, can you ping the controller?

If you open up RDworks there is a aux window called “Laser Works” that towards the bottom of this window is a section called “Device”, click the “Settings” button and you will be given the opportunity to change the address.

I did try to login the bridge pi. I logged into it successfully but afterwards I couldn’t issue any commands below the LB banner, I used Putty ( SSH like) to do this.

This isn’t setting the IP address of the controller. This is defining in RDWorks the address for which to connect to the controller.

As far as I know, the only way to set the IP address of the controller is through the display panel which may prove to be a challenge on your laser.

Well, if this the case I guess I’m screwed. I searched the machine configuration files using Notepad++ (changing nothing) searching for IP addresses and found one which was As per the owners manual this the address for the default WIFI install, That is compatible address for my network ( but I’ve read posting on this forum indicating WIFI and UDP isn’t a good combo for error free data xfer.

I appreciate your information, I guess my reading of the laser’s owner manual was incorrect…

So does your manual indicate that you should be able to connect through IP?

Does the laser come with WiFi installed? The “factory” option I’ve seen for wireless Ruida controllers was using a rebranded ethernet to WiFi bridge so would be nice if that’s changed.

Are you able to ping from your computer? If so, make sure it’s the laser that’s responding by pinging again with the laser off.

Where did you get these files?

So does your manual indicate that you should be able to connect through IP? Yes, but I have never been able to do so.

This is from the Laser’s owner’s manual which is the only info I have on the machines networking:

3.9 Wifi Configuration
Check your local wifi networks to see if “Polar350” already appears. If so, log into it using the default
password 123456abc.
If it does not appear, you may need to reconfigure your own device’s TCP/IP address. The default address
of the Polar 350’s wireless network is You will need to set your computer’s wireless network
card to use a similar but not identical address. Use 192.168.1 for the first three sections and choose a unique
value for the last section. Typically any value from 2–252 except 47 and 100 should be ok but avoid any other
values that are already being used by your other networked devices. Use the subnet mask
Enable wireless control in RDWorks by going to Device at the lower right. If you cannot find it, go to
View (ALT+V), deselect System Work Platform to remove it from view, and make sure that Process Control
Bar is selected for viewing. If Device is still not visible at the lower right, use your mouse to raise the Laser Work
menu until Device becomes visible. Click Setting. In the submenu that will open, select Add on the bottom
left. Toggle the selection to Web, enter the IP address if it is not automatically generated,
and select OK. The wifi connection should automatically be set for use. Click Exit, confirming and saving
your changes. You can now use Device’s drop down menu to switch between using the cable connection
(“USB:Auto”) and the wireless connection (“IP:”)

Sorry for the formatting, it was a cut/paste from a PDF file.

Where did you get these files? They came from OMT on a thumb drive.

Looks like the laser wifi is setup to act as a WiFi Access Point. Have you tried checking for “Polar350” in the available wifi networks on your computer?

I’m curious if Ethernet shares the same network information. Are you able to temporarily plugin the laser to the router? Does that allow you to ping

Looks like the laser wifi is setup to act as a WiFi Access Point. Have you tried checking for “Polar350” in the available wifi networks on your computer?

Yes, there is a Polar350 listed in the available networks. I selected it and connected to it and it says “secured” and “no internet”. I then right clicked and selected properties and it brings up v6 IP address which I don’t know how to translate into v4 ip address.

I’m curious if Ethernet shares the same network information. Are you able to temporarily plugin the laser to the router? Does that allow you to ping

A starlink router has no ports for ethernet so I can’t do the above… I guess at this point I should locate the ruida inside the machine to see if all connectors are connected , fully seated, etc.

This is kind of making sense with their odd instructions then. There’s likely no DHCP server on the AP. Try manually setting an IP in the same 192.168.1.x range while you’re connected.

Seems WiFi is basically functioning. From what I saw of a board photo the ethernet jack is directly soldered to the board but I could be misremembering.

This is the info on the properties of Polar350:

SSID: Polar350
Protocol: Wi-Fi 4 (802.11n)
Security type: WPA2-Personal
Network band: 2.4 GHz
Network channel: 8
Link speed (Receive/Transmit): 130/130 (Mbps)
Link-local IPv6 address: fe80::f6cf:3ace:d396:e73d%9
IPv6 DNS servers: fec0:0:0:ffff::1%1
Manufacturer: Intel Corporation
Description: Intel(R) Wi-Fi 6 AX200 160MHz
Driver version:
Physical address (MAC): AC-67-5D-43-73-2B

I found a ip6 to ip4 converter, but it couldn’t make heads or tails of it:

IPv6 and IPv4 actually run independently of each other unless there’s a specific mechanism to handle interconnection. There’s no need to chase this down.

Did you attempt manually configuring an IP?

What OS are you running?

“Did you attempt manually configuring an IP?”

I have a OMT Polar 350 without the external control panel that would allow one to set an IP address for the laser." You also indicated yesterday that RDworks cannot do this. Do you know of anyway this can be done?

“What OS are you running?”

Windows 10.

BTW, I sent OMT technical support an email requesting help changing the laser’s ip address so I can use LBB software. The laser has a default ip of, that I suspect was done without a control panel so OMT should be able to help… I just need to change the ip to for LBB to work (as I understand things…

have you looked for just a machine console to just plug into your Ruida?

Might be more simple option.

There is nothing in the machine settings that relate to IP, so unless OMTech can help, you might have a problem…

I don’t know about the bridge, but I think it’s pretty much hardwired for the Ruida machine default.

Only person I know of, would probably be @adammhaile, I think he’s got rather intimate knowledge of the bridge software.

As far as I know it isolates the Ruida on it’s own 10.0.3 subnet… don’t know if you can use the 192.168 addresses as a subnet, if that’s also your regular local network…

Seems like this is going to come up with these machines not having a machine console and set to a very common lan address.

Be interesting to hear from OMTech on how to resolve this…

Good luck


I meant to manually configure an IP on your computer, not the IP on the controller.

Take a look here:
How to set static IP address on Windows 10 - Pureinfotech

You’ll want to do this on the WiFi adapter. The one that you’ll connect to the Polar AP.

On my original post to this thread I described my problems using USB and that was my impetus for going to the LBB. Yesterday, I stumbled across You Tube video that shows how to fix this problem. Here is a link:

(start watching at 4:46)

This is the exact same problem I have been experiencing! I was stunned at how simple the fix was. I tried and my Laser is working! Many thanks to :Unemployed Redneck Hillbilly Creations.

I did the fix and at least the Polar 350 works using USB.

I hope this helps others.

Since USB has it weaknesses I’m still pursuing the LBB bridge and I’ll let you know what OMT has to say about changing the ip address…

There is a way to add external Ruida keypad to a Polar 350.

It was the switch on the table he had to bend?

What is that switch do?

Thanks for the video, nice to see one where they power cycle it and you can watch it home … nice he took the cover off so we could see the Z axes…

How does the run/reset button work…? do you hold it down for a reset operation…?

I’d suggest a software reset, which should work as well as a power cycle… much better for the machine and it’s electronics…

From what I’ve seen, you just buy one and plug it in… Of course you need to put console somewhere… 3d print…?

I don’t know if you have room inside for a case mounted panel… replace the run/reset button…?

I’ve seen the consoles for around $100 US at a few of the sites…

This might be the most simple solution.

Good luck


I bought the Ethernet connection. Ran the Ruida on it via the lightburn bridge.

There were difficulties with using my external routers on it… never resolved them… probably my lack on knowledge…

Apparently RDWorks looks like it’s a way to change the machines IP. I didn’t try it with the Ruida connected, but it appears the settings are there. Don’t know how wifi is connected through all of this.

Don’t know if this actually changes it on the Ruida, seems there is reason to believe it’s only for RDWorks…

Hopefully I’ll have to time just run out there and try it out… proof is in the pudding.


This doesn’t change the default IP address of the Ruida controller. The only way to change that address is with the external key pad which my machine lacks. Thanks for your input. Also OMT tech support is clueless in regards to this issue. If your ISP assigns you an IP subnet address of anything other than your OMT Polar 350 is not networkable, without the external key pad, which costs about $100 and takes about a month to get. This is also true for Light Burn Bridge set up. In this situation all you have are the USB ports to communicate with your laser.