Computer Cannot Find My Laser Engraver - Missing CH340 Driver

Lightburn was working perfectly with my Lenovo/Windows10 machine and my Atomstack A5 laser engraver. However. when I moved to an HP Zbook (also Windows10), I found that Lightburn was unable to find the engraver. The laser discovery window remained blank, and when I manually defined a device with the appropriate Grbl parameters and tried to print a pattern, I received a message saying that Lightburn could not find my laser device.

Comparing the Lenovo and ZBook device listings, I found that on the Lenovo the laser device was defined as β€œCH340 Com4” while the Zbook identified a USB Serial Port with an unknown driver. More significantly, the Zbook device manager did not show any Com ports.

I installed a CH340 driver on the Zbook (there are multiple download sites available in the internet) and restarted the Zbook. The device manager now showed a Com port, and Lightburn located and initialized my laser engraver immediately, and I had no further operational problems.

But I did want to share my experience, since possibly the most recent generation of laptops are being shipped without a Com port driver. Lightburn requires a logical Com port.

Hi, this is extremely useful for people.

I wonder if you could also make available a link to the 340 driver you found to work, it may also help save some false starts :grin::scream:

Windows 10 does not include the driver for the CH340. Windows 11 might, Linux and MAC do.

Also, since you have solved this, it would be worthwhile to others if you mark it solved.

1 Like

I downloaded my ch340 driver from CH340 Drivers for Windows, Mac and Linux (gogo.co.nz), but only because it was the first entry returned by my google search.

1 Like