Connecting to laser USB but saying disconnected

I am trying to connect my HP Intel I am having 1th Gen Intel i5 with a 64-Bit operating system and it’s running on Windows 11 Home
but I am having one helk of the time trying to get this program to see my laser
i am trying to use USB (I already went and bought a new one thinking the one the laser came with was just bad) but we are still having the same issue. I have installed and uninstalled this the lightburn app so many times and also the driver. Every single time it never sees my laser when setting it up and then when i got to my laptop it never shows the driver being there under drivers (so don’t know if that is my issue) I really need help before I go crazy -----> seriously 3 days of this and watching every youtube on the planet and i am doing everything they are step by step and theirs goes to ready and mine -------> well it just stays at disconnected and no device found at the bottom

Thank you so much in advance

telling us what laser you have might give us a clue…

1 Like

i am so sorry - i thought i mentioned that but after looking i did fail to do so. it’s a RM 750

Did you try and set it up manually.?

I had difficulties with usb, so I moved it to Ethernet. I advise this on windows as it bypasses any driver issues.

You should not have to install/reinstall this. If you have issues, post them here…

You do have to have the correct driver… I run linux so it’s not a worry for me.

Try it with the manual install and see if you have better luck. If possible, switch it to Ethernet…


i just went and got a usb/ethernet adaptor since my laptop doesn’t have an eithernet port. Hoping this will do the trick - I will keep y’all posted.

Thank you again,

ok i seriously am about to lose my mind over here

went the ethernet route and it still will not see it

i don’t know what to do anymore

i even tried to set up manually

what am i missing? anyone? I am LOST



sorry just saw i was typing in all caps

How did you setup your IP address on the computer side?

Did you follow the ethernet setup guide and FAQ?
Ethernet Connection to Ruida Controllers - LightBurn Software Documentation

So I did exactly what you said to do and still nothing - still is saying no device found and disconnected

I really wonder if the ports are bad or the port to the controller is bad or I really don’t know cause the controller turns on and you can do things with it but it just will not read from the laptothp to the controller

This shouldn’t be this difficult at all I have seriously done everything step by step and changed the IP on the controller like they said and put that into lightburn when asked to do it and NOTHING

What is the IP on the computer side?

Can you run ipconfig /all in a command prompt and return results?

What happens if you try to ping the controller from the computer?

What IP is the controller configured for?

So I have now tried to plug the ethernet straight into the controller and still nothing. Do you think that there is a chance that I have a bad controller? I can manually do lines and stuff just not reading my computer still and lightburn. This again is a brand new machine RM Laser 750 with the Ruida controller which is model RDC6442S. Now by looking at the new controllers it looks as though this one is discontinued and there is a new model out. I am just wondering if it’s even worth trying to go through warranty because that right there has been a nightmare and of no one calling me back as I got it from TOOLOTS (that is where I probably went wrong) lol
Thank you again for your help everyone - I really appreciate it!

Thank you

The problem with plugging in to the Ruida directly is that the port of your computer probably is looking for an IP address from the DHCP server.

I plug mine in directly when needed. I have Ubuntu (Linux) and I set the IP of that port to the Ruida Gateway address and use the ip of the Ruida to talk to it.

Doubt it’s the Ruida, it’s more than likely just isn’t configured properly.

Might not hurt to post what the IP are for everything and see if we can spot the issue. Make sure you add in how it’s physically connected, directly or via a router.


Are you interested in troubleshooting or are you resigned to replacing it? I suspect you’d be in the same boat even with a replacement.

i have been trying to troubleshoot it but the company we bought it from is never available and i have been trying for 2 weeks now
i would love someone to call and help me figure this out. that is why i am reaching out on here to see if anyone else has ever had this issue when getting a new laser and what the solution was.

Agree with @berainlb, doubt it will fix the issue.

We are willing to help you…


If you can provide the details from my previous post I can review to see what might be the source of the problem.

@jkwilborn @berainlb
I appreciate all your help and here are pictures

here is my computer ip information

You’re not showing an IP address for your ethernet connection on your computer. How is your Ruida connected to the network? Do you have it connected to the wifi router? Or are you plugging in directly from computer to Ruida?

If you plug the Ruida into the wifi router you could connect wirelessly from your computer but want to confirm what your setup is.

Can you run this command in a command prompt and then return results: