Connecting to Ruida

I have a new green/black 50w Chinese laser (pic below), I connected the water, air and exhaust :+1:

finally connected the computer and opened lightburn and… nothing :frowning:

no connection.

I’m connecting to the “usb interface” port on the machine (pic below), is that correct? Is there something I need to do on the laser machine to initiate the connection?

Help! :upside_down_face:

(Thanks in advance)

Edit: There are 2 UBB plugs on the machine, no info in the manual about what each does

Screen Shot 2020-02-19 at 9.58.15 PM

Have you tried again connecting to the second one (USB outlet)? :slight_smile: One of these is for communicating with the controller, the other is for file transfer via USB stick.

Hello,
Your computer talks to the usb interface, top one. The second one is for USB file transfer with a thumb drive stick, udisk on the controller.
Cheers

@HPRS_ENGRAVING, Thank you. I hadn’t seen them labeled as shown above so thanks for the clarification.

@NewbDudey, If you look inside the cabinet, you should be able to trace those USB connections to where they connect to the controller to confirm. As David said, UDisk is for USB file transfer with a thumb drive stick, the other is the one you want to use to connect your computer to the laser. Do this and run the ‘Find my Laser’ process to complete the setup.

Let us know how you get on.

Thanks for claering that up :slightly_smiling_face:

Connected to that, ran the find my laser and nothing is found :frowning:

Minutes later its still on this screen:

Hello,
Just go back and add it manually.
image

image
Pick Ruida from list select next
image
Select Serial/USB than next
Name your device and enter your x and y lengths for your work area
image
You may have to add the drivers that came with Lightburn for the usb port to work
That should do it.

I have the exact same machine.
No trouble connecting to the USB or LAN.

I installed Lightburn with the additional USB drivers and connected the cable from the pc to the USB INTERFACE port.
To be sure you can also check if the USB is connected to the controller board on the inside.
And even connect it to the board directly to take out the little cable/interface connection.

If you are still unsuccesful I would try the LAN option and/or connect the laser to a laptop to see if to rule out any other things.
(With LAN I manually added the controller)

Thanks for replying guys, and especially for the screenshots :kissing_heart:

Followed the screenshots and added the machine, but not connecting :frowning:

I think the problem for me is the “additional drivers”, I’m trying to connect via my Mac - suggestions for where can I find drivers for a mac?

You should lead with that next time - Mac is a different animal. The drivers for the USB chip used by the Ruida often conflict with the drivers that ship with MacOS, so you have to remove one of them.

You can set up with Ethernet to bypass the issue: How do I connect a Ruida controller with Ethernet?

Or you can follow here to solve the driver issue: https://superuser.com/questions/1135730/how-to-release-reset-serial-port-ftdi-devices-mac-osx

My bad :stuck_out_tongue_closed_eyes:
I keep forgetting how much this b!tch is hated by “normal” people :laughing:, but I got stuck with one because of work and then just got used to it…

Thanks for the Ethernet link, will try that and post back here :slight_smile: :+1:

Ok, followed the instructions there, did a scan of my local ip and it was 192.168.10.151
I then changed the machine IP to 192.168.10.51
Picked Ruida and Ethernet connection
Added it and… nothing :frowning:
No connection :frowning: :expressionless:

Then had a look at the USB solution :

Quoting from the Superuser solution there:

What seems to have worked for me is actually removing the FTDI driver ( /Library/Extensions/FTDIUSBSerialDriver.kext ), after finding that Apple ships an FTDI driver with the OS itself ( /System/Library/Extensions/AppleUSBFTDI.kext ).

Not sure if it’s hidden on my version of MacOs Catalina, or missing, or a different place (etc) but can’t find either of those FTDI drivers in the directories listed above…

I installed the Mac drivers from here:
http://www.ftdichip.com/Drivers/VCP.htm

still nothing :frowning:

Ideas?

Make sure the Ruida is plugged into the network with a cable, and check that the display says “Lan: On” in the lower-right of the Ruida controller panel. Check that you don’t have firewall software preventing LightBurn from talking to the controller. You should be able to ping the controller from the command line and have it respond. If you get that, the connection should be ok.

Lan is on, unable to ping it… :frowning:

Then something is preventing it from getting through. Firewall, cable, connection, etc. You can try plugging the network cable directly into the Ruida controller inside the machine, instead of connecting to the extension wire on the outside of the box. Sometimes the extensions are bad, or just not connected at all.

Ok, will try that and get back to ya here tomorrow:slightly_smiling_face:

I have a plan B:
I dug up an old Win machine from my drawer, loaded LB and it works on it, found the laser machine no problemo there!
Problem is this machine is an old laptop that overheats :frowning:
at least I know it works, except with one quirk:
I press the left or right button in LB and the laser head moves left or right, but up and down are reversed! Pressing up goes down and down goes up…

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.