Data Transfer Failed after update

Just updated LB to latest version. Running Win 10, Ruida 6442S. Keep getting error message-
“There was a problem sending data to the laser”.
I made sure and deleted any files I had on the machine.
I usually connect via Ethernet. Figured maybe something was bad so I tried USB with no success. Any thoughts?

Which version are you running?

Can you try one of the 0.9.24 tests posted here?

I downloaded the 9.24 windows version.
I am now able to connect via usb but not via Ethernet

Double check to make sure that nothing else on your network in conflicting with the network connection / IP address. If your computer has a network connection to the Ruida with a cable, but you also use WIFI, turn off WIFI and try it again.

I turned wifi off, still no connection. When I ping the laser I get positive results. Any suggestions?

How, specifically, are you connected to the laser? Cable directly from the Mac to the controller, going through a router or switch, or something else?

What IP address do you have assigned to the laser, and what is the IP address of your computer?

my pc is connected through a switch.

Laser IP:

Laptop IP -

The weird thing is that everything was working. I have always used the same Ethernet connection without any issues.

Not sure what else I can do

I appreciate you taking the time to answer my concerns

I think you may have an issue with the addressing. 192.168 then one system is set to 5 while the other is set to 4. Is your switch managing this route for you?

I am not sure if that was the issue, once I changed the laser IP to I got a connection and am able to cut.
The laser ip used to be but once I did not get a connection I tried changing the 4 to a 5. Now I am back where I started but it works!
Thanks for the help.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.