Updated to 0.9.23 and cannot send jobs to laser

I’m running on Mojave and having the same issue! It was cutting and as soon as I updated it the machine stopped moving, it’s showing in the control panel as it was running a job, but nothing happens!

ha! Ooops … sorry I typed in a flurry… so I’ve now reverted back to 0.9.22 and that’s working fine but for 0.9.23 I was able to send jobs to my laser when I created shapes from within lightburn. When I imported/tried to open any files I had created in illustrator I was not able to send the job to the laser.

When I say it would not send, there was no error message flagged so I thought it was all fine but when I went and used the laser trackpad to get the file - there was nothing there… I connected via USB and followed the exact same steps that ‘doublekscreation’ & ‘Zturn’ noted in the above thread. I can control the framing of the job from my laptop but the job does not start from my laptop.

I’m on macOS Big Sur. Not sure how I restart my Ruida 644XG as ‘Zturn’ suggests this could fix it.

Same issue working great until I updated to .23 using Mac. worked great yesterday.
Extremely frustrating working on a large commercial job…

Just updated to .23-2 and it goes 90% and stops this is the exact thing that happened with the .21 update it didn’t work then would go to 90% just a bit frustrating

I cleaned out the local Apple store a few days ago, and now have four different systems - Intel / Mojave, Intel / Catalina, Intel / Big Sur, and M1 / Big Sur.

I’ve been working through the serial transfer code for the past two days solid, and I now have what appears to be reliable communication on the first three systems (I haven’t tested M1 / Big Sur yet). I’m going to get builds posted online after doing a bit more testing.

I will post a link to those builds to this thread so anyone who wants to try them can do so. If you do, please give feedback as to whether it worked for you or not, and with what kind of system, so I can figure out if we need more coverage or not before releasing into the wild.

1 Like

Ok, these links are to the various test builds that will eventually become release 0.9.24:

Anyone having issues with the current release, please download from the appropriate link above, try it, and post your feedback in this thread with the following info:

  • What version did you download?
  • What OS and controller do you have?
  • Did it work, or fail?

I’ve tested this on all the systems I have, and it has worked for me. This does not address the issues with camera connections on Big Sur, but the Mac (Older) version might work for that.


It works.
Downloaded the MacOS (Older)
I have 10.15.7, Ruida 455G controller.
Camera still causes the software to close unexpectidly, but software appears to be communicating with laser and making cuts.

Running on a MacOS Mojave, Ruida RDC5121 controller and now it worked with the new link :blush:

Ok so I just updated LightBurn (the one you have the link here so like it is now fully completing jobs!! Here is some feedback I have I know you said in the post there was some camera problems I have Big Sur and a Logitech camera it is partially working I can see the laser working but it will not put a picture in the workspace also loving the dark mode!!! It needs a bit of tweaking some of the tool bar buttons are a bit hard to see as I’m sure you are aware.

This is known, and not going to be quick to solve unfortunately. Can you try running the non Big Sur version to see if that works with the camera? And yes, Dark Mode was forced on us by the Big Sur version, so we’re going to need to add code to detect that and negate all the icon images and text colors. That’s going to take some effort.

Yes the non Big Sur macOS version works with the camera (I didn’t test anything else in it)

Update, the software did crash on me once, wich never happened before with the older versions.

Hi Oz,

I downloaded MacOS (Older)
Running Catalina and Mojave. Rudia 644XS
Worked on Mojave but did not work on Catalina.

Following, Same problem with Ruida 644xg. It will send and cut a file initially, but I when I got to calibrate the camera I get the machine may be busy error and subsequently it fails to send jobs to the cutter at all. OSX, High Sierra, USB. Problem happened after update, it was cutting last week.

The google drive link for Older Mac OS isn’t working for me

Here is what I see when hitting that link. What do you see?

It wouldn’t download on Safari, it just hangs. I downloaded on Firefox on a windows machine, installed the update on the MacBook that runs my laser and things are working!

Odd, I am not having issues using Safari to complete this download, but glad to hear you have been successful using another browser.

I have the 50w CO2 laser with the topwisdom controller. i tried both of the mac versions but nothing is coming up. still shows that my laser is disconnected. What is interesting is the asterick showing the connection is by the laser and I can move the laser by changing current position but anything else does not work and still says disconnected
I currently use a mac with the Catalina 10.15.7 operating system.

I downloaded the MacOS Big Sur 9.22 and everything works fine now but camera. How do I know what controller I have?