Distorted Image. Anyone have this problem?

I’m working all the kinks out of a new to me redsail x900 60 watt and ran into this one tonight.

This file was sent to the machine and I ran the program from the machine memory not from the laptop.

This is the first image I have engraved (tuning the speed and power at this point) since enabling scanning offset.

I tried to search the fourms but haven’t found anything relatable as I have no clue what to call this.

Any ideas?

Looks like a mechanical problem with slipping belts or pinions.

1 Like

That was my first thought. But ruled it out because the edges line back up as the engraving continues upward from the bottom. Or am I thinking about it wrong?

Is there a way to look at the “code” of the file sent to the machine. Like you can with gcode and notepad?

Good point.

I got nothin’

How fast is the work going? Possibly too fast for the motor and skipping steps. All motors are different and the speeds are different. Try to slow down

Or your file is too big or resolution too high, the controller cant handle it.
It might work if you delete the other files from the controller.

no you cannot look at the code, but how does the file look on the controller screen?

You may not be able to look at the g-code sent to the machine already, but you can have Lightburn save to file, and then look at the g-code there. It will be the same as what it sent to your machine.

Could you post the lightburn file and or the rd file?

This is a Ruida DSP controller - it doesn’t use GCode, and the format it does use isn’t human readable.

Well that answers that question…

@LightBurn I have since removed a usb hub that I had in the machine to connect the controller and a lightburn camera to one usb cable. Both the controller and the camera kept disconnecting at random. This is why I sent the file to the memory. Do you think the file could have become corrupt as it went thru the usb hub?

Is there a reason you don’t use ethernet to connect?

1 Like

I would be all over it if my controller had one (unless I’m blind and didn’t see it).

It’s a 644XG


1 Like

@Bonjour This is what I have.

you have Ruida 320

The control panel for RD644x and RD320 is the same. Bad sellers take advantage of the fact that the buyer does not know many features. It is possible that the stepper motor drivers are not of the best quality. Check all mechanical play and jamming. Try to reduce the speed of work. Very often a bad motor driver breaks down, try swapping them

1 Like

It’s not impossible - I have seen issues with some hubs when doing that, as the camera pushes a LOT of data - it’s quite close to saturating the USB bus all by itself. The Ruida, on the other hand, uses a lower speed device that caps out at 3Mbits (300 kb/sec), so there should be enough, but it could also depend a lot on the connection quality and the hub used.

If that was sold to you as an RDC 6442XG, you should hit them up for your money back.

That’s what I thought it was but LightBurn shows it as a 644XG so I assumed it was a 644XG.