"Dotted" line on y axis


I have problem with Chinese (Sihao/Vevor) 50W co2 blue/white laser with rdc6445g controller.

The problem is since the machine came, when I try to engrave something, the lines are “dotted”.

But the dotted lines are only when y axis is in movement. When I try to do straight horizontal line, the line is smooth as it should be.

Here are things I already tried:

Perforation mode is off
I tried multiple settings provided by other users with same laser like frequency on laser (currently 20khz etc, nothing helped)

I tried to check mirror alignment again
I tried to loose/tight belts again
I swapped x and y drivers and it is still the same
I tried another lens but didn’t help either

The speed I was using for engraving was 5mm/s, 10mm/s, 20mm/s, 40mm/s, 100mm/s etc. but no change

Any idea what could be wrong?

I was thinking that the stepper motor could be faulty, tube is not in Tem00 mode, power supply is not sufficient etc, but I have no clue where to start.

I have at home spare 40W tube and 40W power supply, can I try to use 40W tube with 50W supply in machine / 50W tube with spare 40W supply to see if any of this component is faulty?

Also, the driver has programmable output of ampers and pulse/rev, should I try different amps or pulse/rev?

Thank you for any advice!

I rotated this so it’d fit comfortably on the screen… It’s the third vertical line group. Top is to the left.

I marked the apparent scan direction, but it appears to change as it move down the object… Might help if we understood how the artwork engraves.

If it’s a new machine, don’t go hacking on it until we have some idea of the issue. In other words hang on before changing out the tube and lps… It seems like that’s being controlled…

Is the apparent ghost line intentional?

@ednisley may have something to add…


Typically, “engraving” refers to an image or a filled region that’s scanned with lines traveling left-to-right at relatively high speeds

If I understand correctly, you’re using the term for a line or curve traced from end to end at low speeds, presumably at very low power.

The cut edges of the acrylic sheet don’t show the same dots at any angle visible in the pictures. Is that true for all the cut edges, regardless of their orientation?

Perhaps a reflection from the bottom surface?

Thank you for your responses!

Sorry for misunderstanding. I meant cutting and not raster engraving.

It is only reflection and not ghost line. :slight_smile:

Sorry, I am not sure if I understand correctly the question.
The dotting seems to be different by angle it cuts. When I cut only from left to right (y axis is not moving), then the line is smooth as it should be.

Does the orientation of the material change this? Or is only about the direction of the cut?

It doesn’t appear to me as if it’s lasing properly but it could also be some other type of issue… If I look at the photo even the horizontal lines are not right.

The red is where it’s not lasing or damaging the material as it should. I only marked a few of them. The green are corners that are malformed.

I assume you are using scan angles, like 0 or in 90 deg increments…? If not these would not be handled by the Ruida… it would be implemented by Lightburn…


In the picture of the cut shape with “Alex” on it and your fingers in the background, all of the outer edges seem to be smooth, regardless of the direction they were cut. If that is correct, it suggests the dots depend on the laser intensity, as well as the direction of motion, but it may also be that higher intensity melts the dots together on the edges.

What are the X and Y stepper motor driver settings?

It is only about direction of the cut, Ive also tried plywood but no difference. I mainly use cast acrylic which is on other engraver OK.

That rectangle was with different setting that I was trying. Im including more detailed photos from today with complete lightburn settings.

I think the dots depend on the direction of motion, since when I am engraving square etc, the top and bottom lines are smooth and the problem is with the left and the right one.

It’s in attachment. Also the seller suggested me to try swap x and y drivers (they are set on the same settings - 2 and 7 on) but nothing changed.

I uploaded the photo of the stepper motor - I already tighten the screws on the rod before.

Also I noticed that on the ruida display the already cut areas have little dots - is that only low screen resolution problem or it might mean something?

Thank you everyone for your time and I would like to let you know that I appreciate it a lot!

This is certainly true; I’m trying to rule out other possible influences.

The Idle acceleration used for cuts seems unusually low and there’s no need to derate the speed and acceleration, so

In the Cut Parameters section:

  • Change `Idle Acceleration from 200 mm/s² to 1500 mm/s²
  • Change Accel Factor to 100%
  • Change Speed Factor to 100%

In the Y Axis Settings:

  • Change Jumpoff Speed from 15 mm/s² to 20 mm/s²

Compare the results with those changes to what you saw before, using identical layouts and speeds. If the changes are “better”, that suggests other tests to try.

Additionally, have you checked your laser alignment? What does that look like?

Please add a photo of the dip switches on the stepper driver.

I’m guessing your stepper driver is probably set to 2000 microsteps/rev?, try increasing that to 4000, which should reduce your step length to half of what is currently is, and may give you a smoother output with less resonance.

Also, make sure your belts aren’t too tight otherwise you can generate vibration from the belt teeth.

I did not see any difference with new settings

I think it should be ok.



it is in the pictures above. If I read it correctly it was set on 2500. I set it on 4000 (5,7,4 on) and I think it improved the results.

I did this with the step above together and the results are getting better. Now the dots are not that much periodic as they were before.

This is 20 mm circle

I also don’t understand why the circle has so wavy lines (7mm/s speed and 11% power). If the belts would be too loose than the lines wouldn’t connect at the top together, right? When I tried to tighten them little more than the periodic dots appeared again.

Also I noticed before that the laser dot seems a little bit odd. It is not perfect circle, even though this tape was on mirror 3, when I tried it right before the laser tube the results were the same. I am afraid if the problem could be with tube as well?

I even tried to rotate the tube 90 degrees to see if there would be any change (I thought that when it was glitching on y axis then after change it should glitch on x axis) but nothing changed.

The original setting:

  • 1-2-3 = 3.1 A
  • 4 = half holding current
  • 5-6-7-8 = 5000 step/rev

Your new setting:

  • 4 = full holding current
  • 5-6-7-8 = 4000 step/rev

Switch 4 should be OFF, because half current is enough to hold the motors in place when they’re not moving. Setting it ON keeps the motors hot while they’re idle.

If the 4 is a typo and you really meant 8, then it’s set to 3200 step/rev.

Either of those changes will reduce the machine’s resolution, but the fact that the dot spacing did not change is significant.

Did you recalibrate the controller’s step size after changing the switches?

Because the dot spacing does not change with either speed or motor step size, it is neither a mechanical resonance nor an acceleration issue.

The picture of the Y axis drive pulley shows what looks like very fine tooth spacing, at least in comparison with what’s in my machine. I wonder if those pulleys do not match the belt, with the pulley having twice the tooth count = half the belt pitch.

If that’s the case, then you’re seeing mechanical glitching as the belt teeth jostle into position on the pulley.

Figuring that out will require an inspection mirror, uncomfortable contortions, and a permanent marker to keep track of the tooth count.

What is the tooth pitch on the Y axis belt? Measure the distance spanned by 10 teeth, then divide by 10 for a better number. Remember that the first tooth counts as “zero”, so mark one tooth, count off 10 teeth, mark the last tooth, then measure.

How many teeth does the pulley have around its circumference? Mark a tooth, then start counting as you move the belt by hand; I must mark every tenth tooth to keep track.

What is the diameter of the Y axis drive pulley at the top of the teeth? This is not the pitch diameter, but it’s close enough.

Does one tooth on the Y axis pulley fit neatly into the space between two belt teeth?

Does one tooth on the Y axis belt fit neatly between each tooth on the pulley?

Repeat that exercise for the X axis drive pulley and belt, which should be much easier.

In order to check your tube, you need to check it at the output of the tube, not m3.

Your Ruida display is rather odd. I’ve seen this when I had multiple lines at the same position… don’t know how that would effect the output, but I’ve seen it on the machines screen console.


That’s funny, I somehow did not see the picture of the dip switches before but it’s there as plain as day now…brain fade!

If it was on 5000 steps/rev, and you’ve changed it to 4000 steps/rev then I suggest that you set all dip switches back to exactly how they were before (for now) so that you are investigating/changing only one thing at a time.

Because you noted that tightening the belts made the problem worse it is a good idea to check the belt pitch & pulley meshing as @ednisley has requested.

I have previously progressively loosened belts a lot just to observe the effect, and it is remarkable how long the output will stay fine, so in my opinion it is definitely far worse to overtighten than to be slightly loose with belt tension.

It was not typo. I thought that 4 is controlling step/rev and not ampers. :smiley:
Currently it is on 2 5 7, so it should be on 4000 step/rev. I also recalibrated step size accordingly.

10 teeth = 3 cm, so space between each should be 3 mm.


Should be approx 2 cm. Unfortunately Im unable to measure it 100% sure.

To be honest I am not sure about the y axis. I tried to shoot it on phone but it seems like there is a small space between the belt and pulley. I am not sure if this is considered like OK space or it is a problem.

belt length is the same: 3 cm for 10 teeth.

Will do on Monday, however when Im cutting it seems ok. It just seemed odd that the shape of laser is like egg rather than circle.

I tried to find the sweet spot between when the lanes are wavy and as they should be. Now they are much loosen than before and it looks better. However it is not good as I would expect since there is still difference between x and y cutting.

The belts look like a very possible reason why it is glitching. It might be worth a shot to try change belts and pulley since for me it looks like there is a gap between belt tooth and pulley (not sure if this gap is alright or is abnormaly larger).

Im just not sure if that would solve why there are dots even on complete straight lane.

Also I noticed that when I hit pulse button on machine and press y axis to go up/down then the lane is smooth as it should be.

It seems that if I cut fast enough then the dots disappear (approx 20 mm/s and more). But when I cut fast than the lanes are wavy. So it is either dotted lines on slow cutting or wavy lines on fast cutting. :smiley:

Your examination & pictures rule out pretty much everything I was proposing, which is good news of a sort.

However, the first picture of the Y axis belt on its pulley shows the belt jammed up against the left side of the pulley, without a flange to keep it in place. Having eliminated pretty nearly everything else, I wonder if this is a belt tracking problem: the belt wants to ride up away from the teeth onto the smooth part of the pulley and creates a dot when it snaps downward at each tooth.

On my machine, the idler pulleys at the front of the machine have flanges to hold the belt in place and it tracks near the center of the drive pulleys on the jackshaft across the back. They’re barely visible with an inspection mirror and impossible to photograph, but the teeth show on both edges of the belts.

Loosen the setscrews holding that drive pulley on the jackshaft and slide it a few millimeters to the left (toward the middle of the cabinet), tighten the screws again, then run the gantry back and forth a few times to settle the belt.

If that lets the belt track near the middle of the teeth, check the same thing on the other side. If they’re both tracking properly, that may improve the dots.

Make sure the belt is not touching anything between the pulleys, because that will certainly cause vibrations.

If it doesn’t track properly, that suggests the idler pulleys are angularly misaligned or badly off-center, but try a simple tweak first.

Thank you for your advice.

I moved the pulley as left as possible, tightened the screws, moved up and down for a few times and… the belts wants to go further on the left!

This is after moving the pulley:

This is pulley on the right:

It is quite on the right but it is not touching the flange yet.

I noticed that now It all depends on speed of cutting. When I am cutting slowly (5-15 mm/s) then the dots appear but it is rounded nicely but when I try higher speeds (20-60 mm/s) dotting is gone but there is the problem with wavy lines.

This is the best result I got today:

Also no matter how large circle I try to cut, there are always 4 same areas where the lines are wavy. It seems that when x and y axis are moving in certain angle than this effect appears:

Last thing I noticed today is that when I pulse the laser beam it seems like it is not exactly 90 degrees but more like on this photo:

I have to check tomorrow alignment again. But no clue how to help reduce the vibrations more.

That suggests the tracking adjustment is incorrect, which isn’t surprising, as the machine “worked” well enough to pass whatever criteria they use for final inspection.

The belt passes over an idler pulley at the front of the machine, in a place where it can barely be seen, with provision for tension & tracking adjustments. On mine, the pulley rests in a yoke passing through two slots in the machine frame with a pair of screws pushing against the front of the frame, almost inaccessible from anywhere I can stand.

Belts tend to drift toward the side with the lowest tension, which suggests you should tighten the screw toward the center of the machine. Mine have a jam nut locking the screw in place that must be loosened before turning the screw.

Good luck on not only finding the screws, but getting in there with a wrench and a hex wrench!

The stepper drivers in my laser are set to 5000 step/rev (switch 7 On) and yours are set to 4000 (switches 5 & 7 On). That’s close enough to make little difference, but you might want to change it back.

The belts have 3 mm pitch and the pulleys have 24 teeth, so the distance/step value at 5000 step/rev will be pretty close to:

14.4 µm/step = (24 tooth/rev × 3 mm/tooth) / 5000 step/rev

Which agrees well with the Machine Settings you showed earlier at about 14.3 µm/step.

That should be high enough to prevent any visible artifacts. Setting the drivers to 10000 step/rev (at 7.2 µm/step) and seeing no change will confirm the problem lies elsewhere.

Do you mean this?

I did this and can confirm that there is no difference.

Since the belt on the right side was still sliding on the left side of the pulley, I tried to move whole stepper motor to the left. Now the left and right side is centered but still nothing changed.
I unscrewed this 2 bolts and moved them one position to the left so the pulley on the each side are centered.

Now they are centered but still no difference.

Also I noticed that number 3 LED is on, does it mean something? (+ number 14 is flashing)

Last thing: Since this is cheap machine, do you think it would be possible that the material of the belt is too “tough”? So maybe if I would buy better quality belts it could help with something?

Because the vibrations seems really strong when I try the y axis movement. So I am not sure what else I could try to reduce the vibrations and help the problem.