Dual Solenoid Not Working

I have connected a dual solenoid system to my laser; however, air is not being emitted. For my high pressure solenoid, I have the positive end (red) attached to +24V and the negative end (white) wired to WIND (pin 5). For my low pressure solenoid, I have the positive end attached to +24V and the negative end wired to STATUS (pin 4). I have also included a diode in both of my solenoids. I have also checked and ensured that air assist is enabled in the machine settings by checking on both my controller and on LightBurn. I am not sure what is wrong. I am completely out of ideas. When running a job, regardless of whether air assist is turned on for a layer, the light for the low pressure solenoid lights up. I am not sure what to do. I would greatly appreciate any help. I’ve attached photos of my solenoids and wiring.

Without knowing which controller you have, it’s hard to be specific, but on my KT332N the setting in Menu → Para Setting → Auxi.Air must be Blow when cutting.

That setting does not appear in LightBurn’s Machine Settings list, but the Vendor Settings includes Enable the auxiliary air control, which must also be turned on.

More details on what I went through on my blog:

And then the dual-flow hack:

If fiddling with the corresponding settings in your machine doesn’t solve the problem, swap the two solenoids to see if one is a dud. I think you can swap the electrical blocks without disconnecting the pneumatic tubes, so it might not be as awful as it seems.

I have an RDC6445G controller

It’s never a good idea to run a solenoid direct from a controller. I would slave it to a relay.

I’m on your side, but the 6445 has a 500 mA output current limit with “reverse current protection” which seem like an internal diode to the positive supply. So, in principle, connecting a solenoid valve directly should Just Work™.

I’d run it through a solid state relay despite that, because SSRs are ten bucks and controllers are five hundred.

I went into my controller, and I did not see an “aux air” option under the para settings. The only aux. air setting I can find in the controller settings is Menu → vendor settings → aux air enable. The setting is enabled. Is there another setting somewhere else that I am missing?

That’s the one some folks miss, but it sounds like you’ve got that part under control. Out of curiosity, in LightBurn Machine Settings does it also show the same thing? I know you set it from the controller, just wanted to make sure Lightburn got the message and it got written. When you get that sorted, I agree with Ed, in another post I showed how I used a dual relay ( Air assist diode - Community Laser Talk - LightBurn Software Forum) to control the solenoids on my 60W OMTECH. Hope you get it figured out.

The nomenclature is, at best, confusing, but their English is way better than my Mandarin.

That probably corresponds to the Enable the auxiliary air control setting on mine.

I assume there’s another setting to determine when the air is active, because that’s how my controller works, but the RDC6445G manual is unhelpful and maybe the option does not exist.

The only advice I have is to go through all the possibilities and read the menus with the most generous interpretation you can, until you either find the treasure or verify it’s not to be found.

I think this is doubled posted…


Would not having an SSR be causing my problems? I just don’t understand why the solenoids don’t seem to be working at all. The controller shouldn’t be an issue because I have a status lamp connected to 24, WIND, and Out1, and it works fine.

Which isn’t working?


And on Wind you have a status showing it’s active?


Maybe is stupid question but why you need 2 solenoids?I have just one solenoid and he control high pressure.After solenoid I place T splitter connector and connect stock pump for low pressure air. Between T splitter and pump I place air flow control valve.In LightBurn I use air when cutting and turn off air when engraving( but air still comming from stock pump), program just turn off solenoid

Neither the low pressure solenoid or the high pressure solenoid are working. There is no air being put through whether I have the “air assist” parameter checked for a layer or not. I have double, triple checked that air assist is enabled in lightburn and on the controller. Is there a way to check that the WIND pin specifically is enabled separate from the “air assist enabled”?

I have two solenoids because I’m not using the stock pump. I wanted to use an air compressor for both the low and high pressure. I have a valve to decrease the pressure on the “out” of the low pressure solenoid. Does my version of LightBurn affect whether something is working? I have version 1.2.00.

Do you have indicators on the Wind and/or Status pins?


What do you mean by indicators? Like a light to tell if the pin is working? If so, no there is no light on my controller for my 24 and WIND pins.

Take a piece of wire and short the Ruida Status and/or Wind pin to ground.

That is all the Ruida does… You can do it manually and see if your solenoids are working…

You should either hear them or be able to feel the mechanical change from the vibration…


I don’t quite understand. So take a wire and connect it from the status/wind pin and connect it to the GND pin on the same line?

Your solenoid is connected to 24V, the other end to the Ruida Wind/Status. The Ruida is an open collector and effectively connects the pin to ground.

I’m saying you can do that manually and energize the solenoid… doesn’t matter who pulls it to ground.



So to test it, I can leave the positives connected to 24 and take the negative wire of one of the solenoids and connect it to ground? This should activate the solenoid?