Electric Solenoid Air Valve And Lightburn

I bought a electric solenoid air valve and installed it in my red and black ebay laser. And it works great when I turn it on at my control screen on the laser. Then when I go to light burn software to laser something (with the air assist on the software screen on where you set the speed and power window.)it turns the air assist valve off when I hit the start button to start lasering something. So I tried to the opps. (left the air assist off on the software) that did nothing. So I guess I need to know what in the software do I need to do something so it will control me electric solenoid air valve. Thanks you!!

What controller does your machine have in it?

Ruida with
Autofocus

A bit more here if you will. Model number and firmware version? Pictures if you are not certain.

ruida dsp does that help sorry new to this on here

Back up for the next picture please, can’t see the entire HMI panel. I have not seen a Ruida that looks like that.

Open the cabinet of the laser and grab some pictures for us. We need to see something like this:

What software came with this system originally?

Ah, this is why I was not up on it.

This might help: https://www.lasers123.com/home/essential-upgrades/air-assist

It says it is a Ruida Controller just the new style with auto focus.Here is the link where I bought it. Can you look it over? Preenex 60W 28"×20" CO2 Laser Engraver Cutter Cutting Engraving Ruida Autofocus | eBay

I do have it wired in just like your notes had in it. It works great as long as I turn it on manually until I hit the button in lightburn to run a job.

So what happens if you make a test circle in RDWorks and run it ‘in house’ so to speak?

I haven’t used Rdworks for a long time. I will run a test run in the morning. I’m kinda stuck on lightburn it is a great software. lol

Understand, just looking to narrow down the problem. Take everything but the Ruida controller and software out of the equation.

I do most of my design work in Corel, then dump to RDWorks for some layering and power settings, that’s about it. There are times I would like to have it for the camera feature, but can’t justify it for the single feature that I wouldn’t use all that often. And with Ruida working on a whole new revamp or RDWorks for multi file and a camera, I’ll wait a bit longer. I got the .49 beta with the camera feature in it, just haven’t played with it much. English documentation from a Chinese company on beta software leaves just a liiiiiiitle to be wanting for.

Where can I get the new Rdworks at with the camera features. I’m very glade for any ones help on here.

It’s a beta I got as part of trying to resolve a different problem. the .47 is the current stable version. You have to have .44 and above to set the air assist mode and use .17 or higher firmware. Didn’t get any documentation, and haven’t had time to try and figure out the calibration on it. For all I know it may take a special printout like LughtBurn to calibrate.

Like I said, my biggest problem was with the Laser Work window in the bottom right corner and my low res monitor, when I clicked on the User tab in the upper boxes, the read and write buttons were hidden behind it instead of coming to the front as an active window. You can grab the double bar of the Laser Work window and move it over and up, but it goes right back when you close and open the program.

I did have to chuckle when I first used it to set some pieces for cutting on some scrap.The arrow on the rotation box shows rotating clockwise, but the software actually rotates counter clockwise. Thought I was going crazy until I remembered this software was originally written in Chinese.

You probably need to get a firmware upgrade from Ryxon if you’re having Wind control issues. I think I remember there was an old (circa 2016) Ruida 6442 firmware with a similar issue. Since this Ryxon is a Ruida brother from another mother it is possible it has some of those DNA skeletons in its closet too. You may try contacting @abonventre (who was able to acquire firmware):

I figured it out. You have to go into lightburn machine settings and turn air assist on in there.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.