Enlarging my Ortur workspace

Hi there!
This is more of a ORTUR question then it is a Lightburn question, but hopefully I’ll get lucky and get a good answer.
I enlarged my workspace of my OLM2 from 430 on the Y-Axis to 1000. Big jump I know.
I found the settings in Lightburn to expand the working size under “Basic Settings”. Is this all I’ll have to do to enlarge my work area? Or will there be something I need to do update my controller?
Thanks!

Do you have a Y axis of 1000 mm? Like the physical rail?

Is this where you changed it?

1 Like

In addition to what @LaserWillie has covered on the LightBurn side you’ll likely need to change the GRBL configuration as I recall.

These are defaults on the OLM2 for the 400mm x 430mm workspace:
$130=400.000
$131=430.000

I presume you’d have to do something like this but please research this first as I have not done this myself:
$130=400.000
$131=1000.000

Note that $130, $131, $132 are used to set soft-limits in GRBL.

2 Likes

If they do this all it will do is cause it to crash into the side rail. A software change telling them the hardware is bigger won’t do them any good.

1 Like

@LaserWillie Not following what you mean by this. Can you elaborate? When I was working on a different issue where these values were set too small I was unable to use the full size of my laser.

If @Cowski has enlarged the Y-Axis component of his laser he would need to update his configuration to allow him to use the entire space.

Or is your assumption that no hardware change has been made? I didn’t get that impression from @cowski’s message. @cowski, if that is the case, then no, increasing the LB workspace and max travel limits of your GRBL configuration are likely to lead to crashing and tears. Otherwise, I believe you’d still need to make these changes or something similar. Again, please research this before proceeding.

@LaserWillie Elaborate if I’ve misunderstood you.

I’m not able to elaborate as they’ve not responded as to what they’re trying to do. Out of the box the diode is set for the physical size of the bed. If they think they’re simply going to plug in some software numbers and magically be able to engrave 100%+ more area then that’s simply not how things work.

1 Like

@berainlb I think is right in that he had to have physically made the machine larger. Only an idiot would try and stuff a 4x8’ sheet of plywood in a machine the size of a hat box. Hope I didn’t offend anyone…

The numbers in the Device settings under lightburn define your bed size and give you a grid to work with within the program. It will also notify you if your design is larger than the device settings indicate or goes outside the defined area.

Lightburn doesn’t look at the machines configuration of bed size as far as I can tell. If it did I wouldn’t have to tell it.

You can tell you machine to go 2000mm/s but if the configuration says it’s limit is 200 that’s all it will do. Similar, you can tell the machine to go to 400, 1000 but if the configuration is set up for 400, 440 it will only go to 440 or just choke. It may be options as in mine I can enable ‘soft limits’ but homing is also required.

The limits in the controller should match, if not you will have issues.

:smiley_cat:

1 Like

I was able to “test” shrink my workspace by changing those numbers in Lightburn. I made a 200x200 in LB, and it recognized it. Reset it to 430x400 and it resized it. Are you saying I won’t be able to take that to, let’s say 900x400 in LB and it won’t work?

If not, @berainlb you are mentioning changing $131 = 1000.00. Makes sense. Is this a file I need to edit or where do I make that change?

Thanks everyone for helping me with this. I very much appreciate it.

Making it smaller is not a valid test.

If you are driving your car around the inside of a building and you make the area smaller, there is no issue, make it bigger… :sob:

In ‘Edit → Machine Settings’ you can modify these…

Before you do… Always save the original configuration, so you can restore it if there is a problem.

:smiley_cat:

2 Likes

You shrank the size virtually. Since that area exists physically inside the workspace, it will work.

Yes that’s what I’ve been saying. There’s no way for the machine to physically go outside the boundaries. The workspace doesn’t exist.

The machine will hit it’s limits and you’ might get a lot of noise, some damage maybe or it simply won’t work.

You have to size the virtual machine to the physical limitations.

The resolution to this is ‘how did you do this’?

What @LaserWillie is suggesting is that you did not do anything to your machine you just want the software to make it bigger.

Now I’m confused. Did you make the machine physically larger to accommodate the extra area you wish to use. If the size from the factory is 400x430, software can’t make your machine physically larger. After modifying the hardware, you should be able to make it work.

:smiley_cat:

2 Likes

I’m pretty sure they only enlarged the workspace in the software. They didn’t modify the frame physically.

It’s like wishing you could run 10 miles without ever training to run. You can wish for something but you’re constrained by reality.

I’d buy a $200, 500 mw machine and purchase the software to make it a co2 at 150 watts… :crazy_face:

I hope this isn’t the road he’s going down.

Although I do like his cat.

:smiley_cat:

1 Like

I did make it bigger. This may change some of the answers to this question. I apologize if I confused anyone or omitted pertinent information.

2 Likes

This is very pertinent information. And that’s why I asked

Since you physically altered it you can do as @berainlb commented and you will be able to utilize the entire space.

When asking a question, please include things so people don’t have to do 20 questions and simply guess. It will save everyone time and energy and you’ll get better answers faster.

1 Like

ya think?

Didn’t think @Cowski was the idiot I had described… lol

:smiley_cat:

1 Like

I guess I assumed (I hate that I did that) everyone knew I physically increased it. It would make absolutely no sense at all, in my opinion, to increase the size in the software if you don’t physically have that space to use. Hence why I “assumed” everyone knew that. That’s on me for that. I take full responsibility for it.

Also…IN MY DEFENSE…my original post states:
"I enlarged my workspace of my OLM2 from 430 on the Y-Axis to 1000. Big jump I know."

So I did provide this information. I think someone missed it when replying. I probably should have thrown in the words “physically enlarged…

1 Like

It’s 2021. NOTHING would surprise me these days. The next few years are going to be wild.

1 Like

Your post was confusing all around. It was why I asked clarifying questions. It was the first question I asked. Either way, enjoy the new workspace.

1 Like

I think @LaserWillie sent us down the wrong road, even if he was right, depending on how you look at it.

You know what they say ‘assume’ really means.

If this is the worst that happens today, I’ll be tickled.

@Cowski you don’t have to defend yourself. 2 out of three got the message.

It’s a communication bump, that’s all… Like the USB plug fell out for a few, get over it…

Lets move forward…

@Cowski did you try the changes? (love your cat)

Like to know how it worked out… Curious how tight your alignment will be when operating…

:smiley_cat: