Error: 42 side laser randomly stops mid burn

I was running atzmer 10 watt laser then suddenly it started stopping mid burn. I assumed the laser was worn out so I used that as an excuse to buy a new laser. I purchased an omtech Light B10, only problem is it does the same thing. To top it off my buddy just got a laser and it’s doing the same thing. This is convincing me that it’s a software problem. I’ve searched the web and there is no mention anywhere of error 42. I use this laser for my business and I’m now way behind, please help

All my GRBL error lists stop at Error 38. You need to contact the manufacturer (or distributor) of which ever of the three lasers you are talking about. Until you know what that error means, you cannot guess as to its cause.

I had to do this with Sculpfun for some GRBL $$ parameters unknown to me.

I have not been able to speak to anyone at Omtech regarding this however I have discovered that if I turn off the air assist the issue seams to be gone. This sucks as my machine has built in air assist but meanwhile I guess I will hook up an external air assist.

Does it control the air assist pump, or does it actually power the pump from the controller board (the pump has no separate power supply)? If the second, the pump might be drawing too much current and causing low voltage on your controller board.

I’m not sure how the new machine (omtech Light B10) is running the air assist. The air assist is wired into the machine but the machine obviously has a power supply, I would assume they are using the signal to simply turn it on and off not to actually power the blower. My old machine (Acmer 10 watt diode) did not have air assist built in and it did the same thing which is why I purchased the new machine thinking the Acmer had bad wiring somewhere or the control board was going bad. I now have about 14 hours of cut time without an issue since I turned the air assist off for each layer. I did have one layer that I forgot to turn it off for and about 30 min into that layer it stopped again. The only reason the air assist was turned on for the different layers when using the Acmer is because it was automatically on and since it made no difference to my machine I just ignored it. I have since then experimented with the Acmer and it also works perfect with the air assist off. My friend who is having the same issue also turned off the air assist and now his is working fine as well. That makes 3 machines on 2 different computers all having the same issue, so at this point I am convinced that there is a glitch in the software. That being said I do not have the issue when using my co2 laser (omtech 3555 130w co2) which is a Ruida controller. And of course on my fiber laser there is no issue as it is a galvo unit. It seems like it only is affecting my machines that use a GRBL controller. Please feel free to correct me if I’m wrong about it being a software glitch, I’m still pretty new in the laser world and these are just my observations. Only thing that confuses me is the error 42. Like you said all the lists only go to 38. I have looked all over the net and cannot find anything where it mentions an error 42. But I got it from both machines as well as my friend getting it from his machine.

Some of the 32-bit builds are diverging away from the Typical GRBL builds.

When the Engraver first connects to LightBurn, there’s a few messages that go back and forth. Please open the Console window in LightBurn, Select that first connection message and copy it, then paste it into a reply here.

I’m hoping they left me a couple of clues in that connection / start message to point me toward which custom build might be throwing an Error 42 and why.

If you do not have 2 wires to the air pump, one to the controller and another to a power supply, it is powered by the controller board. Sculpfun’s new machines do this. If you don’t run the pump and the problem goes away, then the pump is bad.

The first Screenshot is showing the error code the second is what you asked me for .
error 42
Error 42 a

But my old machine did not even have built in air assist I just had an external air supply that was always on and it was doing the same thing.

Also I have 2 of the omtech Light B10 machines here and they are both doing it, so that would mean that I got 2 machines that are brand new with bad blowers

[MSG:Mist coolant on pin GPIO(4)] implies the air pump might be fed from a separate power source.

Clue #1.

Clue #2. With this info, I would be looking at the power source feeding everything. That separate pump should have has no effect on the laser operation.

I have tested my theory on the air assist being the problem here are my results. I have a Acmer 10w diode machine using an external air supply and I have 2 omtech light B10 machines both come with factory built in air assist. I have tested with each machine and the results were always the same. If i run a burn with the air assist turned on it will stop mid burn and give me an error 42 along with alarm 3 or alarm 6. I have not yet been able to determine why it is sometimes alarm 3 and sometimes alarm 6. However if I run with air assist turned off in Lightburn and just use an external air assist pump that is always on it will run the complete burn with no issues even with a 6 hour burn. I have also tested this by having the air assist turned on for only one layer. It will run everything until it gets to the layer with the air assist turned on and hen it will throw the code 42 along with one of the alarms. To elaborate a little farther, it does not throw the error code immediately sometimes it will run a layer with air assist turned on for 5 minutes and sometimes it will run for 2 hours before throwing the code. It has however failed to complete a single burn that is more than 5 minutes long. Since I have the air assist turned off I have completed over 36 hours of total burn time without any faults. I am running windows 10. Also just to reiterate I have not had any issues with my machine that has the Ruida control only my machines with GRBL. Please let me know if you need any more info or if you would like me to try something else.

If I run with air assist turned off in Lightburn and just use an external air assist pump that is always on it will run the complete burn with no issues. It only happens if I go to “cuts/layers” and turn on the air assist for the layers. My air assist pump is on a completely separate circuit. I have also thought it could be a power issue and so I checked the circuit that the laser is on and have recorded the power on this circuit with a Fluke-1732 Energy Logger I still have from my days as an electrical service technician. There have not been any accourances of any kind even during the time of the errors.

Try with Air Assist ON, but with the external pump.
If it runs, it is the other pump.
If it fails, it is the controller board.

Lightburn can be eliminated with a couple of GCode tests, but I don’t think that is necessary.

Tried with all three of my machines, also had my friend try with his machine. Everytime the air assist is turned on it throws error code 42. Sometimes within 5 min sometimes takes an hour or more but always before the burn is complete.

I’ve seen this sort of issue stem from an under-rated power supply on devices that use a relay to control air assist on/off. My Sculpfun S30 alpha unit had a board that reset when you turned on air assist, because it was drawing too much current from the anemic power supply. Sculpfun was quick to rectify with a new board and power supply. Perhaps you have another power supply on hand with the same plug polarity and more current capacity to test with?

I basically asked that you turn on Air Assist with this one. I know the air is always on, but I wanted to know if Air Assist ON had an impact with the air pump NOT cycling on and off.

Had the same issue yesterday on my new B10 so I reached out to Sakura on OMTech’s support team. He says:

“That is the smoke/fire alarm and they are very sensitive, you can simply disable it by hitting the white button by the LED light.
Is not the rotary one at the corner it is closer to the lights.
Please let me know if this helps.”

Also, sent him a link to your query as a shortcut to me having to explain exactly what’s happening to my machine :sweat_smile:. He’s looking further into it and I’ll let you know if he adds any other solution or insights.

Now we know what Alarm 42 is. Hopefully, they will provide the rest of them.

I’d like to confirm that the error message is the same. If you’re willing, please capture the error message with a screen capture tool as above. If it is, we should submit some feedback to the folks writing the firmware to update their error message around Error: 42

@Kurtzy - Thank you for the screen captures. This is interesting.
forum 112860 error 42 means Door Switch

Do you have the same error message for lines other than (On or near line 336:)?

Is the “Safe door err!” triggered when you open the door and is this the actual meaning of Error 42?

Door switch wiring could be intermittent or could behave like an antenna if there’s noise or static electricity around. Signal switches for logic levels are 3.3V or 5V and in the mA range so it’s an opportunity to use very light/fragile wiring. I’d take a very close look at the wiring, especially at the connectors and joints. Some manufacturers have excellent results with crimped terminals but some seem to have more variability in crimp quality than others.

Take a look at the position of the Door switch and confirm whether it can be adjusted or misaligned. If the switch is on the edge of working or not working this type of error will show up.

If the wiring looked solid and undamaged and if the switch isn’t on the ragged edge of its operating range, I’d move toward shielding the wiring, moving the switch, adding an optocoupler, or adding a couple of noise suppression components somewhere in the circuit.

This is also very helpful.
omtech B10 Light (which controller)

From this, I’m seeing that the B10 Light uses the MKS DLC32 as its controller. This comes from the MakeBlock team and I have one here.

If I were to guess, the 8M is memory and the H35 is the 3.5" screen. I have a scrambled H24 screen on mine. Version 4.0 looks new/custom firmware.