Error 9 when using outside

OLF 152.

[MSG: Flame detector Inactive. Luminosity too high]

Grbl 1.1f [’$’ for help]

[MSG:’$H’|’$X’ to unlock]


G-code locked out during alarm or jog state.

Hi I just got this it was smoking up my entire house so shocking response I brought it outside…Idk if there is some light or wind issue but it wont work. This is absolutely ridiculous. I try and google these codes and no one really gives answer. I try typing in those $H $X codes and doesnt seem to do anything. How do I fix this. Should be working out of the box and not have to deal with this crap

Hi, have you tried typing ‘error 9’ in the search bar, top right?
you’ll find a lot of threads about the error 9 problem and maybe the answer. :crossed_fingers:

I have tried. Nobody has answer. bought this junk for $500 might just return. Not crazy to expect to be able to plug in and draw a square without doing a scavenger hunt to solve unnecessary problems

[MSG: Flame detector Inactive. Luminosity too high]

That’s going to be the issue right there. If the machine has a flame sensor, but when used outside it’s in the sun and can’t tell if there’s a flame, you’d have to disable the sensor. I’m not sure how to do this, but @OrturTech would know, or you could contact Ortur Support directly.

I looked it up on Ortur’s site:

$261=0 is to disable the flame detection.

1 Like

$261=0 will disable sensor
However Flame sensor wont trigger Error:9 Something else is doing it above in the console but we dont have access to.

Also i would recomend updating to latest 1.55 version on the OLM2 Pro
A few important Error message changes and a few tweaks

Ok I will update. I brought it back inside and not working but I’m honing in on problem potentially having to do with home location. I think if I put the square near 0,0 area it is out of bounds of where the tic marks on my ortur line up as 0" 0". I’m going to update and look more into it after. Thanks everyone for the help was expecting no response!

I would go over the firmware update
Make sure to not bypass the $RST=* step to reset firmware to defaults

Then $261=0 if you wish to disable flame sensor (OR… if you prefer tape it over with black tape )

If you get other error 9 though, scroll up please and see if you see the error that put machine in lock state (which is what error9 indicates)
So something else, happened, that causes error9
The something else is important

So is this perhaps part of the issue? I had 4 different little squares down there I had and was not working. When I create new file and simple it down to one square and in corner I get this when I hit continue anyway it does not actually cut anything just gives this.

Starting stream
Layer C00
G-code motion target exceeds machine travel. Machine position safely retained. Alarm may be unlocked. (Right-click the 'Devices' button to reset the connection)
On or near line 4:
Job halted
Stream completed in 0:00
[MSG:Reset to continue]
Ortur Laser Master 2 Pro Ready!
OLF 155.
[MSG: Flame detector Inactive. Luminosity too high]
Grbl 1.1f ['$' for help]
[MSG:'$H'|'$X' to unlock]
[MSG:Caution: Unlocked]

I have the square at 9000 mm/s speed and 90 power fill. I presume may be too fast to be that close to edge. I tried lowering the speed and anything below 190mm/sec seems to work without that issue.

So if this is the case (and I presume what was causing other error) is this how it should be or should I change a setting somewhere? I’m just trying to do the old test a bunch of squares for different powers and speeds and what not. In practice should I be approaching this as dont plan to use faster than 190 mm/sec within (idk exact) 1cm of edge of 400mm by 400mm workspace

Alarm 2 will definitly set your machine in error 9 mode
What job start you using? Absolute coordenates?
Can you post a full screen of your lightburn?

if i had to make an educated guess i would say you using user defined job start mode

Yeah that is what the default was I’m not entirely sure what it means. I assumed home position was default (0,0). This is also my first time with lightburn as well as the ortur so forgive me for newness. Also the bad attitude from impatience lol

Try this file for me, Open it
Use some bit of cardboard please
Bottom left corner

Make sure Start From: Is absolute coords

Dot Test with Angle.lbrn (46.3 KB)

When done, take a image of the result engrave
If it fails please take image of console as you did before

Yeah that worked fine. Now even when I put that closer to the edge no problem. Now when I hit fill while close to edge then do get problem. I presume drawing a square as border it can handle but the perpendicular to edge back and forth of fill causes problem

Do you have a high overscan setting on the fill
Double click the layer and on fill mode check the overscan
if for example you set a 5% overscan on a 100x100 box that will be 5mm
So if your origin is at 0x0 and machine trys to ovescan 5% to the LEFT of zero it will for SURE cause issue
I am not 100% sure however if lightburn has built in procedures to avoid this @LightBurn

You can always judge the box in 5mm and verify if the problem disapears?

Closer one doesn’t work. Farther one does work

mmm makes no sense really
Did yoU $RST=* after firmware?
Can you type ## in console and tell me what outputs

also can you move head to center, press power and record the homing cycle in video. Maybe you can post it here . 10 seconds should sufice

Also on the error, it is Alarm 2?

I think overscan is off actually

No overscann would only be a thing IF you was at the very 0x0 edge which is not the case.
Something else is at play here

I think we should retrace our steps
a) if you can Edit → Device settings. Post please the screen image
b) Edit → settings > post image
c) $$ in console, post output
d) The video of homing if possible









































































Ummm bad news I’ve reached the maximum number of replies a new user can do and need to wait 22 hours…