Failed to connect to the server due to network error - Trial version MacOS

I just downloaded the trial version for MacOS (using macbook air M2, MacOS Sonoma).
The version was downloaded from the official site (Download / Trial – LightBurn Software) and I assume it’s the newest version (1.5.02).

I can install the software and can open it to the start screen.
When clicking on “Start your Free trial” an error window opens with the following text “Failed to connect to the server due to network error”
My internet connection is working.

I have seen that others have had the same problem on the forum. There also appears to be some solutions found for windows users.
Would appreciate if someone could help with this problem from a MacOS perspective?

Thanks in advance.

Uncertain if this could be a local or broader network issue
I am assuming you can connect to lightburn domain well as … well you are here! :smiley:

Do you have on mac any security software/Firewall or similar?

Edit: can you connect to this website. Is lightburn licensing manager

I can connect to the link, but don’t have a login.
I have innactivated my firewall, VPN and other types of security software. It didn’t fix the problem.

Probably should ask someone who has dealt with this… @Rick can advise you of the issue…


It’s a bit of a longshot but I seem to recall some of the Mac computers needing Rosetta. I think it was for RISC architecture which is Apple silicon (as opposed to intel). I’ll look into it.

Rosetta installation should not be the problem, as i can install and open the software, the problem is with activating the free trial.
However i tried Installing Rosetta (2), no luck with that either.

If anyone has any other ideas I’m all ears.

I share a few posts with options for connection and things to check. Please let us know how you progress.

1 Like

for the sake of diagnostic would this confirm or deny a “successfull” connection attempt?

Thanks for all the help.

Got it working. Not really sure what I did or didn’t do.
The only difference I found from previous attempts was that i updated a my VPN that had come with a new update (Nord VPN).
Although I don’t think that was the problem/solution, because earlier I couldn’t get it working even if I had shut down VPN completely.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.