Frame speed after update

with the new update, when i hit frame the head rapids to the area but then while its framing its terribly slow


Sorry about this! I found the issue and have fixed it. I will talk to @LightBurn today about how soon we can get a patched release out.


Speaking of which and since my laser is in the adjacent laundry balcony i would have loved having the option to SHIFT+FRAME for it to start “X” seconds after clicking and go “Y” given amount of times.

Please consider such option.

1 Like

Thanks for that! I’m having the same issue :slight_smile:
Just renewed my license a few days ago; keep up the great work!

Hi Squid, you can also make a ‘remote’ fairly easily, with which you can control such basics as framing, starting, etc.

See here: Numpad mask to control Ruida

I have tried that before to no avail.
I will give it another shot.

When I’m back at the workshop, I’ll make a screenshot for the setting in HID Macro that allows you to bind the Frame shortcut to for example the numpad enter key.

You’re the man,
Much obliged.


I’m in quarantine atm, sorry man, it’ll have to wait!

No worries mate. health comes first.
I as well self-quarantined myself, second week now.

So I was just back at the workshop for a bit and looked up the settings I use for HID macros.

So what you want to do is add a new Macro for each shortcut you want to use. Click the Scan button and hit the key on the keyboard you want to bind the shortcut to. Give the macro a name.

Now enter the following commands in ‘Send Keyboard Sequence’ for these shortcuts:

  • Frame: %r (= Alt+R)
  • Rubberband frame: %+r (Alt+Shift+R)
  • Focus: %+f (= Alt+Shift+F)
  • Start: %s (= Alt+S)

Note the bold commands are case sensitive. Let me know if you can figure it out.

Thank you very much. I followed your guide and this actually works and I managed to send commands to LB, however from time to time it wont send commands anymore and i don’t understand why. sometimes this works and sometimes it does not. Are you experiencing the same?

It should basically work 100% of the time as long as Lightburn is the active window/application. If you have another window selected, like a browser or notepad, HID Macros will simply send the shortcut to that application where it won’t do anything (or something unintended).

The one thing that doesn’t always work for me is jogging/nudging the laser head with the numpad keys (1-9). Somehow, if a shape is selected, the laser doesn’t (always?) move. Not sure if that is intended or maybe a bug.

The laser jog commands with the numpad are only processed if the edit window has the keyboard focus, meaning it was the last window you clicked in. If you click one of the data entry fields anywhere in the main window, we have to allow the number pad for number entry in those, so the jogging commands are disabled then.

1 Like

This goes without saying. what i did find out is that i need to run the app as administrator and it works much better when connected directly to my PC and less predictable when connected to laser usb hub which is 10 meters away. USB cable is active and works flawlessly even at 100mms/300dpi stream / engraving so i think i can rule out connection issues. I am still investigating what goes on under the hood. it might be my win10 acting up even though i run the latest and greatest version 1909.

I am now using the pad connected locally to my remote pc and so far so good. i wish to have the same behavior when pad is connected near the laser. one day I will purchase a small PC near my laser but it’s not the best time to spend money on less important things (hobbyist K40 at home)

Of course, that makes sense, thanks!

Ah okay, i don’t know about that laser USB hub. Good luck figuring out the last parts! Isn’t it a possibility to run a long USB extension cable from your pc to the laser?

I have one single 10m active USB extension cable between my PC and laser. i wish i could add another one but i need to drill more holes through concrete for it and i am tired just thinking of going through this mess again.

Just use a USB hub?