G-code motion target exceeds machine travel on Ortur Laser Master 2 Pro

Hi All, First some background so you get the full picture: I’ve only had my laser for just over a week and it’s been working fine. That was until I attempted to try out the YRR rotary unit! I followed @richfaraone 's video on setting it up but hit a bit of a wall as the machine wouldn’t move until it was homed, anyway it’s probably something I missed out so I’ll go back to it later. I decided to remove the rotary and go back to standard config so I went to load the original settings that I’d saved (as per Rich’s instructions) but the file I’d saved wasn’t there! I’m not sure what happened but somehow it hadn’t been saved (I’ve been using/programming computers since the early '80s so it wasn’t a newbie error!). So I just reversed what I’d changed.

My issue is that I’m now getting the “G-code motion target exceeds…” error and I can’t see why. I can jog the laser head around the workspace using the jog buttons in LightBurn but if I try to use “Frame” or run a job it just errors out. I’ve attached some screenshots along with a console log and NC file to help diagnose the issue. You’ll notice that the current pos’n shown on the main screen is showing negative X and Y which definitely doesn’t look right to me (I also used to be a CNC programmer/setter/operator so I’m familiar with CNC terminology etc.). It’s as if it thinks the top right is the origin, which it obviously shouldn’t be. Hopefully someone will be able to spot what’s wrong and will be kind enough to help me out. I’ve scoured the forum and this error seems to be a recurring issue for various reasons.

If you need any more info just let me know.





LightBurn Console log.txt (1.5 KB)
exceed limits.nc.txt (375 Bytes)

Many thanks.

Your PWM frequency is wrong. $33 should = 1000, but that’s not the problem. You have to clear the error.
Go to the Laser tab and RIGHT click on the DEVICES button.
Now MANUALLY move the laser and the gantry to the bottom left corner of your Ortur, the home position.
Go to the MOVE tab → Get Position
It should now say 0.00 x 0.00
Go to the LASER tab and click HOME.

1 Like

Hi Rich, thanks very much for your quick reply. I would’ve replied earlier but I was busy cooking dinner when your reply came through!
I’ve checked the PWM frequency and it’s already set to 1000 Hz, which agrees with the screenshot I uploaded, so maybe you were looking at something else :wink:
Ok, this is what I did:

Plugged in the USB to laptop.
Powered up the OLM2Pro.
Machine automatically ‘Homes’ to bottom left (as it should).
Fire-up LightBurn (connects on COM3).
Re-homes (it’s set to home on connect).
Jogged machine to top-right of workspace.
Manually moved laser head back to bottom left (then move it away so the microswitches just open).
Click ‘Get Position’. Coordinates say 0,0.
Click the ‘Home’ button. Machine rehomes.
Coordinates still say -397,-397.

I’ve also tried right-clicking the DEVICES button and running through the procedure but there’s no change I’m afraid . It still thinks the origin is in the top right. If I click the ‘Go To Origin’ button it moves up to the top right.
Is there anything else I can try?
Love your videos btw

I’m a complete noob, but I had a problem similar too yours on a different machine (3018 Pro) and I now have an OLM2 Pro, which I have yet to set up. My problem was offsets, and I’m going to quote Oz from another post in case it might apply:

" Type this command “$#” in the console to see your workspace offset values (and press enter)

You should see a few lines, with the first (G54) having values other than zero. If you type this line in the console and press enter, it will clear the offset:

G10 L2 P1 X0 Y0

That assigns an offset of X0 Y0 to the primary workspace coordinate (G54). Using the “$#” command again should show it zeroed out, and the ‘Get Positions’ button should report correctly after that."

My machine was always reading negative numbers when I moved it to the front left (it homes back right) and it would never work right until I cleared out the offsets. As I said, our problems seem to sound similar and it wouldn’t hurt to at least to have a look at G54. If it reports back all zero’s then there are no offsets, then never mind.

As I said, the post from Oz was to someone who was having problems with set position not working so it may or may not apply to your issue.

Thanks very much for your help, unfortunately G54 etc. are all set to 0,0 so it doesn’t seem to be a work offset issue.

Here a copy of what’s returned by the “$#” command:

$#
[G54:0.000,0.000,0.000]
[G55:0.000,0.000,0.000]
[G56:0.000,0.000,0.000]
[G57:0.000,0.000,0.000]
[G58:0.000,0.000,0.000]
[G59:0.000,0.000,0.000]
[G59.1:0.000,0.000,0.000]
[G59.2:0.000,0.000,0.000]
[G59.3:0.000,0.000,0.000]
[G28:0.000,0.000,0.000]
[G30:0.000,0.000,0.000]
[G59.6:0.000,0.000,0.000]
[G92:0.000,0.000,0.000]
[HOME:-397.000,-397.000,0.000:3]
[TLO:0.000]
[PRB:0.000,0.000,0.000:0]
ok

You can also see that the HOME position is set to -397,-397. I’ve found a workaround for now but I would like to get it working properly.

Type $RST=* in console to clear the -397 -397

I am not sure how that offset could have been set
Did you by any chance use the wizard and installed the ortur originally as a x-carve of shapeoko instead of GRBL?

Well done, that was it!!! :grinning:
I didn’t use the wizard so I set it up manually as I didn’t have the machine at the time. When I plugged it in it just worked. I did then attempt to use the wizard but it wouldn’t detect the machine for some reason. Anyway, it was working just fine until I tried to set up the YRR rotary axis (just to make sure it worked). That’s when it all went pear-shaped!
BTW, I’m assuming you’re the same ‘Gil’ that helped me out with my faulty offline controller the other day?

Thanks for your help once again.

Correct!
need to figure out where that home offset comes from though not the 1st user with the issue
Cant imagine what procedure would add it in.

Last question if i may
“ORTUR LASER MASTER 2 PRO
OLF 1.xx”
AS welcome message when you connet
Can you tell me your OLF 1.xx reading on your machine when you have a chance?

It’s interesting that I’m not the first user to encounter the issue. That kind of problem can be very difficult to track down.
Of course, here’s the welcome message in full:

[ORIGIN: China] [PRODUCER: ORTUR] [AUTHOR: ORTUR] [MODEL: Ortur Laser Master 2 Pro] [OLF: 170] [DATE:19:08:08 - Jul 12 2021] [VER:1.1f(ESP32).20210403:] [OPT:VNMSLW,15,1024,3] Target buffer size found

1 Like

Been fighting for two days trying to figure out my issue… which was the -397 -397 Using you $RST=* resolved my issues…

1 Like