GRBL factory settings of AtomStack A5/30W Laser Engraver

Recently I bought the A5/30W laser engraver and ran some first tests. LightBurn recognized the machine and set the working space correctly. Everything went fine.
It’s the newer model with the red eye protection case and a power switch.

Then there was this time of the year the annoying daylight saving time ended and I decided to fire up Arduino IDE to set my little Arduino Uno powered digital clock. To my surprise the sketch didn’t work so I tried to debug it and uploaded it several times. After some time pulling my hair and looking around my eyes fell on the USB plug of the laser engraver. It hit me what I have done: I downgraded the laser to a non-functional and rather expensive digital clock. The controller was going to try to read from a non-existent RTC clock and update a non-existent LCD panel.
I contacted the manufacturer but haven’t got a reply yet.

To make a long story short I had to flash the GRBL again because I would rather use the new hardware as intended.
Now It’s recognized again but of course the factory settings of the controller are all gone. Could some nice soul please post the settings so I can try to replicate what it should have been before I killed it?

Thanks in advance.

Can you restore your old controller, read and save the configuration information? Then write it back to the new controller…

Might be easier to get a copy of the original configuration and reload the old controller to get the data you need.

Of course, you ALWAYS make a copy of your configuration data.


The Gcode output from the console?

The controller (the brick attached to the machine with one end being the USB socket and the other the connections to the steppers) cannot be restored. I opened the case and although it doesn’t look like it it seems to be an Arduino Uno compatible and that’s why it happily accepted the compiled sketch that was meant to go to a usual Uno board.
As I was just starting to play around with the engraver and the software I haven’t really thought of backing up what I assumed was more or less hard-coded parameters from the firmware.

After flashing the GRBL the scaling and the acceleration of the motors are off so I think what I need is a copy of the machine settings of an A5 (Edit → Machine Settings in LightBurn).

There are also the device settings but that still looks OK to me so I assume these are parameters LightBurn stored when I added the machine.

I’m making lots of assumptions here and I’m new to LightBurn and laser engraver in general so I may be wrong but it feels like the right track.

EDIT: I just double checked the GRBL wiki (Grbl v1.1 Configuration · gnea/grbl Wiki · GitHub) and the names and parameter indexes in the machine settings including the section “Outputs setup” and yeah, I’m positive that’s what I need.

1 Like

Give me a few minutes and I’ll post them for you. It’s the A5 “Pro” but I don’t think it matters much. The gantry is the same just the power is different.

AtomStack.lbset (5.4 KB)


Yay! You’re my hero. :slight_smile:

Just burned a test “blah” and it looks like before regarding the speed, acceleration and placement.

Thank you so much.

1 Like

They’ll be the stock settings because when you power off an AtomStack it resets to factory settings.

Don’t forget to put that config file somewhere, just in case :crazy_face:



I read about it. Atomstack may use a different method but I switched my A5 off and disconnected the USB cable then attached it again and powered it on and the scaling and positioning is still correct.
Thinking about it it makes sense as I “upgraded” the firmware by mistake and the machine is running a stock GRBL 1.1h now.

1 Like

Oh yeah, I’ll copy it all over the places here :slight_smile:

1 Like

On the plus side I can confirm that you can flash a recent GRBL on an Atomstack A5 and with the correct settings it will work just fine (as far as I can see).

1 Like

One of the devs here examined one here pretty extensively and you can only write to the board X number of times.

Mine walks like an Uno, quacks like an Uno so x >= 100000 ?!?

1 Like

Hy, I have a question : @LaserWillie , when you say that “They’ll be the stock settings because when you power off an AtomStack it resets to factory settings.” : Do you known how to change that ?..
I would like change preset ($21=1 / $22=1 / $23=7) to activate homing but when I powered off, all presets are canceled !.. Help !!!
I’ve download you file AtomStack.lbset (5.4 KB) but I don’t know how use it in lightburn ?..
Thanks (I’m new here and I’ve buy my licence now !)
PS : I have an A5 Pro model… with Atomstack “LaserBox V 1.0” inside…

I don’t think you can change it. Most models will reset once powered off. You’d have to flash the motherboard to stock GRBL and then take it from there. I don’t know about the newer X7 but I’m sure the company went cheap on those motherboards too.

You don’t need to, that’s for an AtomStack machine that lost it’s settings. That’s all that file is.

That’s true. I needed that to get mine working again after accidentally erasing the complete firmware. But as that worked fine I thought about that and I see no reason why it shouldn’t work to change the default settings and flash that image.
There is no way I’m aware of that would only change the settings but keep the firmware. I’m pretty sure that’s not trivial and unsupported.
I have a rough idea how Atomstack went the way it is but take that with a grain of salt as I don’t have access to the source they use. Mine came with GRBL 1.1f and in the console there was a warning that reading from the EEPROM failed. With the stock GRBL 1.1h there is no such warning and my machine kept the settings I wrote once using LightBurn’s machine settings function. I think they deliberately let it fail so that each power cycle will result in factory settings. My guess is that they do that to make the support easier (in the sense of: telling the customer to switch the machine off and on again and you can rule out corrupt settings).
My unplanned tests have shown that you should be able to do the change you want although in an unsupported manner and I don’t know what would happen in regards to warranty if you change the firmware with something you cooked yourself.

1 Like

A post was split to a new topic: AtomStack Error 9 - coordinate system