Has anyone noticed problems with "User Origin" setting in the latest version of LB?

I have been using LB for a long time and I have had no issues with it until I updated to 0.9.24.

Just recently, after the very 0.9.24, I cannot set and use the “User Origin” for my projects.
I even uninstalled and re-installed LB from scratch but have no luck to resolve the issue. This is what happens:

1- I restart my X-Carve and my JTech controllers.
2- I start LightBurn and home my machine
3- I draw a very simple 1x1 inch box.
4- select “User Origin” and choose center as a starting point.

  • I manually move the laser to the middle of the board,
    4a- Under the “Move” tab, I push “Clear Origin” and then “Set Origin”.

4- At this point, I can click on the “Frame” button and see the frame fine. It goes around the 1x1 perfectly fine.

Here is where the problem starts:
5- If I move the laser to anywhere else and click on “Go to Origin” button under the “Move” tab, my laser starts coming all the way to the lower left (home) of my laser machine.
6- If I click on the “Start” button, first it gives me the usual “it might be out of bound” warning and then moves towards the home, lower left corner of my machine.

This did not use to happen the last time that I used my machine before the last updates.

I would appreciate if someone would share his/her experience or guidance how to fix this.

Thank you,

  • Power the laser
  • Home it
  • Run the “Use Laser” macro (sets $10=0, G10 L2 P1 X-750 Y-750, or whatever is appropriate for your bed size, and $32=1)

From there, your normal process should work exactly as described. LightBurn should have automatically set up the ‘use laser’ macro for you when you first set up the X-Carve.

1 Like

You are correct. I missed typing that step in here.

I got that button when I originally added my XCarve controller as a new device. I always started LightBurn with or without using that button and everything was working fine… Now, even that is not working.

I noticed that the “Exact location” would work (better, without going back to home) but would still give me the out of bound error.

Thanks again for your suggestion though.

Where/How can I download the previous version of LB ( I am currently using 0.9.24) to test if my current issues with the “User Origin” setting were not introduced by the latest update? Once again, I was using my machine without any of the issues that I listed above prior to the last update.

Thanks again for your help and suggestions. This is one of the best forums that I have ever been a part of.


All older versions are available through a link at the bottom of our download page here:

Very nice to hear you are enjoying our efforts. Thank you. :slight_smile:

As a friendly,…

Thanks again to everyone who responded. Instead of trying to explain the issue in a ticket, I decided to record the problem, step by step. If you would, please take a quick look at this problem and share your ideas what might have caused it and how I could possibly resolve it. Once again, I have not installed anything new on my machine and have not made any changes except updating my LightBurn software to the latest version.

Thank you

This is a good place to help in understanding the different ‘Start From’ options: Coordinates and Job Origin - LightBurn Software Documentation

Have a review, and let us know how you progress. :slight_smile:


With all due respect, did you even review the video clip? Did you see what the problem was? I have been using my CNC X-Carve and V-Carve software for years and I do know the difference between the “Starting point” options. I can set my origins fine. I can bring the laser head to the right “User Starting” point. LightBurn would even show me the exact frames. Why would it go all the way to home (lower left) when I click on the “Start” button?


Does this mean that the machine wasn’t homed? I see in the video that you did home, but it would be worth checking, as it looks like your system is homing to the front-left instead of rear-right, which is not what I expect for these.

Can you click ‘Save GCode’, save it to a txt file, and attach that file here?

Also, can you click the ‘Get Positions’ button in the move window? What does it report when you are near the middle of the table like you were?

I always move home and then hit goto origin to validate it knows where the origin is and it’s what I expect. I didn’t see you validate the origin was stored either. I know you clicked the buttons to store it but validating that the software and firmware are working together is probably helpful.

I did, and wanted to start with some basics first, as I have found this can be the simplest of misunderstanding. It happens quite often for folks coming from a CNC configuration. Did not mean any offense. Yes, I watched your video and have been in search for further possibilities ever sense, but how would you know this. :wink:

Oz is helping so we are in good hands.

I have been setting “start from” to “user origin” and it seems to work for me, i can move to any point in my work surface and delete and set origins and a go to origin command always brings me to the bottom left corner in my case of where ever i set that point. I have also picked the bottom left corner in the grid below the start from option.

So it does not go back to the point you set the origin to but instead some corner of some box or something other than the coordinate point(X,Y)? Seems unusual but there are some settings in these firmwares which have offsets/etc which might effect your origin setting. In GRBL there’s a command to see those settings/defaults.

I may have not been clear in my description, it always goes back to the origin i set. Right now i am testing a burn, my auto home sets the machine at 0,0 which is front left corner, i jogged the machine to 275,50 and set a new origin, set start from to user origin and it always goes back to 275,50 when ever i tell it to go to origin at least until i clear that origin and set a new one. I do have #define HOMING_FORCE_SET_ORIGIN turned on in my firmware, so my machine does not go into negative space when i home it.

You are correct. I reset my origin and I set the new origin. LightBurn will correctly show the frame around my origin BUT when I click on “Start”, it will come to the lower-left (my home) instead of actually starting the project. Also, if I move my laser from that new origin that I set to anywhere else, it would not go back to it when I click on “Go to Origin”. Instead, again, it goes back to my home, lower left. And just to note, I do home my machine when I start and I do click on the “Use Laser” to set the plane correctly.

Your machine is doing exactly as it is supposed to do and that is also how mine was doing until recently. I am just trying to understand what has changed any setting in my machine that is acting like this. Do you also have an X-Carve? Where would I be able to see that firmware setting that you mentioned? Thank you for your help and suggestions.

My Ortur diode laser has it’s home limit switches in the front left corner and your setting of G10 L2 P1 X-790 Y=-790 seems strange to my unskilled mind. LB user origin stuff just seems to work fine and as expected with my Ortur setup.

With homing switches, do you have home switches( my CNC does not but I’m not using LightBurn with that machine ) you shouldn’t see negative positions when homing.

I’m going to back out since Oz and Rick are far more knowledgeable in this area than I.

I am not entirely sure but i believe that command may be remapping the unit from negative space to positive, i know it can be done in commands instead of in the firmware.

I compiled my firmware under Arduino IDE 1.8.2 the grbl download goes into the library folder. If you go to that folder you will find config.h as well as all the other files.