Help with trouble shooting X axis issue

Hello everyone. I got a lot of useful info from here of the past few months building my laser but, I can’t seem to find enough info to fix my problem so I made an account. Hi!

Here is my problem If I draw a line (half circle) then do something that changes directions rapidly and go back to draw a line that lines up (other half of the circle) it is off on the x axis by the thickness of the beam.
If I draw the half circle and them right after draw the other half of it with out doing something that changes direction in between it lines up. I’ll try to attach in image that I hope will help.

Here is what I’ve tried so far.
Ruida RDC445G

  • Decrease acc all the way down to 100

  • Swap the PMW rising edge v from no to yes

Hardware

  • Replaced the Driver (DM542)

  • Tested for binding or stick spots on the axis

  • Replaced the wires and motors (both of them of this axis)

  • Replaced the belts (both of them on this axis)

  • Tried belt tensions to loose too tight and just right.

Light Burn

  • Checked the “reduce direct changes” in the optimization setting.

Between each change I tested the same file. Nothing ever changed. I can’t think of anywhere to go from here. Any suggestion are appreciated.

You have mechanical problems. Fix those and your software will work correctly.

You have first to ckeck if you miss steps, or if it’s a mechanical problem.

It you’re missing steps, verify if there’s enought current on the steppers.

More current than nominal is useless since it will only produce heat on motors, not mechanical power.

Are your motors properly sized? Dont forgot steppers torque ratio fall down when you’ll go beyond a certain speed. Are u sure to use them properly (see curves!!!). If you’re overspeed you motors, your torque will fall down, and you’ll miss steps… Try to reduce speed to stay in max torque domain (see curve again!).

And other idea would be to check belt tension. Your belts should produce a low-pitched sound. When using high speed / acceleration, if belts are too loose, you could see that… Check also all all transmission elements are properly tighten (specially pulleys). If there’s a tension mechanism, check if not too light…

Yours
JPC

1 Like

You can enable the ‘Hide Backlash’ option in the optimization settings, and that will help, but you should reduce it mechanically as much as possible first.

How would one know the difference between mechincal problems or missing steps?

I’ll try the hide backlash option if nothing else it might be a good short term solution

To diagnose missing steps, try to move with G0 X 1000 F24000 then G0 X 0 F100 many times. If you don’t return at the origi at each iteration, then you’re missing steps…

That won’t be an option with a Ruida controller, but it would be easy enough to mimic the motion using the ‘Click to Position’ feature in LightBurn.

Sorry, i forgot this is a Ruida controller…

Thank you all of your help. Sorry for not replying more quickly its been a busy week.

OK I was unable to find “click to position” in light burn. What I did do was unplug the laser and ran a 30 minute job with lots of little parts. EVERY time I run this the device shows an error of “hard limit reached” when it goes home.

Recently I’ve tried loosing up the rollers to where they are barely touching the rails, tightening the belts again and giving each of the steppers its own driver.

I’m using these steppers


and these drivers
https://www.automationdirect.com/adc/shopping/catalog/motion_control/stepper_systems/stepper_drives/dm542e?gclid=CjwKCAiAzNj9BRBDEiwAPsL0dymX6IXiiIKZXoASvDoghun7TDACihoz5b8xZD16_R1cqW8kkz0MSBoCCK4QAvD_BwE

I’m currently running them with 24 volts at 2,84 amps and 6400 pluses per rev.

image

If you don’t have enough ‘back off’ set for your home / zero position, it’s possible that returning to the origin after the cut is tripping the limit switches again, and that could be all this is. The system will move the laser head toward the switches until they activate, then back-off from them until they deactivate. If that distance isn’t large enough, and you have hard limits enabled, you could trip the sensors just by going back to zero.

Right in front of my face… No wounder I couldn’t find it. :grin:

I’m new to lasers and still have a lot to learn. So I’m not saying the back off is not an issue however when I run a small simple job I don’t get an error and I do when I run 30 min job. Also, during the 30 min job I can see it shifting more and more off as time goes on.

If the laser is shifting over a long job then you most likely have your acceleration set too high, or you’re running vector shapes too quickly and the resonance is causing the steppers to skip (which can also be helped by lower acceleration).

Oz thank you for your continued support. I have never dealt with something so frustrating.

Today, I took your earlier advice and set the origin a good 20mm away from the end stop. Then I dismantled the entire system. I currently running the y axis (works good) on its single stepper and only one of the X axis steppers. I tapped a zip tie to it and ran my 30 min job. It does not point the same direction as it started. I think i can safely say its not a mechanical issue.

I read you post and adjusted my acceleration to 100 from 1000. I’m running the 30min job again. I’ll let you know what happens.

It’s possible that you are using the wrong ‘side’ of the step pulse. I can’t say for certain that this is the issue, but it could be: How do I fix skewed or slanted engraving?

The lower accerlation did not change anything. I’ll try the step pluse but I don’t think that’s it. It’s one of the first things I tried. However I was using different steppers at the time.

That wouldn’t be the steppers, but the driver. I saw that you had checked that. Try exchanging the X & Y axis drivers. If the problem moves to the Y axis, that would point at the driver itself being the issue.

1 Like

well it work. I turned down the amperage on the stepper drivers and things starting cutting straight. What I’m not sure of is, where the stepper just getting hot and losing steps or was my power supply not keeping up. I have a 6.5 amp power supply so that seems unlikely but, I was pretty sure the amperage i was using was appropriate for my steppers. I’m going to replace the power supply with a new 10 amp version just to be on the safe side. Right now i’m just happy to be burning again.

Appreciate the help. Thank you!

Steppers “bounce” when they take single steps, and if the supply current is too high, it can actually make resonance worse, not better, particularly if the stepper isn’t damped with enough weight. It’s not impossible that the current was just set too high for the X axis, though that is pretty rare.