How to send job to SDcard?

I can’t believe this is even a question - but as I have no ability to connect via USB. And although my laser has wifi connectivity, light burn can’t seem to connect with its bridge system.

I just need to send the print file (or whatever is the customary name for laser files) to an SDcard so the laser can ‘play’ the file. I assume it will be a gcode file.

Laser is a 20w elegoo phecda

I’ve seen references to putting LB into advanced mode before a ‘save to card’ option appears. Prefs don’t have that (in latest version), but do show ‘beginner’ mode disabled.

Any help would be much appreciated.

And ya…. I’ve watched hours of ‘official’ videos on LB and searched in vain with google.

:slight_smile: :slightly_smiling_face:

Of note, the proprietary app works but is too limited to be of much use.

Elegoo is a GRBL controlled machine right?

Normally - the SEND file to a machine - are features of the Ruida controllers.

GRBL controllers tend to just receive the Stream directly off Lightburn.

That I know of - there is not a GRBL controller that accepts file transfers into their SD card.

Any particular reason why you need to send files to SD card instead of stream direct?

There is no way to connect our computers directly as they are in another area to where the elegoo laser is.

The documentation claims to be able use gcode files among others. There is SD card reader for doing that. I’ll follow up with what other file types it can read.

There is also wifi which would theoretically work (not that Light Bridge seems to recognize it, even though a browser window can be opened on the LAN with some limited functionality.

The LightBridge software does say it can produce gcode with one of the three versions.

Do you know how to output a laser file to a card/volume?

To follow up @gilaraujo :

file types that our laser can use are “.nc”, “.gc”, and “.gcode”.

I believe (newby here) that LB can output .nc files. If only I could figure out how to do that…

And thank you for your reply :slight_smile:

Gcode is really a text file with a different extension.
If your firmware is nice - it should accept all of those formats.

I would break it in 3 parts, not being sure what level of compatibility your laser has (Will figure out in between :slight_smile: )

“The manual way”
Typically, how 3d printers used to work.
Bring SD to computer
Plug SD to computer
In Light Burn Prepare your design.
Instead of click “Start” click Save Gcode button instead
(Might require be outside beginner mode - EDIT > Settings)

Note: Your Elegoo profile must be correctly set up as well as the coordinates as they get hard coded in the generated code.

“The WebUi way”
I am not certain if Elegoo has this, but It would be nice if it did.
Many times laser engravers claim WIFI capability, but this does not extend to full serial over wifi. Meaning, they connect to your wifi but Lightburn cannot connect to the laser and - importantly - stream to it.

However, this gives the ability to connect to the machine webui - which is normally a local website that you can use to upload the Gcode files to.
This bypasses the Sd card method and is way more convenient.

“Serial over Wifi” way.
IF available, this would be the ideal method with caveats.
If your port 23 is open on the machine and Firmware allows it and is compatible you can create a GRBL device with network connection instead of USB.
This should give you full control - remotely - of your laser and ability to stream data to it.
Caveat here being: as you are not near the laser this procedure of starting the laser from your desk would go against all we preach. NEVER ever leave your laser unattended. Never, Ever, EVER!



This being the app they refer for android only

Latest Firmware seems to be 21st March 2024 - Might want to check that.

So I think - but can be corrected - you are on Mode 1 of operation
SD Card mode

I have not been able to find any ‘save Gcode’ button. In settings I could only find ‘beginner mode’ which seems deselected as default. But I did try both positions.

I really appreciate your help! Thank you again.

I will pursue the wifi options as well - but totally agree with ‘being there’. Which puts us back to using SD card…

You might need to create your profile - they do document it well here:

Also, I would go through the Download section

They seem to have a few test files you can just plop in the SD card maybe?

1 Like

I will do as you suggest and report back.



1 Like

Although I appreciate it, those weren’t helpful.

One lists Elegoo firmware.

The other goes over how to make a profile using a USB connection. Which is part of the problem.

LB suggested making a ‘manual’ profile if you can’t use USB, which I did. That allows one to make and edit files to print. But LB still won’t give a way to send to a card to print. I also was able to add to the library for various material settings. So I do have a profile as you suggested. All other aspects of LB seems accessible and works well. I just can’t output it.



This is a requirement though so Lightburn knows what laser you are designing from - regardless if you are connected or not.

With the Elegoo profile selected, can you take a full screen of your LIghtBurn please
with a project open even if its a box?

You should see something like this:
Important the “start From” - Make sure is set to Absolute Coordinates.

The Save Gcode is the button you SHOULD see

Will do - on mobile right now. Will go back to LB computer for screenshots…

I did download and use the wifi app for Elegoo - but it’s not very useful. No where near what LB has to offer.

You have here some more settings to easy your setup.

Now I´m going to sleep.


@gilaraujo screenshots as requested

Thank you @parsec !

I did find that post earlier today and did add the material list to my library for the manual laser profile I set up.

It is useful for settings! But sadly doesn’t help without a way to get the files onto an SDCard.

Thanks again! And sleep well :sleeping:


Interesting… Seems you’re using the materials test, which has no gcode output that you can save…

I think this is because the actual device hasn’t been defined…


To be clear @jkwilborn I have tried with several different project files. Not just the material test.

Some text. Photos. Graphic elements.

I still can’t find a gcode button to output file to an SDcard for engraving/cutting.

Here’s one of my grbl lasers configured but not on-line. There is a save gcode button…


Looking at your photo, I’d have to conclude the laser isn’t setup properly. I see no buttons at all in your photo of the laser window … it can’t populate the correct buttons without knowing the type of machine.

Same for the laser tools → materials test.


I’d suggest you double check the setup of that machine… worst case you should get some buttons in the laser window.