I can't get my computer to recognise my laser

Hello, I have a 1060 laser with Ruida, I use LightBurn 1.0.06 in a MacBook Pro running BigSur; I have the DSP license and everything but when I plug the laser to my computer it just won’t recognize it, I tried making it manually but nothing. My brother has a laptop with windows and has the trial version of LightBurn and in that laptop I was able to connect it, it didn’t recognized it either but when I did it manually it worked. I tried exporting the file to my computer and even though I did it successfully it still doesn’t want to recognize that the laser is plugged

You likely didn’t install the USB Driver for the Ruida controller. Re-run the LightBurn installer, and on the last screen, there is a checkbox to install the FTDI Driver. Click that checkbox, and it will run the installer for the driver.

I tried but there aren’t any screens; once I run the installer it just opens LightBurn and asks me to add a new laser. No checkbox, nothing :confused: I don’t know how to install them.Do I have to have the drivers installed separately? I looked other people’s problems and stuff and I’m quite confused right now.

Make sure you are re-running the original install executable (LightBurn-v.1.0.06.exe) The last screen of the install is this one. You need to check the box to install the FTDI driver. If you’re not seeing this screen, you’re not re-running the install.


Yes I am… But MacOs is not like windows, I even uninstalled it completely and installed it again

Ah, I didn’t catch that you were running Mac. There are a lot of issues with USB on Mac. There is a lot of info in this thread: Macbook doesn't recognize my ruida machine - #19 by LightBurn

In the end, it might behoove you to switch to Ethernet. It’s way more stable, and a lot faster in the end. USB and Mac have had issues for a long time. (Mac issues, not LightBurn caused)

Haha, no problem, thank you very much I think this will help me

Yeah… So… I ended giving up xD. I changed to windows :smiling_face_with_tear: And it works perfectly, just one little question where the heck is the button to distribute obects in the space? I only see the button to align them

You have 2 ways of doing this:

It only let me do the “move h together” and “move v together” the other options doesn’t appear

Do you have 3 or more objects selected? If not, those actions are not applicable.

If you’re still having a problem send a screenshot of your setup.

Also as you can see it doesn’t appear in the tool bar

That’s odd. It’s behaving as if you’re in Beginner mode but I don’t see any indication of that in your screenshot.

Go to Edit->Settings. Disable Beginner Mode if currently set. If not set now, try setting it once and then unsetting it.

Not sure why else you wouldn’t get those options.

Yeah, it looks like the begginer mode was activated, I didn’t even know it has one. Now everything is where it was on my other computer. Thank you very much

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.