I cant seem to change my G92 setting

I want to set my G92 to X0 Y0 but the software will not take it.
I keep getting error messages.
What am I doing wrong?

I get the sense you’re describing an attempted fix to a problem you’re having but not having the outcome you desire.

Can you start by describing the core problem, what you’ve tried to resolve it, and what complications are preventing you from doing so?

The problem that I’m having is the machine will not go to the set X0Y0 origin.
If I run a program all the way through, everything is fine. (it goes back to the X0Y0 position)
However, if I stop a program part of the way through and click the “go to origin” The machine go to a spot ~.880" positive in Y and .1" positive in X
This corresponds to the feedback I get from the console when I enter $#

Can you home and then run this in Console and return output:


I did not install the homing switches.
I never use homing.
I always set an X Y zero origin and work from there.
All I want to do is change the G92 line to read all zeros.

How are you doing this?

Also, G92 offsets typically do not survive a power cycle from what I remember. Are you doing something to enable this?

In any case push “go to origin” then run ? command in Console. Return results please.

I bought this machine to do tiles.
I use a fixture to hold them.
The first picture is where I set the origin.
The second picture is where the machine goes when I press “go to origin”

screen shot

Was that the entirety of the output? Looks like something is clipped on the right.

Sorry about that.
screen shot

Thanks. I was hoping for something more there. I’m curious why your position is off from G92 by .001 on X and Y each.

Try this.

Enter these commands into Console:

G0 X0.0828Y0.8185
G92 X0,0828Y0.8185

What do you get back?

Can I do that while the machine is running?
I’m currently running a test tile.

You probably don’t want to. I think technically you might be able to slip the commands in between the streamed commands but not much value in that.

Plus I don’t think you’d want to shift the offset from under the middle of the job.

screen shot

By the way,
I appreciate all your efforts.

1 Like

Glad to help. Although that last screenshot has me a bit confused.

Let’s try again. Can you try this:

G0 X0.0828Y0.8220
G92 X0.0828Y0.8220

screen shot

I’m not following what’s happening.

Can you run this and return results?

G0 X0.0828Y0.8220

screen shot

When I entered that command, the machine moved in the Y positive direction.

If you run the G0 command multiple times does the laser head continue to move with each command?